X
Tap here to go to the mobile version of the site.

Support Forum

The cookie Exceptions.... tab does not work. If I do not check "accept cookies from sites", making an exception to allow does not work. Worked till this week

Posted

Until this week I easily handled my cookie preferences by NOT checking the "except cookies from sites" option. I then made exceptions to this default with the exceptions tab or through a cookie manager add-on. Since the last recent Firefox update, this no longer works. Nothing in cookie exceptions does anything. In addition to not letting me allow cookies, it will also not let me block cookies when I do check the "except cookies from sites" option. The Cookie Exceptions Do Nothing. I will appreciate any real help.

Until this week I easily handled my cookie preferences by NOT checking the "except cookies from sites" option. I then made exceptions to this default with the exceptions tab or through a cookie manager add-on. Since the last recent Firefox update, this no longer works. Nothing in cookie exceptions does anything. In addition to not letting me allow cookies, it will also not let me block cookies when I do check the "except cookies from sites" option. The Cookie Exceptions Do Nothing. I will appreciate any real help.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Shockwave Flash 19.0 r0
  • Shockwave Flash 16.0 r0
  • 5.1.40728.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Select All of the tests. Then press Execute on the bottom.


You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.

'''[https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance]''' {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the '''Options''' button. Select All of the tests. Then press '''Execute''' on the bottom. ---------- You may have a corrupt '''cookies.sqlite''' file. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''cookies.sqlite''' file. Then rename or delete it. Restart Firefox.

Question owner

For some reason, cookie exceptions are now working. I did not do anything. Whatever changed, happened on its own. Thanks for thinking about it. if problem returns, will try suggestions.

For some reason, cookie exceptions are now working. I did not do anything. Whatever changed, happened on its own. Thanks for thinking about it. if problem returns, will try suggestions.

Question owner

Unfortunately, today my cookie exceptions are once again not working. I changed nothing. But after determining what was going on, I rebooted computer. No change. I deleted the cookies.sqlite file and restarted firefox...... No Change. So the problem does not seem to be a corrupt cookie.sqlite file. I will greatly appreciate any other ideas or suggestions.

Unfortunately, today my cookie exceptions are once again not working. I changed nothing. But after determining what was going on, I rebooted computer. No change. I deleted the cookies.sqlite file and restarted firefox...... No Change. So the problem does not seem to be a corrupt cookie.sqlite file. I will greatly appreciate any other ideas or suggestions.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Most exceptions are stored in permissions.sqlite, so you can check for issues with this file.

Do you use any extensions that deal with exceptions?

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Most exceptions are stored in permissions.sqlite, so you can check for issues with this file. Do you use any extensions that deal with exceptions? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

This morning cookie exceptions where working briefly after again not changing anything new. I restarted firefox as a test and cookie exceptions do not work. I deleted permissions.sqlite file and restarted. Still does not work. Started in safe mode with all add-ons disabled. Still does not work. I will greatly appreciate additional ideas. Thanks very much.

This morning cookie exceptions where working briefly after again not changing anything new. I restarted firefox as a test and cookie exceptions do not work. I deleted permissions.sqlite file and restarted. Still does not work. Started in safe mode with all add-ons disabled. Still does not work. I will greatly appreciate additional ideas. Thanks very much.

Helpful Reply

I have suspected that the most recent update to firefox 42 is the problem. I downloaded firefox 41.0.2 and cookie exceptions work fine! Then I allowed firefox to update to version 42 and cookie exceptions stopped working. I reloaded 41.0.2 and cookie exceptions work again. It is hard to see how this is not related to the firefox 42 update which is where this problem started. So now I am hoping I can keep my firefox up-to-date and working as intended. All help is appreciated.

I have suspected that the most recent update to firefox 42 is the problem. I downloaded firefox 41.0.2 and cookie exceptions work fine! Then I allowed firefox to update to version 42 and cookie exceptions stopped working. I reloaded 41.0.2 and cookie exceptions work again. It is hard to see how this is not related to the firefox 42 update which is where this problem started. So now I am hoping I can keep my firefox up-to-date and working as intended. All help is appreciated.
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Strange, but good to know. I've called the big guys to help you. Good luck.

Strange, but good to know. I've called the big guys to help you. Good luck.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode"
CoolBlue 0 solutions 8 answers

My exceptions to no-cookies stopped working this week also.

I have tried safe-mode, refresh, and a complete uninstall / re-install with all firefox files deleted and still the problem persists.

I can only access cookie-requiring sites by accepting all cookies. The minute i disallow cookies, i get bounced out of certain logins, and i cannot sign into sites like amazon. even to they are on my whitelist it tells me to enable cookies in order to log in.

this is a completely new problem. Never experienced it before.

exceptions made before this week still worked. but new exceptions no longer worked. Unfortunately, by doing a refresh and then uninstall / etc now all my previously set exceptions are gone, so i have two choices - accept all cookies or accept none.

Any help would be gratefully appreciated!

My exceptions to no-cookies stopped working this week also. I have tried safe-mode, refresh, and a complete uninstall / re-install with all firefox files deleted and still the problem persists. I can only access cookie-requiring sites by accepting all cookies. The minute i disallow cookies, i get bounced out of certain logins, and i cannot sign into sites like amazon. even to they are on my whitelist it tells me to enable cookies in order to log in. this is a completely new problem. Never experienced it before. exceptions made before this week still worked. but new exceptions no longer worked. Unfortunately, by doing a refresh and then uninstall / etc now all my previously set exceptions are gone, so i have two choices - accept all cookies or accept none. Any help would be gratefully appreciated!
CoolBlue 0 solutions 8 answers

Update: I reloaded the 41.0.2 version and cookies exceptions now work.

Since this is what happened to the original question owner, that seems to validate this is a problem with the latest FireFox upgrade.

please help!

Update: I reloaded the 41.0.2 version and cookies exceptions now work. Since this is what happened to the original question owner, that seems to validate '''this is a problem with the latest FireFox upgrade. '''please help!
CoolBlue 0 solutions 8 answers

Helpful Reply

I found a solution!

If you put the site exception in both of these formats, it works!

http://mozilla.org https://mozilla.org

Either one on its own does not work. This is new with the update, it didn't used to matter what format you used.

I found a solution! If you put the site exception in both of these formats, it works! '''http'''://mozilla.org '''https'''://mozilla.org Either one on its own does not work. This is new with the update, it didn't used to matter what format you used.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

You normally only specify the domain in a cookie exception and not the protocol. Did you try that version?

You normally only specify the domain in a cookie exception and not the protocol. Did you try that version?
CoolBlue 0 solutions 8 answers

Yes i tried everything this is the only thing that works: putting it in those two formats.

If u just type in "amazon.com" it puts it in as "http://amazon.com" and that won't do it. you also have to have "https://amazon.com" and then it works. Crazy right? lol

So just to summarize again for anyone confused. To make the "exceptions" work, if u r having the same problem i did, you have to put in both formats http:// and https://

Here is another person talking about it altho in the context of an addon which i don't have, but this is what tipped me off to the workaround. https://www.reddit.com/r/firefox/comments/3ri2z1/firefox_42_splits_cookie_exceptions_into_http_and/

and, it does work! thank goodness

Yes i tried everything this is the only thing that works: putting it in those two formats. If u just type in "amazon.com" it puts it in as "http://amazon.com" and that won't do it. you also have to have "https://amazon.com" and then it works. Crazy right? lol So just to summarize again for anyone confused. To make the "exceptions" work, if u r having the same problem i did, you have to put in both formats http:// and https:// Here is another person talking about it altho in the context of an addon which i don't have, but this is what tipped me off to the workaround. https://www.reddit.com/r/firefox/comments/3ri2z1/firefox_42_splits_cookie_exceptions_into_http_and/ and, it does work! thank goodness

Modified by CoolBlue

cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Is that with a cookie manager extension that allows to tweak such an exception for normal and secure connections?

Is that with a cookie manager extension that allows to tweak such an exception for normal and secure connections?
CoolBlue 0 solutions 8 answers

No it has absolutely zero to do with the cookie manager extension. i only actually tried that extension after all the other steps i took - as a potential workaround. it did nothing to fix the problem. i currently do not have the extension. If i put http:// only or https:// only, it does not work (firefox will treat as if no exception for the site). If i put both formats in to the exceptions, it works, as in, it will then accept cookies for the site. It is that simple.

If you read that person on reddit i provided the link, they said the new firefox "splits" cookies into the two formats. not sure if that is accurate descriptor, but it certainly seems to need both formats to "see" and execute the exception rule for any given site.

No it has absolutely zero to do with the cookie manager extension. i only actually tried that extension after all the other steps i took - as a potential workaround. it did nothing to fix the problem. i currently do not have the extension. If i put http:// only or https:// only, it does not work (firefox will treat as if no exception for the site). If i put both formats in to the exceptions, it works, as in, it will then accept cookies for the site. It is that simple. If you read that person on reddit i provided the link, they said the new firefox "splits" cookies into the two formats. not sure if that is accurate descriptor, but it certainly seems to need both formats to "see" and execute the exception rule for any given site.

Question owner

Thanks CoolBlue, I will try your fix. I hope that there can be some work done by the firefox magicians to actually fix this problem. Thanks to all for thinking about this.

Thanks CoolBlue, I will try your fix. I hope that there can be some work done by the firefox magicians to actually fix this problem. Thanks to all for thinking about this.
ppost 0 solutions 1 answers

I also verified that the http/https workaround avoids the problem. However, it is a pain because my exception list has 54 entries. I first experienced this problem when FF 42 was updated, and it still exists in FF 43.0.2. Since the root cause of the problem was identified weeks ago, I am very disappointed that it has still not been corrected.

I also verified that the http/https workaround avoids the problem. However, it is a pain because my exception list has 54 entries. I first experienced this problem when FF 42 was updated, and it still exists in FF 43.0.2. Since the root cause of the problem was identified weeks ago, I am very disappointed that it has still not been corrected.