X
Tap here to go to the mobile version of the site.

Support Forum

Some web page icons do not load.

Posted

Tried all advice in current forum replies for similar problems. No joy. Not a problem with IE 11. Also tried adding screen shots to illustrate, but after waiting 10 minutes for image to load I gave up.

Tried all advice in current forum replies for similar problems. No joy. Not a problem with IE 11. Also tried adding screen shots to illustrate, but after waiting 10 minutes for image to load I gave up.

Chosen solution

Special icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real character and not the little box with the CSS code.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value to true).

Firefox 41 will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Colors" disabled. When unsupported code points are used then you see the little boxes with the hex code.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Content Blocker Extension
  • DjVu browser plugin
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.65.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • PDF Architect 2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • Virtual Keyboard
  • Windows Activation Technologies Plugin for Mozilla
  • iTunes Detector Plug-in

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Dangerous Websites Blocker 4.5.1.379 (content_blocker_663BE84DBCC949E88C7600F63CA7F098@kaspersky.com)
  • Self-Destructing Cookies 0.4.8 (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • Virtual Keyboard 4.5.1.379 (virtual_keyboard_07402848C2F6470194F131B0F3DE025E@kaspersky.com)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4400
  • adapterDescription2:
  • adapterDeviceID: 0x041e
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 8-4-2015
  • driverDate2:
  • driverVersion: 10.18.14.4264
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4400 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 159999 answers

Chosen Solution

Special icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real character and not the little box with the CSS code.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value to true).

Firefox 41 will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Colors" disabled. When unsupported code points are used then you see the little boxes with the hex code.

Special icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. If you have a font installed that covers this Unicode range then you may see a real character and not the little box with the CSS code. Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value to true). *http://kb.mozillazine.org/about:config Firefox 41 will allow icon fonts that use PUA code points to work with the font setting in "Options/Preferences > Content > Colors" disabled. When unsupported code points are used then you see the little boxes with the hex code. *http://www.ghacks.net/2015/07/21/firefox-41-mozilla-modifies-how-icon-fonts-are-handled-by-the-browser/

Modified by cor-el

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Sometimes icons are images, and sometimes characters in a custom font...

Do you see tall rectangles with two lines of two characters in place of the icons?

Usually this is caused by overriding website fonts with a standard set of fonts. You can check for and undo that change on the Options page:

"3-bar" menu button (or Tools menu) > Options > Content

Click the "Advanced" button and if the checkbox for "Allow pages to choose their own fonts, instead of my selections above" is empty, go ahead and check it. Then OK that change.

If you reload the page, do the icons display? If not, possible other explanations include:

  • Font downloading blocked by a preference in about:config (rare)
  • Font downloading blocked by the NoScript extension (inapplicable)
  • Secure site issue -- have you gotten any untrusted connection issues on any sites? is your Firefox fully set up to work with your Kaspersky software's encrypted site scan feature?
  • "Cross-site" issue with the font -- you may see a specific error message about this in Firefox's Browser Console. To check that, open the console either from the Developer menu or using Ctrl+Shift+j, click the Clear button at the top of the console to flush past messages, then reload the problem page and look for any error messages (usually you can ignore the little blue triangle warning messages)

Non-font icon blockage

I'll start by pointing you to the support article, but if you are able to attach the screen shots to a reply or describe the symptoms in more detail, volunteers might be able to zero in on the problem. Fix problems that cause images to not show

Sometimes icons are images, and sometimes characters in a custom font... '''Do you see tall rectangles with two lines of two characters in place of the icons?''' Usually this is caused by overriding website fonts with a standard set of fonts. You can check for and undo that change on the Options page: "3-bar" menu button (or Tools menu) > Options > Content Click the "Advanced" button and if the checkbox for "Allow pages to choose their own fonts, instead of my selections above" is empty, go ahead and check it. Then OK that change. If you reload the page, do the icons display? If not, possible other explanations include: * Font downloading blocked by a preference in about:config (rare) * Font downloading blocked by the NoScript extension (inapplicable) * Secure site issue -- have you gotten any untrusted connection issues on any sites? is your Firefox fully set up to work with your Kaspersky software's encrypted site scan feature? * "Cross-site" issue with the font -- you may see a specific error message about this in Firefox's Browser Console. To check that, open the console either from the Developer menu or using Ctrl+Shift+j, click the Clear button at the top of the console to flush past messages, then reload the problem page and look for any error messages (usually you can ignore the little blue triangle warning messages) '''Non-font icon blockage''' I'll start by pointing you to the support article, but if you are able to attach the screen shots to a reply or describe the symptoms in more detail, volunteers might be able to zero in on the problem. [[Fix problems that cause images to not show]]

Modified by jscher2000

Question owner

cor-el

Thank you, thank you, thank you. Downloadable fonts were not enabled. Now they are. Problem solved. Now I can let my hair grow back in after months of pulling it out. Thanks again.

cor-el Thank you, thank you, thank you. Downloadable fonts were not enabled. Now they are. Problem solved. Now I can let my hair grow back in after months of pulling it out. Thanks again.