Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I disable the pop-up message "to make Yahoo your homepage in Firefox" which keeps coming up?

  • 3 replies
  • 2 have this problem
  • 123 views
  • Last reply by jscher2000

more options

When I disabled Java and upgraded all the plug-in status, Firefox made MSN my home page and I wanted Yahoo. Now the message to make Yahoo my home page keeps coming up even tho Yahoo is now in homepage status.

Chosen solution

The "Internet Settings" in the Windows Control Panel are just for Internet Explorer, so you can set those aside for the time being. To check and change Firefox's home page, you can use the Options page, as described in this article: Startup, home page, tabs, and download settings.

Amethyst48 said

Now the message to make Yahoo my home page keeps coming up even tho Yahoo is now in homepage status.

Where do you see that message? If it's on Yahoo itself, you can ignore it or click the button to ignore it. Sites have no idea of your current home page because web pages are not allowed to read your browser settings. Typically they just incessantly promote themselves, and if you tell them to shut up, they remember that by setting a cookie.

Read this answer in context 👍 0

All Replies (3)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

more options

There was nothing call "Yahoo Anything" in my Extensions. Nor is there any Yahoo in my Uninstall Programs. Mozilla Reset just made Firefox my homepage, even tho Yahoo is listed as homepage in Internet Settings.

more options

Chosen Solution

The "Internet Settings" in the Windows Control Panel are just for Internet Explorer, so you can set those aside for the time being. To check and change Firefox's home page, you can use the Options page, as described in this article: Startup, home page, tabs, and download settings.

Amethyst48 said

Now the message to make Yahoo my home page keeps coming up even tho Yahoo is now in homepage status.

Where do you see that message? If it's on Yahoo itself, you can ignore it or click the button to ignore it. Sites have no idea of your current home page because web pages are not allowed to read your browser settings. Typically they just incessantly promote themselves, and if you tell them to shut up, they remember that by setting a cookie.