Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube and WebMs are weird when trying to automatically play (details inside), yet using Flash to load videos on sites like DailyMotion works fine.

  • 3 replies
  • 2 have this problem
  • 24 views
  • Last reply by jscher2000

more options

This started a few days ago, possibly coinciding with updating to 41.0.1.

If I load a video on Youtube, or load a WebM, the video shows that it's set to "play", as it's supposed to, and it loads as normal, but it doesn't actually play, the time just stays at 0:00. If I pause and unpause it, or move the timer, it plays like normal. Also, if I load a Youtube video from a referral link on the page of a video I'm already playing, this doesn't happen. This also doesn't happen on sites like DailyMotion that only use Flash instead of HTML5.

Is there a proper fix for this? Even if I were to force Youtube to play with Flash instead of HTML5, it won't fix the problems with WebMs.

My Extension setup is the following:

  • Custom New Tab 2.1.1
  • Dictionary Extension 3.0.12.1.1
  • Download Manager Tweak 1.0.9.1
  • Download Youtube Videos as MP4 1.8.3.1
  • DownloadThemAll! 2.0.18.1
  • HTTPS-Everywhere 5.1.1
  • Mega 3.1.19
  • NationStates++
  • New Tab Override 1.0
  • NoScript 2.6.9.38
  • Ratings Preview for Youtube 4.1.2.1
  • uBlock Origin 1.2.1
  • Undo Close Tab Replacement 8
  • Youtube mp3 1.0.9.1

My Plugin setup is the following:

  • OpenH264 Video Codec by Cisco - Always Activate
  • Primetime Content Decryption Module by Adobe - Always Activate
  • Google Update - Ask to Activate
  • Java Deployment Toolkit 8.0.600.27 - Ask to Activate
  • Java Platform SE 8 U60 - Ask to Activate
  • Microsoft Office 2010 (Officer Authorization) - Ask to Activate
  • Microsoft Office 2010 (open and edit files) - Ask to Activate
  • Nexon Game Controller - Ask to Activate
  • Raidcall plugin - Ask to Activate
  • Shockwave Flash 19.0.0.185 - Ask to Activate
  • SumatraPDF Browser Plugin - Ask to Activate
  • Windows Activation Technologies - Ask to Activate

Thanks

Chosen solution

Did you disable autoplay in the HTML5 media player or have an extension that blocks media files?

You can check this pref and other media prefs on the about:config page:

  • media.autoplay.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 👍 1

All Replies (3)

more options

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Chosen Solution

Did you disable autoplay in the HTML5 media player or have an extension that blocks media files?

You can check this pref and other media prefs on the about:config page:

  • media.autoplay.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

I agree with cor-el's diagnosis. Before Firefox 41, scripts would send a Play command to the HTML5 media player to start the video to work around users who disabled autoplay. Firefox 41 stops the playback, but it does not fix the player controls, so you see a pause button even though the playback is halted. Hopefully there's a way to fix it in a future update.