X
Tap here to go to the mobile version of the site.

Support Forum

Why has Firefox suddenly lost all graphics and gone to text only?

Posted

When I booted up this morning Mozilla Firefox appeared as a text-only page as did everything I attempted to access via Firefox. I've done an uninstall, folder clean-up and clean install of latest version of Firefox but it's come up exactly the same. Can anybody help, please? (I'm running Windows 7 PC).

When I booted up this morning Mozilla Firefox appeared as a text-only page as did everything I attempted to access via Firefox. I've done an uninstall, folder clean-up and clean install of latest version of Firefox but it's come up exactly the same. Can anybody help, please? (I'm running Windows 7 PC).

Chosen solution

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; GWX:QUALIFIED; rv:11.0) like Gecko

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59846 answers

Chosen Solution

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? While still in Safe Mode, Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

What page opens when you start Firefox?

Is that the built-in about:home page or a website?

You can find the home page setting here:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.


If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This setting affects background images.

See also:


There are extensions like Adblock Plus (Firefox menu button/Tools > Add-ons > Extensions) and Anti-Virus software that can block images and other content.

See also:

What page opens when you start Firefox? Is that the built-in about:home page or a website? You can find the home page setting here: *Tools > Options > General > Startup: Home page *https://support.mozilla.org/kb/How+to+set+the+home+page Firefox supports multiple home pages separated by '|' (pipe) symbols. ----- If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions" Check "Tools > Page Info > Media" for blocked images *Select the first image link and use the cursor Down key to scroll through the list. *If an image in the list is grayed and "<i>Block Images from...</i>" has a checkmark then remove this checkmark to unblock images from this domain. Make sure that you do not block (third-party) images, the <b>permissions.default.image</b> pref on the <b>about:config</b> page should be 1. ---- Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure that you allow pages to choose their own colors. *Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working. This setting affects background images. See also: *http://kb.mozillazine.org/Website_colors_are_wrong ---- There are extensions like Adblock Plus (Firefox menu button/Tools > Add-ons > Extensions) and Anti-Virus software that can block images and other content. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *http://kb.mozillazine.org/Images_or_animations_do_not_load *http://kb.mozillazine.org/Websites_look_wrong