Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After installing 41.0.1 gmail site has security problem, also can't get roboform tool bar to display after enabling Roboform in FF

  • 9 replies
  • 5 have this problem
  • 1863 views
  • Last reply by andycruce

more options

FF was crashing so I upgraded to 41.0.1. After that whenever I tried to access gmail.com I got an untrusted sight security message. Tried ignoring the message but got another similar message and was uncomfortable just setting up an exception for all of them.

Also enabled roboform in the newly installed version but can't get the roboform tool bar to diaplay.

I am running windows 10 and the version of ff is 41.0.1

Chosen solution

Hi Andy, what did the Certificate Viewer tell you about the "issuer" of the certificate that Firefox doesn't trust. Did it mention Microsoft Family Safety? Unfortunately, everything I know about that certificate was already in my earlier reply.

Read this answer in context 👍 0

All Replies (9)

more options

Hi Andy, in another thread you mentioned you got an error page on my website (https://support.mozilla.org/questions/1084406#answer-791134), and that you removed McAfee and have Norton. Norton usually doesn't cause problems accessing secure sites.

To investigate further, could you inspect the certificate? Here's how:

Load https://jeffersonscher.com/res/jstest.php again.

Expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

I should mention that one thing affecting a lot of Windows 10 users is that parental controls are being applied to their accounts, which causes seemingly random silent blockages.

Could you check Microsoft Family Safety and either disable it or take your account out of the family as a test: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

If that is the culprit but you want to continue using the feature, you can set that up using the steps in this thread: https://support.mozilla.org/questions/1083592

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

more options

Here is what I got when I accessed your web site:


jeffersonscher.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

(Error code: sec_error_unknown_issuer)

If you understand what's going on, you can tell Firefox to start trusting this site's identification. Even if you trust the site, this error could mean that someone is tampering with your connection.

Don't add an exception unless you know there's a good reason why this site doesn't use trusted identification.

Hope this helps. I like FireFox but at this time IE seems to work properly. I'm surprised that version 41 was released with this kind of bug. Haven't had this problem with earlier releases and I've been using FF for a long time.

Andy Cruce

more options

Hi Andy, the next step is to look at the certificate as I described in my earlier post: https://support.mozilla.org/questions/1087594#answer-791139

Often this will identify an intermediary software product that is causing the problem.

more options

I went to:

http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

After opening this I needed to select a person to turn family protection off. However, I am the only one using the computer and since there was no entry for me I could get any of the selections to turn something off to work. Not sure what to do now.

Andy Cruce

more options

Chosen Solution

Hi Andy, what did the Certificate Viewer tell you about the "issuer" of the certificate that Firefox doesn't trust. Did it mention Microsoft Family Safety? Unfortunately, everything I know about that certificate was already in my earlier reply.

more options

I looked at the view of the site characteristics when setting up an exception and noticed that there was a problem with a popup blocker that I use - ADGUARD. Once I got rid of its security the problem with gmail.com went away.

I do have one other question - I use roboform as an add on. I have it enabled but the roboform tool bar is not displayed. How do I get it to display?

Thanks for the help so far,

Andy Cruce

more options

I think I also was able to fix roboform. after disabling ADGUARD's security option and rebooting the computer firefox came up with the roboform tool bar.

Thanks again,

Andy Cruce