Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix "Firefox is Not Responding"

  • 4 replies
  • 2 have this problem
  • 22 views
  • Last reply by tonto91

more options

Starting a few days ago I've been having some serious issues with Firefox. It crashes almost constantly when I try to go on the internet. I have tried uninstalling and reinstalling the browser. Didn't work. When I go to close the page there is no option to send a report, it just asks me if I want to close the page or wait for it to respond. Then when I bring back Firefox it gives me the "Well this is embarrassing" message.

All Replies (4)

more options

Sorry to hear about the crashes.

It sounds as though you are getting the Windows 8 crash dialog -- wait, shut down. In that case, could you start by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions, hardware acceleration, and some other advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?


When Firefox is "not responding" unfortunately Firefox usually doesn't capture any data about the problem. However, when Firefox crashes and presents the Mozilla Crash Reporter form, the data Firefox logs may help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.

Also, for hangs and freezes, this article might be useful: Firefox hangs or is not responding - How to fix.

more options

Sounds very similar to my problem. Started Saturday. Win7 64 machine. There are specific sites I can go to and FireFox just falls into Not Responding mode. Did a Refresh Firefox. Have tried YesScript. Cleared cookies and cache. It crashed when trying that even. The problem persists. I've got three extensions counting YesScript. Just like the post above when I go to close the page there is no option to send a report, it just asks me if I want to close the page or wait for it to respond. Then when I bring back Firefox it gives me the "Well this is embarrassing" message.

more options

Hi tonto91, did you try Firefox's Safe Mode?

To both of you: To minimize potential issues with Flash, I suggest two things:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

No I haven't run in safe mode because I run a pretty much plain vanilla out of the box version of Firefox, no theme, two basic extensions and that's it.

However setting Flash to Click-to-Play has worked to stop the Not Responding situation for me. Also didn't realize some pages use Flash only for tracking or playing ads which has enhanced my user experience on those pages since I'm not ad bombed upon arrival.

So thanks for the help. I'm good for now. Eventually when we live in a Flash free world the web will be a better place.  :)