Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Reduce horizontal icon spacing in address bar

  • 2 replies
  • 1 has this problem
  • 20 views
  • Last reply by dez93_2000

more options

[FF40.0.3 win7] The new FF seems to have increased horizontal buffer space between address bar icons, such that the address & search boxes are squished to nothingness by icons which previous took up little space. Is there any way to change this? The bookmarks bar, by contrast, has very tight spacing, which I like.

Attached screenshots

All Replies (2)

more options

Hi, the UI hasn't changed since FF29, so if this is new, your issue may be caused by the theme you are using, so try disabling it (Ctrl + Shift + A to open the Add-ons Manager). If it isn't that, you can try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If this isn't a new issue, you can try an add-on like Classic Toolbar Buttons which I have used myself since FF29 (when IMHO the UI was mucked up), and in Options > Navigation toolbar buttons, I suggest you try 'Classic small buttons.'

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Hi Scribe, cheers for the response & sorry for my delay in getting back to you. I've since installed FF in a fresh install of linux & have the same issue; the fact that it affects the standard buttons (bookmark, history, smiley face, addon buttons) tells me that it's not specific to the buttons within the google bookmarks addon.

There's an addon which addresses this issue within the bookmarks toolbar (https://support.mozilla.org/en-US/questions/935861) although I find the bookmarks toolbar spacing to be fine!

I appreciate your point that this may not be new - I'm surprised I've only just noticed it, but there you go! My question remains, therefore - do we know if it's possible, through an addon or by tweaking about:config, to shrink this space?

Thanks!