X
Tap here to go to the mobile version of the site.

Support Forum

Adobe Flash Player Plug In Crashes

Posted

Ever since I upgraded to Windows 10, my Firefox browser keeps crashing with the message Adobe Flash Player Plug In has crashed. I have and have reinstalled the latest versions of Firefox and Adobe Flash Player. The crashes are constant and are making it extremely difficult to use Firefox as my browser. Neither Adobe Flash Player nor Firefox seem to have a solution.

Ever since I upgraded to Windows 10, my Firefox browser keeps crashing with the message Adobe Flash Player Plug In has crashed. I have and have reinstalled the latest versions of Firefox and Adobe Flash Player. The crashes are constant and are making it extremely difficult to use Firefox as my browser. Neither Adobe Flash Player nor Firefox seem to have a solution.

Chosen solution

I use technical support from Dell. We finally solved this problem by uninstalling Adobe Flash Player (period). They told me Windows 8 and Windows 10 have built in flash players and Adobe was causing a conflict. This would be good information to pass along to all of those complaining about this issue.

Read this answer in context 24

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Amazon MP3 Downloader Plugin 1.0.18
  • Citrix Online App Detector Plugin
  • Coupons, Inc. Coupon Printer 5.0.2.3
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • FlashGot 1.5.6.12.1-signed ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • RoboForm Toolbar 7.9.15.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • YouTube™ Flash® Player 1.3.1-signed (jid1-HAV2inXAnQPIeA@jetpack)
  • Norton Toolbar 2015.5.2.24 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0152
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 054b1028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-10-2015
  • driverDate2:
  • driverVersion: 10.18.10.4252
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Scribe 631 solutions 3055 answers

Hi, see if anything here helps - Adobe Flash plugin has crashed - Prevent it from happening again.

If not, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hi, see if anything here helps - [[Adobe Flash plugin has crashed - Prevent it from happening again]]. If not, try Firefox Safe Mode to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Chosen Solution

I use technical support from Dell. We finally solved this problem by uninstalling Adobe Flash Player (period). They told me Windows 8 and Windows 10 have built in flash players and Adobe was causing a conflict. This would be good information to pass along to all of those complaining about this issue.

I use technical support from Dell. We finally solved this problem by uninstalling Adobe Flash Player (period). They told me Windows 8 and Windows 10 have built in flash players and Adobe was causing a conflict. This would be good information to pass along to all of those complaining about this issue.
FredMcD
  • Top 10 Contributor
3215 solutions 43386 answers

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.
tnicoson 0 solutions 6 answers

I am still on Windows 7 (64 bit) and still on the previous version of Adobe Flashplayer, but have been experiencing the same problem. I am shy on download bandwidth at the moment, so will have to wait until my overnight "free period" to download the latest version of Adobe Flash. However, disabling Adobe Flash "Protected Mode" and "Hardware Acceleration", as described in the Adobe Support forum, appears to have resolved my problem - even with the older version.

To disable Flashplayer Protected Mode, start Firefox and go to Tools > Add-ons > Plugins. Find the entry for "Shockwave Flash" in the list and LEFT click on "Options". At the bottom of the Options list, if the box to the right of "Enable Adobe Flash protected mode" is checked, LEFT click on it to uncheck it. Restart Firefox. Be advised that disabling Protected Mode involves some security risks. The choice is yours. If you are unwilling to accept this, then do not perform this procedure. You may want to try just disabling hardware acceleration to see if that, alone, will resolve you problem. It did NOT for me. I had to disable BOTH, so I may resort to a different browser for video work. I am going to hate that, as I have been with this browser since version 1 of Netscape Navigator.

To disable Adobe Flashplayer hardware acceleration, select a Flash video to play and left click on the "Play" arrow. As the video is loading, point to the video window and RIGHT click on it. When the menu pops up, LEFT click on "Settings" (NOT Global Settings). You may have to LEFT click on "Settings" several times very quickly to get it to register. When the "Settings" window comes up, if the "Enable hardware acceleration" box is checked, LEFT click on it to uncheck it. Close the window and restart Firefox. Firefox has its own hardware acceleration option, but it was not necessary for me to disable it to get Flashplayer working, so I left it enabled.

I am still on Windows 7 (64 bit) and still on the previous version of Adobe Flashplayer, but have been experiencing the same problem. I am shy on download bandwidth at the moment, so will have to wait until my overnight "free period" to download the latest version of Adobe Flash. However, disabling Adobe Flash "Protected Mode" and "Hardware Acceleration", as described in the Adobe Support forum, appears to have resolved my problem - even with the older version. To disable Flashplayer Protected Mode, start Firefox and go to Tools > Add-ons > Plugins. Find the entry for "Shockwave Flash" in the list and LEFT click on "Options". At the bottom of the Options list, if the box to the right of "Enable Adobe Flash protected mode" is checked, LEFT click on it to uncheck it. Restart Firefox. Be advised that disabling Protected Mode involves some security risks. The choice is yours. If you are unwilling to accept this, then do not perform this procedure. You may want to try just disabling hardware acceleration to see if that, alone, will resolve you problem. It did NOT for me. I had to disable BOTH, so I may resort to a different browser for video work. I am going to hate that, as I have been with this browser since version 1 of Netscape Navigator. To disable Adobe Flashplayer hardware acceleration, select a Flash video to play and left click on the "Play" arrow. As the video is loading, point to the video window and RIGHT click on it. When the menu pops up, LEFT click on "Settings" (NOT Global Settings). You may have to LEFT click on "Settings" several times very quickly to get it to register. When the "Settings" window comes up, if the "Enable hardware acceleration" box is checked, LEFT click on it to uncheck it. Close the window and restart Firefox. Firefox has its own hardware acceleration option, but it was not necessary for me to disable it to get Flashplayer working, so I left it enabled.

Modified by tnicoson

tnicoson 0 solutions 6 answers

Helpful Reply

UPDATE:

Just downloaded and installed Firefox 43.0, and Adobe Flash Player is still working with the modifications described in my 12-12-2015 post.

UPDATE: Just downloaded and installed Firefox 43.0, and Adobe Flash Player is still working with the modifications described in my 12-12-2015 post.
Ledlane 0 solutions 1 answers

The following works for me every time. I am on Windows 10 (64 bit) and experienced these problems for a couple of weeks. Despite following advice from Adobe and Mozilla nothing corrected the crash. Adobe Flash Player is version 20 NPAPI, and whenever going down the uninstall route and trusting the inbuilt devices, it did not work and I kept getting the prompt to install Flash from Adobe. I gained further advice from an online source, and cannot remember exactly where, but they were spot on as far as I am concerned. I have joined the forum to pass on this knowledge in the hope it works for others. Go to your Device Manager on the Control Panel and seek the Display Adaptor. Then open the Graphics Card properties and uninstall its driver. Shut down your pc and reboot, whereupon the card will seek and reinstall its driver. This process worked for me first time, and despite experiencing another crash a few days later, I simply repeated the same and effortlessly experienced a clean reinstall. All has been steady ever since and I would recommend this simple task first, to see if the problem was identical to mine. Good luck.

The following works for me every time. I am on Windows 10 (64 bit) and experienced these problems for a couple of weeks. Despite following advice from Adobe and Mozilla nothing corrected the crash. Adobe Flash Player is version 20 NPAPI, and whenever going down the uninstall route and trusting the inbuilt devices, it did not work and I kept getting the prompt to install Flash from Adobe. I gained further advice from an online source, and cannot remember exactly where, but they were spot on as far as I am concerned. I have joined the forum to pass on this knowledge in the hope it works for others. Go to your Device Manager on the Control Panel and seek the Display Adaptor. Then open the Graphics Card properties and uninstall its driver. Shut down your pc and reboot, whereupon the card will seek and reinstall its driver. This process worked for me first time, and despite experiencing another crash a few days later, I simply repeated the same and effortlessly experienced a clean reinstall. All has been steady ever since and I would recommend this simple task first, to see if the problem was identical to mine. Good luck.