Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HTML5 player will not go to full screen on one site

  • 2 replies
  • 2 have this problem
  • 13 views
  • Last reply by cor-el

more options

Hello, I am trying to stream a movie from a site and the HTML5 player will not go full screen. When I click the full screen switch inside of the player the switch changes its representation to show full screen but no action takes place on the screen. The player still stays the same size. Is there an add-on or a way to force full screen in HTML5. I tried right clicking inside the player but it only shows a link to Vodlocker and does not allow any changes in settings. I have noticed this before with HTML5 for some streaming sites.

All Replies (2)

more options

Please update to the most recent version of Firefox, the latest version is 40.0.3:

Second, are there any times that fullscreen may have been disabled or not allowed> Check in the Page Information of the site by right clicking on the page and selecting "Page Info". Under permissions, are there any preferences for fullscreen?

If you change anything please reload the page to see changes if they are not there right away.

more options

You can inspect and manage permissions (including the full screen permission) for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected

Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window