Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bank of America Website displays text only using firefox 40.0.2

  • 17 replies
  • 1 has this problem
  • Last reply by cor-el

more options

Bank of America Website displays text only using firefox 40.0.2

All Replies (17)

more options

I assume you tried the usual things, but I'll list them just in case:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page and logging in again. Does that help?

Assuming that does not work, one common explanation for seeing "unstyled" websites would be a problem with the security certificates of the servers that host the page's style sheets and scripts.

Have you noticed any certificate error messages in Firefox recently?

Also, are you currently using BitDefender (you have a disabled BitDefender add-on)?

more options

Thanks for you help! I tried eveything you mentioned. The first page after login now displays correctly, but the next page is text only. No certificate errors have appeared. I do use BitDefender.

more options

Okay, that's progress. On the page with the broken layout, could you try this:

Press Ctrl+Shift+k to open the Web Console, a second that opens in the lower part of the tab. There are buttons along the top edge of the console. Click Network to show the Network Monitor section.

Then use Ctrl+r or click the reload arrow in the address bar to reload the bank page. The network monitor should start filling up with web addresses.

Once things settle down, scroll back up in the network monitor list and look for the items which list "css" in the Type column. These are the style sheet files that either are not loading or are not being applied. At the left end of the row, there should be a status indication. For example, a green dot and the number 200 indicates the file was retrieved successfully.

What kind of status do you see for the style sheets?

For each style sheet that didn't load successfully, could you right-click its row and then Open in New Tab? Normally a style sheet looks like a huge wall of text, just a bunch of style rules. Does yours load that way or do you get an error message?

more options

green dot 200 yellow triangle 304 green dot 206 yellow triangle 304 green dot 206 yes, huge wall of text

the last css got a content encoding error

Modified by fdbetts

more options

Hmm, content encoding error and refusing to show the wall of text for that style sheet? It's hard to think of why that would happen. Can you post the URL of that style sheet? I don't think it will have any personal information in the address, but if you can't tell whether it contains a session cookie, you could make sure to log out of the site before submitting your post here.

more options

Content Encoding Error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

   Please contact the website owners to inform them of this problem.

more options

Hmm, when I research that error, I see the following:

  • Problem with a bad file in the cache. Try to reload the page bypassing the cache (Ctrl+Shift+r)
  • Can be caused by SpeedBit Video Accelerator
  • Can be caused by other LSP's (Layered Service Providers which intercept inbound/outbound traffic)
  • Can be caused by a proxy server

Do you use anything like Trusteer Rapport or other financial institution security software? I wonder whether this is a new bug with one of those programs.

I hope it's not a sign of spyware.

more options

Not to my knowledge.

I can't believe I'm the only one with this problem.

more options

Do you think it would help to uninstall FIREFOX and reinstall?

Please reply.

more options

hi, please try to refresh firefox (a mere reinstall likely won't change anything about the problem).

more options

Try to reset the network.http.accept-encoding pref on the about:config page if it currently shows user set (bold).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Back to my problem which still has not been solved (although I had mistakenly reported it as solved).

about:config shows the following (not bold):

network.http.accept-encoding;gzip, deflate

more options

fdbetts said

about:config shows the following (not bold):

network.http.accept-encoding;gzip, deflate

You could try clearing out that preference (double-click to edit, blank it out, click OK) to see whether that makes any difference.

Is this still the only site that has a problem with styles not being applied?

more options

Have you ever tested in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Yes, this is the only site having problem.

more options

It worked in safe mode.

more options

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "3-bar" menu button > Exit (Power button) (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit)