Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't unpin Firefox icon from Windows 7 taskbar - new install.

  • 5 replies
  • 5 have this problem
  • 194 views
  • Last reply by SCLUCAS

more options

I installed Firefox on a new laptop running Windows 7 today. It appear that the install put a FF icon on my Windows 7 icon. Great. However, when I click that icon, it adds a second FF icon next to the original, and another and another for every FF session that I open. It clogs up the taskbar! My previous install simply "stacked" FF session icons in one location on the taskbar???

I've read several threads that suggest opening FF with the original icon on the taskbar. Then, right click the new icon, and select "pin this icon to the taskbar". Then right click the original icon and select "remove this icon from the taskbar". This is the problem. When I right click the original icon, no additional options are displayed. Nothing! It just says "Mozilla Firefox".

So basically, I cannot remove the original icon at all??? Any suggestions would be appreciated!

Chosen solution

jscher2000. Thank you again. Well, I resolved it, but it was by chance. I rebooted the PC and the icon was gone from the taskbar! Weird. I created a new one from the Start menu, and not it works as expected.

On your previous post, you are probably correct. FF did not place the icon in the taskbar. I must have dragged it there from the one that was placed on the desktop. Good catch.

Not sure why the previous icon would not cooperate at all on the first go. Only until after the reboot. Perhaps a registry setting???

Thanks again!

Read this answer in context 👍 0

All Replies (5)

more options

Could you check your Taskbar button setting? Here's how:

right-click the Taskbar, then Properties

On the Taskbar tab (displayed by default), if the "Taskbar buttons" setting is not "Always combine, hide labels", click that drop-down and change the setting.

Does that restore it to what you used to have?

more options

Thank you jscher2000. The taskbar was set to "Always combine, hide labels". So no luck.

This original FF icon is the only one in my taskbar that can't be unpinned. I took a screen shot below. The one to the left is the one that FF installed. When I click it, it opens the new icon to the right. This shows multiple browser sessions stacked on top of each other. I would prefer to have just 1 FF icon in the taskbar. As other have suggested, I can pin the new icon to the right, but I cannot unpin the original to the left???

more options

I didn't think Firefox auto-installed to the Taskbar, only to the desktop. However, I don't reinstall Firefox very often...

Could you check this folder, you can copy this and paste it into the Start menu search box to open it:

%AppData%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\

If you see a Firefox shortcut there, delete it. Was that the one you wanted to remove?


In reading about this, I learned there is a setting in the Windows registry that links Firefox's Taskbar icon with its jump list data (the recent/bookmarked pages you add to the right-click list):

HKEY_CURRENT_USER\Software\Mozilla\Firefox\TaskBarIDs

You might not need to do anything with that, but if, after you pin Firefox again, the jump list stops working, you might need to clear that. I haven't tried it myself.

more options

On another forum, someone said they could cause this issue on Windows 10 by custom installing Firefox and not having the installer create any shortcuts. You probably didn't do that, but if you did, it sounds as though the only cure is to run the installer again and have Firefox create shortcuts: http://forums.mozillazine.org/viewtopic.php?p=14292041#p14292041

more options

Chosen Solution

jscher2000. Thank you again. Well, I resolved it, but it was by chance. I rebooted the PC and the icon was gone from the taskbar! Weird. I created a new one from the Start menu, and not it works as expected.

On your previous post, you are probably correct. FF did not place the icon in the taskbar. I must have dragged it there from the one that was placed on the desktop. Good catch.

Not sure why the previous icon would not cooperate at all on the first go. Only until after the reboot. Perhaps a registry setting???

Thanks again!