Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I click on a url, it should open in a new tab; why does it open in the same tab?

  • 14 replies
  • 2 have this problem
  • 778 views
  • Last reply by jscher2000

more options

I have my Mozilla preferences set up so that everytime I click on a url, it should open in a new tab, but every once in a while Mozilla goes on the fritz and opens the new url IN THE SAME TAB! I checked my preferences, they are still set correctly. I checked Tools: Options: General: Tabs: Open new window in tab instead. and When I open a link in a new tab, switch to it immediately. So this is still set correctly.

What am I missing?

Chosen solution

That preference refers to links that are coded to launch in a new window: launch them in a new tab instead of a new window.

Unfortunately, there's no built-in setting for links that are coded to launch in the same tab to launch them in a new tab instead of in the same tab. You would need an add-on for that.

Normally I would suggest checking out Tab Mix Plus as the "Swiss Army knife" of tab-related features, but lately it has a little bug so if it hasn't been updated in recent days, you might hold off on using it.

Read this answer in context 👍 1

All Replies (14)

more options

It's not Firefox, it's the web page. Some links open a new window. Some don't. If you have a 3 button mouse, the middle button opens to a new tab.

more options

It's happening on all web pages.

more options

Chosen Solution

That preference refers to links that are coded to launch in a new window: launch them in a new tab instead of a new window.

Unfortunately, there's no built-in setting for links that are coded to launch in the same tab to launch them in a new tab instead of in the same tab. You would need an add-on for that.

Normally I would suggest checking out Tab Mix Plus as the "Swiss Army knife" of tab-related features, but lately it has a little bug so if it hasn't been updated in recent days, you might hold off on using it.

more options

What are the settings of theses prefs?

For links opened via JavaScript you can look at this pref:


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I don't feel comfortable going to safe mode. If I have to keep right clicking to open things in a new tab, that's what I'll do.

more options

Did you check the values of the prefs I mentioned above on the about:config page?

  • browser.link.open_newwindow
  • browser.link.open_newwindow.restriction

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can middle-click a link with the mouse scroll wheel or hold Ctrl and left-click to open the link in a new tab.

more options

Firefox's Safe Mode is not really that scary. When you're in Safe Mode and you exit Firefox, it starts up normally the next time (assuming you don't hold down the Shift key). Of course, watch out for a choice between Safe Mode and a Refresh, since a Refresh removes all your add-ons. I think the buttons are labeled clearly.

In case it's useful, you can hold down Ctrl and left-click a link to direct it to a new tab. Or if your mouse has a click wheel, you can "middle-click" the link with the wheel to open it in a new tab.

more options

jscher2000 said

That preference refers to links that are coded to launch in a new window: launch them in a new tab instead of a new window. Unfortunately, there's no built-in setting for links that are coded to launch in the same tab to launch them in a new tab instead of in the same tab. You would need an add-on for that. Normally I would suggest checking out Tab Mix Plus as the "Swiss Army knife" of tab-related features, but lately it has a little bug so if it hasn't been updated in recent days, you might hold off on using it.

THANK YOU jscher2000!!!

I've been sick for a couple weeks so I had not bothered to come in and try to deal with this problem. When I got back on the computer again I was just right clicking to open things in tabs again. While emptying hundreds of pieces of mail I came across your suggestion and decided that it looked easy enough to try out, and I knew if it didn't work it was easy enough to get rid of. Thank you so much because it appears to be working so far. What a relief!

more options

FredMcD said

It's not Firefox, it's the web page. Some links open a new window. Some don't. If you have a 3 button mouse, the middle button opens to a new tab.

Honestly, it was completely unpredictable. Some days it worked and some days it did not. Some websites in worked part time.

more options

cor-el said

Did you check the values of the prefs I mentioned above on the about:config page?
  • browser.link.open_newwindow
  • browser.link.open_newwindow.restriction
You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. You can middle-click a link with the mouse scroll wheel or hold Ctrl and left-click to open the link in a new tab.

I just wasn't willing to accept the warning/risk.

more options

For me, one of the great pleasure of Mozilla is it independence. It has its price, e.g. that a clicked hyper-link doesn't open in a new tab. Very frustrating! I do think it's unbelievable that you, all the beautiful Mozilla-experts, don't have a solution to this very fundamental handicap of Mozilla. Is there a add-on which tackles this problem?

more options

Hi astrohubble, the default position is that Firefox handles links the way pages specify, except that "new window" is usually interpreted as "new tab." There are extensions such as Tab Mix Plus that let you override this approach and drive everything into a new tab.

more options

Thank you, jscher 2000, but this Tab Mix Plus doesn't work in my browser!

Modified by astrohubble

more options

astrohubble said

Tab Mix Plus doesn't work in my browser!

Is your browser Firefox 43?? I haven't seen other threads mentioning that problem (although, I can't read everything). You might want to start a new question and include your Firefox configuration details. You can use the Ask a Question link at the top of any support page; scroll down past article suggestions to find the next part of the form.