X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Flash 18.0.0.232 crashes repeatedly after Windows 10 upgrade

Posted

Toshiba laptop: I just upgraded to Windows 10 and Flash 18.0.0.232 crashes repeatedly. Switched hardware acceleration off in Flash settings but no improvement. Having to use Edge to get Duolingo to work. Help please?

Toshiba laptop: I just upgraded to Windows 10 and Flash 18.0.0.232 crashes repeatedly. Switched hardware acceleration off in Flash settings but no improvement. Having to use Edge to get Duolingo to work. Help please?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Shockwave Flash 18.0 r0
  • VLC media player Web Plugin

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Video DownloadHelper 5.4.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Norton Toolbar 2015.5.2.24 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0f31
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 6-16-2015
  • driverDate2:
  • driverVersion: 10.18.10.4242
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8871 solutions 72589 answers

Sorry to hear about the crashes. Are you getting the Mozilla Crash Reporter dialog, or the Windows crash dialog? If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.


Could you try disabling protected mode? The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Sorry to hear about the crashes. Are you getting the Mozilla Crash Reporter dialog, or the Windows crash dialog? If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "[[Firefox Crashes]]" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here. ---- Could you try disabling protected mode? The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Question owner

When I entered about:crashes at the address bar the list of crashes appeared. I right clicked on the most recent and selected 'Open link in new tab'. I got a 'Page not Found' screen with the following address: https://crash-stats.mozilla.com/about/throttling.

When I entered about:crashes at the address bar the list of crashes appeared. I right clicked on the most recent and selected 'Open link in new tab'. I got a 'Page not Found' screen with the following address: https://crash-stats.mozilla.com/about/throttling.
jscher2000
  • Top 10 Contributor
8871 solutions 72589 answers

Helpful Reply

You might need to try a few times. Throttling refers to the server rejecting some requests/submissions due to heavy load.

For any crash report IDs that start a lower case bp- you can paste the ID into your reply without revisiting it. Although, you might be interested to see what is included.

You might need to try a few times. Throttling refers to the server rejecting some requests/submissions due to heavy load. For any crash report IDs that start a lower case bp- you can paste the ID into your reply without revisiting it. Although, you might be interested to see what is included.

Question owner

Turning Flash protected mode off seems to have fixed the problem........but isn't that exposing me to a security risk that I would not be exposed to if I were using another browser that didn't have this plug-in issue?

Turning Flash protected mode off seems to have fixed the problem........but isn't that exposing me to a security risk that I would not be exposed to if I were using another browser that didn't have this plug-in issue?

Question owner

I left-clicked on the crash report id and it appearted to me that the 'bp' prefix was appended.

Here's the report id: https://crash-stats.mozilla.com/report/index/bp-3c52c853-3e17-416e-9dd7-78db22150821

I left-clicked on the crash report id and it appearted to me that the 'bp' prefix was appended. Here's the report id: https://crash-stats.mozilla.com/report/index/bp-3c52c853-3e17-416e-9dd7-78db22150821
jscher2000
  • Top 10 Contributor
8871 solutions 72589 answers

Helpful Reply

I'm puzzled by the crash report; it seems partially blank like the crash happened so fast there wasn't a full data capture.

Turning Flash protected mode off seems to have fixed the problem........but isn't that exposing me to a security risk that I would not be exposed to if I were using another browser that didn't have this plug-in issue?

Protected mode is useful because it lowers the privilege level of Flash content and therefore limits what the media is allowed to do on the system. The big Flash exploits that make the news are bypassing protected mode in all browsers, but nevertheless, it's still a worthwhile feature for more run-of-the-mill content.

With the feature off, it should be your goal only to run Flash media you can trust. This is where click-to-play could be useful ("Ask to Activate" permission for Flash). This delays Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

If you want finer control: This extension addresses the issue of only wanting some videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it myself)

I'm puzzled by the crash report; it seems partially blank like the crash happened so fast there wasn't a full data capture. <blockquote> Turning Flash protected mode off seems to have fixed the problem........but isn't that exposing me to a security risk that I would not be exposed to if I were using another browser that didn't have this plug-in issue? </blockquote> Protected mode is useful because it lowers the privilege level of Flash content and therefore limits what the media is allowed to do on the system. The big Flash exploits that make the news are bypassing protected mode in all browsers, but nevertheless, it's still a worthwhile feature for more run-of-the-mill content. With the feature off, it should be your goal only to run Flash media you can trust. This is where click-to-play could be useful ("Ask to Activate" permission for Flash). This delays Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. ''If you want finer control:'' This extension addresses the issue of only wanting ''some'' videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tried it myself)

Question owner

Thanks. Sounds fine as a temporary fix, but as Flash ran fine in protected mode under Win 8.x presumably a fix will be in the offing to address this soon?

Thanks. Sounds fine as a temporary fix, but as Flash ran fine in protected mode under Win 8.x presumably a fix will be in the offing to address this soon?

Question owner

Just tried the "Ask to Activate" feature. I like that and will see how it works day to day. Flash isn't the best software citizen anyway so having some discretion over its behavior may not be a bad thing.

Just tried the "Ask to Activate" feature. I like that and will see how it works day to day. Flash isn't the best software citizen anyway so having some discretion over its behavior may not be a bad thing.

Question owner

A few more: https://crash-stats.mozilla.com/report/index/bp-b895e0cd-dbd3-4852-8c04-296832150821 https://crash-stats.mozilla.com/report/index/bp-8d460506-0b77-4336-842a-ceece2150821 https://crash-stats.mozilla.com/report/index/bp-d153eca2-d104-45d3-b9b6-ebb592150821 Does Norton typically intercept Flash instrusions that Flash fails to block?
jscher2000
  • Top 10 Contributor
8871 solutions 72589 answers

The two latest Flash crashes are linked to a bug that seems to affect sites where Flash gains access to the camera and/or microphone such as chat sites or audio recording sites. The bug report is specific to Windows 10, but the issue affects older versions of Firefox as well as current, so it could have been triggered by a Flash update or a Microsoft change.

Adobe is aware of it, but I couldn't find their bug report on it. In Mozilla's bug report, I didn't see any workaround for this issue. You might to use a different browser for sites where you use your webcam and/or microphone for the time being.

Regarding a protected mode fix, I really have no idea. (sad face here)

The two latest Flash crashes are linked to a bug that seems to affect sites where Flash gains access to the camera and/or microphone such as chat sites or audio recording sites. The bug report is specific to Windows 10, but the issue affects older versions of Firefox as well as current, so it could have been triggered by a Flash update or a Microsoft change. Adobe is aware of it, but I couldn't find their bug report on it. In Mozilla's bug report, I didn't see any workaround for this issue. You might to use a different browser for sites where you use your webcam and/or microphone for the time being. Regarding a protected mode fix, I really have no idea. (sad face here)
jscher2000
  • Top 10 Contributor
8871 solutions 72589 answers

I'm not sure how Norton works with Flash or with plugin-container.exe. There is a free program (free for home use) that claims to block exploits from escaping your browsers. I haven't tried it myself: https://www.malwarebytes.org/antiexploit/

I'm not sure how Norton works with Flash or with plugin-container.exe. There is a free program (free for home use) that claims to block exploits from escaping your browsers. I haven't tried it myself: https://www.malwarebytes.org/antiexploit/
geraa48 2 solutions 50 answers

I saw a reply somewhere that I can't find again now which suggested TURNING OFF PROTECTED MODE in flash settings on firefox flash plugin, HAVE DONE SO AND IT SEEMS TO HAVE WORKED !!!!!!! :-)

I saw a reply somewhere that I can't find again now which suggested TURNING OFF PROTECTED MODE in flash settings on firefox flash plugin, HAVE DONE SO AND IT SEEMS TO HAVE WORKED !!!!!!! :-)