Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 10 isn't allowing me to change the defalut browser to mozila?

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

for some reason i can't change the default browser settings it just doesn't change how do i fix it ?

All Replies (2)

more options

Goto settings/Select the Advanced panel(genereally a three lined bar on right corner), click the General tab, and then click Make Firefox the default browser. The Set Default Programs window will open. In the Set Default Programs window, select Firefox from the list of programs on the left and click Set this program as default. Then click OK to close the window.

If this solves your problem click 'Solved for the reply'.

more options