Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default Page For New Tab With New Tabs Experience

  • 7 replies
  • 17 have this problem
  • 2295 views
  • Last reply by ideato

more options

My firefox just updated and I have been inundated with this 'New Tab Controls' Experience which seems to have disabled my set custom home page for new tab opens. I still the page I want to open set in browser.newtab.url in about:config, but the "New Tab Controls" experience is overriding it, showing me a blank page with a toolbar on the right allowing me to choose either a blank page or showing my top sites.

Chosen solution

Hello Tcalp, yes from 41 the browser.newtab.url preference is abused and should be removed (bug Bug 1118285)

try to install the next add-on : New Tab Override (browser.newtab.url replacement), and after that, modify (double-click on it) the next preference

  • extensions.newtaboverride@agenedia.com.url

to about:newtab

probably now you are able again to set your pages.


thank you

Read this answer in context 👍 3

All Replies (7)

more options

Chosen Solution

Hello Tcalp, yes from 41 the browser.newtab.url preference is abused and should be removed (bug Bug 1118285)

try to install the next add-on : New Tab Override (browser.newtab.url replacement), and after that, modify (double-click on it) the next preference

  • extensions.newtaboverride@agenedia.com.url

to about:newtab

probably now you are able again to set your pages.


thank you

more options

Hello, for unknown reason, this add-on does not work for me. Any ideal what happen? Reinstalled Firefox 41 and repeatedly downloaded this add-on but still not working. Any ideal ?

more options

If an extension that modifies the new tab page isn't working then you might have multiple extensions installed that try to set the new tab page and they might not be compatible with each other.

Classic Theme Restorer includes this feature as well. In current CTR versions (1.3.9+) you find "New tab page url" in the Tabs (1) section.

There is this extension if you use the home page as the new tab page.

You can use these special pages for the new tab page or use the URL of a web page. the default new tab page with the tiles is about:newtab

  • the default home page is about:home
  • for a blank page you can use about:blank
  • for Super Start you can use about:superstart
more options

I just want Google.com as new tab page, don't need homepage for every new tab. browser.newtab.url in about:config is "Google.com". However, the extension override looks like following:

Extensions.newtaboverride@agenedia.com.sdk.dbaseURI Extensions.newtaboverride@agenedia.com.sdk.domain Extensions.newtaboverride@agenedia.com.sdk.load.reason Extensions.newtaboverride@agenedia.com.sdk.rootURI Extensions.newtaboverride@agenedia.com.sdk.dversion Extensions.newtaboverride@agenedia.com.url

The first 5 extension status is "user set", the 6th is "default" and value is "about:newtab". Is these first 5 extension causing the trouble because of multiple downloaded? Can I just delete the first 5 extensions and leave 6th ?

more options

Hi mingy1, it sounds as though you just need to change the last preference to the page you want. Or you can use the interactive settings page as described below, but I don't think you should delete the other preferences .

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override and click its Options button. (See first screen shot attached.)

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.

Success?

more options

Hi jscher200, thanks for instruction. It (the second screen) was default to "about:newtab" and it brings up the tiles although browser.newtab.url in about:config is set to "Google.com". When I changed to full URL "Google.com", it's finally working as I want to bring up the old fashion Google search engine for new tab. So the tricky is 1) download the New Tab Override (browser.newtab.url replacement) 2) modify (double-click on it) the next preference,

   extensions.newtaboverride@agenedia.com.url, 

to (URL you want), not "about:newtab".

Thanks so much for your information.

more options

mingy1 said

Hi jscher200, thanks for instruction. It (the second screen) was default to "about:newtab" and it brings up the tiles although browser.newtab.url in about:config is set to "Google.com". When I changed to full URL "Google.com", it's finally working as I want to bring up the old fashion Google search engine for new tab. So the tricky is 1) download the New Tab Override (browser.newtab.url replacement) 2) modify (double-click on it) the next preference, extensions.newtaboverride@agenedia.com.url, to (URL you want), not "about:newtab". Thanks so much for your information.

Hi, :-), see : https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/reviews/725778/

thanks