X
Tap here to go to the mobile version of the site.

Support Forum

Hardware acceleration in Windows 10 is not working - NVIDIA

Posted

High CPU usage on Youtube - hardware acceleration not working. (Windows 10 - NVIDIA)

about:support - http://i.imgur.com/Y8V2UoU.png?1

Firefox - http://i.imgur.com/jTXKaEt.png

Chrome - http://i.imgur.com/rquAwzL.png

Edge - http://i.imgur.com/CtFVnFk.png

High CPU usage on Youtube - hardware acceleration not working. (Windows 10 - NVIDIA) about:support - http://i.imgur.com/Y8V2UoU.png?1 Firefox - http://i.imgur.com/jTXKaEt.png Chrome - http://i.imgur.com/rquAwzL.png Edge - http://i.imgur.com/CtFVnFk.png

Additional System Details

Installed Plug-ins

  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • VLC media player Web Plugin

Application

  • Firefox 40.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Download YouTube Videos as MP4 1.8.3.1-signed ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • FlashGot 1.5.6.12.1-signed ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Omnibar 0.7.28.20141004.1-signed (omnibar@ajitk.com)
  • Super Drag 0.15.1-signed (superdrag@enjoyfreeware.org)
  • GNotifier 1.8.9.1-signed (jid1-OoNOA6XBjznvLQ@jetpack) (Inactive)
  • User Agent Overrider 0.2.5.1-signed (useragentoverrider@qixinglu.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 660 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1183
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-22-2015
  • driverDate2:
  • driverVersion: 10.18.13.5362
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11 WARP

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23532 answers

hi, it is unfortunate, but since this driver version is responsible for a widespread crashing issue for people updating to windows 10, it is blocklisted for hardware acceleration, until this problem is resolved...

however the issue on youtube might be of a different nature - if you look at your graphics section in about:support it says "supports hardware h264 decoding: false", which sounds a bit like bug 1178098

hi, it is unfortunate, but since this driver version is responsible for a widespread crashing issue for people updating to windows 10, it is blocklisted for hardware acceleration, until this problem is resolved... however the issue on youtube might be of a different nature - if you look at your graphics section in about:support it says "supports hardware h264 decoding: false", which sounds a bit like [https://bugzilla.mozilla.org/show_bug.cgi?id=1178098 bug 1178098]

Helpful Reply

Hi philipp,

With regard to the youtube issue, it is only that when I updated my Firefox did the problem exists. Even the appearance of fonts were affected as I think because of the DirectWrite.

Just a note. All browsers posted above used HTML5 during the test.

Thank you

Hi philipp, With regard to the youtube issue, it is only that when I updated my Firefox did the problem exists. Even the appearance of fonts were affected as I think because of the DirectWrite. Just a note. All browsers posted above used HTML5 during the test. Thank you
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23532 answers

Helpful Reply

yes, it is expected that the change is just recognizable after the update to firefox 40, since 39 was not tweaked to process win10 specific blocklist entries yet.

in case you didn't have a crashing problem before, you might look at https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#How_to_force-enable_blocked_graphics_features in order to re-enable Direct2D/layers acceleration.

yes, it is expected that the change is just recognizable after the update to firefox 40, since 39 was not tweaked to process win10 specific blocklist entries yet. in case you didn't have a crashing problem before, you might look at https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#How_to_force-enable_blocked_graphics_features in order to re-enable Direct2D/layers acceleration.

Question owner

I came with an interesting yet confusing result. I tried to force enable the blocked graphics features:

- webgl.force-enabled=true. - webgl.msaa-force=true. - layers.acceleration.force-enabled=true. - gfx.direct2d.force-enabled=true.

Then after restarting Firefox, it would only display a white screen with only the minimize, maximize and close buttons present. So I run Firefox into safe-mode and revert the graphics features to disabled.

- Now the "supports hardware h264 decoding: false" is set to "true" - Fonts returned to normal even if DirectWrite is still disabled in the config. - CPU usage on youtube returned to normal.

about:config - http://i.imgur.com/occz3Lo.png Normal CPU usage - http://i.imgur.com/L6tI6gR.png

However using this test produced another result -https://developer.mozilla.org/media/uploads/demos/p/a/paulrouget/8bfba7f0b6c62d877a2b82dd5e10931e/hacksmozillaorg-achi_1334270447_demo_package/HWACCEL/

Before - High CPU usage (30%+) 30-45fps After - Lower CPU usage but still higher than normal (28%) but 60fps

I came with an interesting yet confusing result. I tried to force enable the blocked graphics features: - webgl.force-enabled=true. - webgl.msaa-force=true. - layers.acceleration.force-enabled=true. - gfx.direct2d.force-enabled=true. Then after restarting Firefox, it would only display a white screen with only the minimize, maximize and close buttons present. So I run Firefox into safe-mode and revert the graphics features to disabled. - Now the "supports hardware h264 decoding: false" is set to "true" - Fonts returned to normal even if DirectWrite is still disabled in the config. - CPU usage on youtube returned to normal. about:config - http://i.imgur.com/occz3Lo.png Normal CPU usage - http://i.imgur.com/L6tI6gR.png However using this test produced another result -https://developer.mozilla.org/media/uploads/demos/p/a/paulrouget/8bfba7f0b6c62d877a2b82dd5e10931e/hacksmozillaorg-achi_1334270447_demo_package/HWACCEL/ Before - High CPU usage (30%+) 30-45fps After - Lower CPU usage but still higher than normal (28%) but 60fps
HPDeskjet 1 solutions 14 answers

This seems to now be fixed with the release of FF 40.0.2, when used in conjunction with Nvidia Windows 10 (355.60 for desktops) drivers.

This seems to now be fixed with the release of FF 40.0.2, when used in conjunction with Nvidia Windows 10 (355.60 for desktops) drivers.
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23532 answers

the blocklist entry for the nvidia driver was removed - this isn't tied to a particular release, since firefox installations will update the blocklist once every day...

the blocklist entry for the nvidia driver was removed - this isn't tied to a particular release, since firefox installations will update the blocklist once every day...