Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't update autocomplete settings after loading the page (ex: gmail login page)...)

  • 1 reply
  • 1 has this problem
  • 99 views
  • Last reply by negtrick

more options

Firefox doesn't remember form entries even if autocomplete parameter has been deleted for a form field AFTER loading the page (javascript...).

For example, Firefox does anymore remember emails in Gmail login page. If you delete all your history and you try to connect several time, you will have to type your email by hand each time.

I think Google has changed the code of the login page by adding "autocomplete="off" to the email field. But when you rigth-click in the field, and "inspect element", you will not see it. You have to right-click on the page and choose "view source". Then you will see "autocomplete="off" for an (hidden) email field.

No problem with others browsers (Iron or IE).

Is there any way to force FF to remember form entries even if autocomplete is set to off on load?

Chosen solution

negtrick said

Firefox doesn't remember form entries even if autocomplete parameter has been deleted for a form field AFTER loading the page (javascript...). For example, Firefox does anymore remember emails in Gmail login page. If you delete all your history and you try to connect several time, you will have to type your email by hand each time. I think Google has changed the code of the login page by adding "autocomplete="off" to the email field. But when you rigth-click in the field, and "inspect element", you will not see it. You have to right-click on the page and choose "view source". Then you will see "autocomplete="off" for an (hidden) email field. No problem with others browsers (Iron or IE). Is there any way to force FF to remember form entries even if autocomplete is set to off on load?

To reproduce the problem:

- Take a virgin FF profil - Go to Gmail, deactive checkbox "Stay connected" and connect - Refuse to save password for this website - Disconnect - Re connect et verify that FF prompt with the last email entered by doucle clicking in the email field or by typing "↓"

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

negtrick said

Firefox doesn't remember form entries even if autocomplete parameter has been deleted for a form field AFTER loading the page (javascript...). For example, Firefox does anymore remember emails in Gmail login page. If you delete all your history and you try to connect several time, you will have to type your email by hand each time. I think Google has changed the code of the login page by adding "autocomplete="off" to the email field. But when you rigth-click in the field, and "inspect element", you will not see it. You have to right-click on the page and choose "view source". Then you will see "autocomplete="off" for an (hidden) email field. No problem with others browsers (Iron or IE). Is there any way to force FF to remember form entries even if autocomplete is set to off on load?

To reproduce the problem:

- Take a virgin FF profil - Go to Gmail, deactive checkbox "Stay connected" and connect - Refuse to save password for this website - Disconnect - Re connect et verify that FF prompt with the last email entered by doucle clicking in the email field or by typing "↓"