Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to block sound from pages listed in the new tab page

  • 3 replies
  • 1 has this problem
  • 40 views
  • Last reply by jscher2000

more options

When I have visited a web page that plays a sound, and that page shows as a tile on the new tab page, then every time I open the new tab page, the sound plays. This is rather annoying.

For example, I have visited this page: http://lotto.pch.com/ and it now shows as a tile on the new tabs page. Every time I open the new tab page, the sound from this page plays. This is just one example I could find quickly, It has happened on other pages as well.

I assume this is a ".wav" file, but I could not see any ".wav" files in the page source. It is probably being played through a ".js" file that is loaded when the page loads.

How can I stop sound files on pages listed in the new tab page from playing when I open the new tab page?

I am currently running Firefox v-31.0, but it also happens on Firefox v-37.0.2.

Modified by ff2fan

All Replies (3)

more options

I didn't find any solution in advanced configuration of Firefox to do what you want. Moreover, pages in new tab page seem to be in the cache of the browser, that means when the page content has been loaded one time, it is saved for the other times.

But I propose you an alternative solution: since there isn't a lot of pages with sound which are automatically displayed in the new tab page, you can manually delete the thumbnail with the sound by clicking on the cross in its upper right corner. Firefox will remember this choice for later and won't display any more this website on the new tab page.

more options

since this is a reproducible problem, i've filed a bug about this: https://bugzilla.mozilla.org/show_bug.cgi?id=1183044

more options

Hi ff2fan, I tested that site and what I noticed was that its "thumbnail" on the new tab page was blank. I think the sound playing is related to the missing image, and Firefox retrieving the entire page (including audio) in the process of trying to create it in the background.

Were you able to resolve the issue using the little "X" icon that appears in the upper right corner over the tile (while you hover the mouse over it)?