X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Wav files won't play in Firefox 22

Posted

Wav files won't play in Firefox 22. Previous versions of Firefox are fine. Other sound is fine. I have the latest mac OS X. Quicktime is set to play wav files. I have the latest version of it.

Is there a fix for this?

Is there any other plugins I can install which will play the wav files?

Modified by Sun-flower

Chosen solution

I found the following bug (looks like it will be fixed in Firefox 23)

  • Bug 890516 - Embedded audio stopped working after installing FF 22
Read this answer in context 4

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Picasa plugin.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

The QuickTime plugin should play wav files in Firefox 22 as long as they are served with the correct content type and your Applications list is set to open them with the QuickTime plugin. Ref: Set how Firefox handles different types of files

According to my about:plugins list, my QuickTime Plug-in version 7.7.4 is enabled and should open WAVE audio files served with the audio/x-wav and audio/wav content types. I've attached an image of what I see in the Firefox Applications list for wav.

On windows, this wav file opens in my QuickTime plugin:

Does that link work for you? If it does, then do you have a link to a wave file where it doesn't wotk?

Question owner

Thank you for your reply. The mystery thickens. I was able to play your woptheme.wav file.

In Application Preferences (Mac OS X) I have "Use Quicktime Plugin" for audio/wav though there is no entry for audio/x-wav.

I have changed no settings anywhere. Everything was all right with all previous Firefox versions. Then I installed Firefox 22 and suddenly I had a problem with sound.

The specific sound that no longer works is a wav file which notifies me when I have a new email on my webmail. It still works OK with Safari but somehow stopped working when I installed Firefox 22. When I re-install Firefox 21, it works again. When I re-update to Firefox 22 it stops working again. Yet I can play the wav file you left for me, so I do not understand it.

I do not know what to do or what is causing the problem.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Hello Sun-flower, see in the first link AliceWyman gave us (Set how Firefox handles different types of files) the Adding download actions session, if for a reason does not exist then you must create that action for the specific entry (audio/x-wav).


thank you

Question owner

Thank you for your advice ideato.

I had wondered if my problem was due to the fact that I had no entry for audio/x-wav in my Applications options so I went back to Firefox 21 which had no problems playing my wav sound and discovered that there is also no entry for audio/x-wav yet the wav sound plays OK so it can't be that, unfortunately.

ideato
  • Top 25 Contributor
616 solutions 4260 answers

The specific sound that no longer works, you get it from a program(application), like Google notifier or Notify mail ? if yes, check if the program changed the option or if the program is not compatible with the 22.0 firefox.

it is a program ? if yes which program ?


thanks

Question owner

Thank you for trying to help me with my problem, ideato.

Specifically it is my Webmail new email notification sound that no longer works with Firefox 22. It is related to the webmail site which plays the wav sound when a new email arrives for me. I checked with the webmail company who are not aware of the problem. Strangely, it is just with Firefox 22 that does not play the sound. I have just switched back to Firefox 21 and the sound is fine again. Maybe it will rectify itself again with future versions of Firefox. I do not know what else could fix the problem or what could be causing the problem. It has never happened before. It just seems to be the Webmail wav sound. Other wav sounds play OK.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Any luck with disabling wav in Firefox by setting the media.wave.enabled pref to false on the about:config page?

Question owner

Unfortunately, cor-el, there was no joy with trying this.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

Question owner

I have now tried this but my wav sound, sadly, still does not work. Many thanks for trying to help me.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Can you post a link to a page that contains such a not working wav file?

Then someone on a Mac can test this, I'm on Linux, so things may be different.

Question owner

Thank you but I don't think this is possible. There is no link to send. It is a Webmail feature. It automatically activates when a new email is received - a sound is heard to alert you that a new email has arrived. Another mac user would have to be signed into their own email account on the webmail, which is www.Cotse.net if there ARE any mac users with an email account with them.

Modified by Sun-flower

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Just to clarify, I checked on a computer running Mac OS X 10.6 and the about:plugins list in Firefox 22 (which you can see by entering about:plugins in the address bar) shows that my QuickTime 7.6.6 plugin handles WAVE audio files served with both the audio/x-wav and audio/wav content types. Could you check that?

In the Firefox Preferences Applications panel on Mac, I see both Wave Audio file and iTunes Document (audio/wav) listed. I found them quickly when I entered wav in the search bar. You should also see two entries for wav, if the QuickTime plugin is set to handle both content types. Your entries could also have different names.

As for the issue with new mail notification for your www.Cotse.net Webmail, this isn't a Firefox feature. Do you have a Firefox extension installed for webmail notifiications? You can find your extensions listed in the Firefox "Help -> Troubleshooting Information" page, or in "Tools -> Add-ons -> Extensions".

Why the new e-mail sound notification worked in Firefox 21 but not in Firefox 22, I don't know but it's probably something that your webmail provider needs to check into,

Modified by AliceWyman

Question owner

Thank you for your response Alice.

I checked about:plugins and I DO have audio/wav and audio/x-wav. It it QuickTime 7.7.1 I have.

In Firefox Preferences Applications Panel I do not seem to have the iTunes.Document audio/x-wav there, only the audio/wav and Waveform Audio.

Re the New Email Notification feature with my Webmail, this is not activated via a Firefox extension. I don't really know how it works but when I'm logged into my Webmail email account and a new email arrives, a wav sound is played to alert me of the new email. This has always happened with all previous versions of Firefox, just not since I updated to Firefox 22 but when I go back to Firefox 21, it works again.

I have previously asked about this with my Webmail company. They knew nothing of this problem. I have now asked them for a second time now that I know that it is only THEIR wav sound that won't play. Other wav files play OK with Firefox 22.

I do not know what is at fault - Firefox 22, QuickTime or the Webmail site but for the past few days I have frequently switched between Firefox 22 and Firefox 21. Each time the New Email Notification wav sound works with Firefox 21 and doesn't with Firefox 22 so that makes me suspect that somehow Firefox 22 is at fault.

But it is a mystery and I might be stuck with it - unless it disappears as mysteriously as it arrived with a newer version of Firefox or maybe even a newer version of Quicktime.

Thank you to everybody who has tried to help me.

Modified by Sun-flower

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Does that sound still play if you run Firefox 21 in Safe Mode and possibly with plugins disabled in case other software is responsible for this sound?

Question owner

I have just tried this. The sound still played in Safe Mode with Firefox 21 (which does not have the problem). I disabled each plugin one by one. The email wav sound still played except when I disabled Quicktime then worked again when I re-enabled it.

Question owner

I have heard back from my Webmail company. There is only one other person who has reported the problem. That is likely to have been me, I think. The problem does not appear to be caused by them.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

If you still get this sound then it isn't done via an extension, but must be embedded in the web page.

You could try to check the page source (Command+A to select all and View Selection Source in the right-click context menu) to see if you can locate the object or embed or audio tag that is used to play the sound.

Question owner

Yes, maybe it is embedded in the web page. I successfully tried your suggestion and got a very long page of data but I am afraid I could not understand it so I could not locate what you say I should try to find.

Is there anything specific that I could ask my Webmail company that would be useful to find out, if they know?

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You can try to search (Command+F) for each of these: <object and <embed and <audio (one at the time) to see if anything comes up that is related to playing this notification.