X
Tap here to go to the mobile version of the site.

Support Forum

Can't set homepage when Firefox loads

Posted

My homepage has recently changed itself, although I did not authorize this change. I want it to be msn.com, but now it displays either bing.com or the blank Firefox page seen after clicking the "Reset" button on the Options page.

I've tried entering msn.com into the Home section of the Options page, and also dragging the msn.com tab to the Home button of my browser. MSN loads when I click the Home button, but on startup, one of the other pages loads. Again, I made zero changes to my homepage settings myself. I'd greatly appreciate any advice.

Thanks in advance.

My homepage has recently changed itself, although I did not authorize this change. I want it to be msn.com, but now it displays either bing.com or the blank Firefox page seen after clicking the "Reset" button on the Options page. I've tried entering msn.com into the Home section of the Options page, and also dragging the msn.com tab to the Home button of my browser. MSN loads when I click the Home button, but on startup, one of the other pages loads. Again, I made zero changes to my homepage settings myself. I'd greatly appreciate any advice. Thanks in advance.

Chosen solution

Good news! By hovering over the user.js file and taking a screen shot of its location, I was able to find the file using My Computer and then delete it. Since then, Firefox *seems* to be loading my intended homepage on each new startup. Therefore, I should be in good shape in terms of this issue.

Thanks to all for the help. Much appreciated.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • GEPlugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • PDF-XChange Viewer Netscape Gecko Plugin
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • 5.1.31211.0
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 40.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Norton Toolbar 2015.5.0.113 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 21b7103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 3-16-2015
  • driverDate2:
  • driverVersion: 10.18.14.4170
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
snitch_ninja 1 solutions 14 answers

Is "When Firefox starts" set to "Show my home page"?

Do all the settings look correct in the options ?

Is "When Firefox starts" set to "Show my home page"? Do all the settings look correct in [http://about:preferences#general the options] ?

Question owner

Indeed, "Show my homepage" (msn.com) has been selected in my options. All the other settings look fine, and I've double- and triple-checked them. For some reason, though, MSN still won't load when I start Firefox. Thoughts?

Thanks for your help.

Indeed, "Show my homepage" (msn.com) has been selected in my options. All the other settings look fine, and I've double- and triple-checked them. For some reason, though, MSN still won't load when I start Firefox. Thoughts? Thanks for your help.
snitch_ninja 1 solutions 14 answers

Maybe some other program has decided that you want bing.com as your hompage... have you tried reinstalling Firefox?

Do you have any extensions? (options > Add-Ons > Extensions)

Maybe some other program has decided that you want bing.com as your hompage... have you tried reinstalling Firefox? Do you have any extensions? (options > Add-Ons > Extensions)
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Helpful Reply

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check if it has effect if you start Firefox in Safe Mode by holding down the Shift/Options key.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program. You can check if it has effect if you start Firefox in <u>[[Safe Mode|Safe Mode]]</u> by holding down the Shift/Options key.

Question owner

  • Update: Now, instead of bing.com, Firefox loads the last page that was up the last time I closed it.
  • If I reinstalled Firefox, would I have to save my favorites/bookmarks and settings so that I don't lose them?
  • My two extensions are Ad Block Plus (enabled) and Norton Toolbar (disabled).
  • The target line in the Properties window reads as follows: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" (including quotation marks)
  • The issue does appear in Safe Mode, along with standard mode.

Any additional advice? Thanks in advance.

* Update: Now, instead of bing.com, Firefox loads the last page that was up the last time I closed it. * If I reinstalled Firefox, would I have to save my favorites/bookmarks and settings so that I don't lose them? * My two extensions are Ad Block Plus (enabled) and Norton Toolbar (disabled). * The target line in the Properties window reads as follows: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" (including quotation marks) * The issue does appear in Safe Mode, along with standard mode. Any additional advice? Thanks in advance.
snitch_ninja 1 solutions 14 answers
Update: Now, instead of bing.com, Firefox loads the last page that was up the last time I closed it.

What do you mean, the last page? If you have multiple tabs open, does it open all of them? Or the most recently opened tab?

Theres a setting for opening all the last tabs. But about reinstalling:

(This wont delete any of your personal data, like bookmarks, as those are stored in AppData.)

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

<blockquote> Update: Now, instead of bing.com, Firefox loads the last page that was up the last time I closed it. </blockquote> What do you mean, the last page? If you have multiple tabs open, does it open all of them? Or the most recently opened tab? Theres a setting for opening all the last tabs. But about reinstalling: (This wont delete any of your personal data, like bookmarks, as those are stored in AppData.) Hello, Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from [https://www.mozilla.org mozilla.org] (or choose the download for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]) and save the setup file to your computer. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the close button [[Image:Close 29]]). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox|here]]. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be easily recovered unless they have been backed up to an external device!</u> See [[Back up and restore information in Firefox profiles]]. <!-- Starting in Firefox 31, the Firefox uninstaller no longer lets you remove user profile data.Ref: Bug 432017 and https://support.mozilla.org/kb/uninstall-firefox-from-your-computer/discuss/5279 [Fx31] Windows uninstaller will no longer offer the option to remove personal data --> Please report back to say if this helped you! Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Helpful Reply

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the current Firefox profile folder:

The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can check if you have a user.js file in the Firefox profile folder that sets the <b>browser.sessionstore.resume_session_once</b> pref to true. *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself.

Question owner

Indeed, a user.js file did show up in my Firefox profile window. I tried to delete it, but couldn't. The only options were to open, open in new tab, and so on since it was a hyperlink on my profile page. No results were found during a Windows search for "user.js", either. How else might I go about deleting this file?

When I start Firefox, the last active page that was open (the last time I closed) appears. For example, if my last active window was Google, then Google appears on startup. Same for any other page that was the last one I'd opened.

I appreciate the info about reinstalling Firefox. However, I'd like to try to delete this user.js file first to see if it fixes my problem. Hopefully it will, but if not, I'll try the reinstall.

Thanks again for the help.

Indeed, a user.js file did show up in my Firefox profile window. I tried to delete it, but couldn't. The only options were to open, open in new tab, and so on since it was a hyperlink on my profile page. No results were found during a Windows search for "user.js", either. How else might I go about deleting this file? When I start Firefox, the last active page that was open (the last time I closed) appears. For example, if my last active window was Google, then Google appears on startup. Same for any other page that was the last one I'd opened. I appreciate the info about reinstalling Firefox. However, I'd like to try to delete this user.js file first to see if it fixes my problem. Hopefully it will, but if not, I'll try the reinstall. Thanks again for the help.
John99 971 solutions 13138 answers

If it is hyperlink are you able to right click it and find its properties ? What is it pointing at and what is that file's content ? (User js is normally a short text fil)

I also would expect it to be possible to right click and delete it. See

The forum software did pick up that you had a user.js file (see the link on the right towards the top: Question Details -> More System Information) That also indicates you are using Firefox 40 which is odd

If it is hyperlink are you able to right click it and find its properties ? What is it pointing at and what is that file's content ? (User js is normally a short text fil) I also would expect it to be possible to right click and delete it. See * http://windows.microsoft.com/en-us/windows/create-delete-shortcut#1TC=windows-7 The forum software did pick up that you had a user.js file (see the link on the right towards the top: Question Details -> More System Information) That also indicates you are using Firefox 40 which is odd
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157456 answers

Try to hold the Shift key when you right-click the file to see if that opens a context menu with more items.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that allows to delete the user.js file.

Try to hold the Shift key when you right-click the file to see if that opens a context menu with more items. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that allows to delete the user.js file. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Chosen Solution

Good news! By hovering over the user.js file and taking a screen shot of its location, I was able to find the file using My Computer and then delete it. Since then, Firefox *seems* to be loading my intended homepage on each new startup. Therefore, I should be in good shape in terms of this issue.

Thanks to all for the help. Much appreciated.

Good news! By hovering over the user.js file and taking a screen shot of its location, I was able to find the file using My Computer and then delete it. Since then, Firefox *seems* to be loading my intended homepage on each new startup. Therefore, I should be in good shape in terms of this issue. Thanks to all for the help. Much appreciated.
Rubin Bhandari 24 solutions 211 answers

Trying adding your desired page to homeoage section under startup in General settings. Make sure you have selected when firefox opens show my homepage. Restart your browser if problem persists,let us know.

Trying adding your desired page to homeoage section under startup in General settings. Make sure you have selected when firefox opens show my homepage. Restart your browser if problem persists,let us know.