X
Tap here to go to the mobile version of the site.

Support Forum

When I open a new tab, a new window opens

Posted

I used to be able to open multiple tabs within the same Firefox window. Now, every time I click a link or access an external hyper link, a whole new window opens instead of a new tab in the existing window.

browser.link.open_newwindow is set to integer type and value of 3.

This doesn't seem to matter. The problem persists. I don't want to do a refresh or uninstall and reinstall a fresh copy. What can I do to fix this? Like I said, it was never this way before and it seems to have started happening out of nowhere.

I used to be able to open multiple tabs within the same Firefox window. Now, every time I click a link or access an external hyper link, a whole new window opens instead of a new tab in the existing window. browser.link.open_newwindow is set to integer type and value of 3. This doesn't seem to matter. The problem persists. I don't want to do a refresh or uninstall and reinstall a fresh copy. What can I do to fix this? Like I said, it was never this way before and it seems to have started happening out of nowhere.

Chosen solution

Try to set browser.link.open_newwindow.override.external to 3 as well.

Did you check your (tab related) extensions?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • GEPlugin
  • Google Update
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Picasa plugin
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • Unity Player 4.5.4f1
  • VLC media player Web Plugin

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Awesome screenshot: Capture and Annotate 2.4.9.1-signed (jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack)
  • LastPass 3.1.95 (support@lastpass.com)
  • Map With Google 1.1.1-signed (jid1-loW864ytUiNY7Q@jetpack)
  • Viewhance 1.0.1 ({00000c4c-fcfd-49bc-9f0d-78db44456c9c})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 760
  • adapterDescription2:
  • adapterDeviceID: 0x1187
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 27653842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 6-17-2015
  • driverDate2:
  • driverVersion: 10.18.13.5330
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 760 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Banban 57 solutions 334 answers

You can have a look at this page, the problem was a bit similar. The option browser.link.open_newwindow doesn't work anymore, whatever the value. The issue is to use add-ons (a few names are given in the link above).

You can have a look at [https://support.mozilla.org/fr/questions/1066069 this page], the problem was a bit similar. The option browser.link.open_newwindow doesn't work anymore, whatever the value. The issue is to use add-ons (a few names are given in the link above).
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157481 answers

Chosen Solution

Try to set browser.link.open_newwindow.override.external to 3 as well.

Did you check your (tab related) extensions?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Try to set browser.link.open_newwindow.override.external to 3 as well. Did you check your (tab related) extensions? *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window