Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can not get my fonts to show correctly in firefox what font types do you display on your browser ???

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

I am using this css in my html

@font-face { font-family: 'Roboto-Thin'; src: url('fonts/Roboto-Thin.woff'); font-weight: normal; font-style: normal; }

Which I have been told is correct but still firefox does not show the font correctly ? It just displays as normal Times text

Kind Regards


Mike

All Replies (2)

more options

I suggest using regular (") quotation marks in CSS instead of (') apostrophes in case that makes any difference.

What is rule applying Roboto-Thin to the body (or other relevant element)?

Is it working in other browsers?


Could you look for any download or CSS errors in Firefox's Web Console?

While viewing your page, open the console in the lower part of the tab using either:

  • command + alt + k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console

On the top line of the console, click Network. Then reload your page bypassing the cache (command+shift+r) and watch for whether the .woff file is requested and if it is, what the status is. Since you are bypassing the cache, you would expect 200.

If the file is downloaded, click over to the Console section and check for any error messages related to the file or its application. Anything?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"