Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Docs Rendering Roboto Weights Wrong

  • 6 replies
  • 1 has this problem
  • Last reply by syberknight

more options

using Firefox 96.0.3 on macOS 12.1

i've been creating some Google Docs this week and using the various Roboto font weights (Light, Thin, Normal, Medium, Bold) to format them with. the majority of the docs are using the "Normal" weight.

suddenly, i came back to it today and ALL the "Normal" weights display as "Medium" and all the "Medium" are displaying as "Normal" - even in the dropdown font selector menu.

it looks normal in Safari. and the Roboto variants look normal when viewing at so it's only in Firefox on Google Docs (as far as i can tell).

i have tried running in Troubleshooting Mode, which didn't change anything. so i event went as far as deleting all Addons, and completely resetting Firefox to factory defaults. the problem persists.

any ideas?

All Replies (6)

more options

You can check in the Inspector what font rules are applied.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window


more options

i tried all those suggestions. and as mentioned, i even completely deleted Firefox and all it's associated files in the system, restarted, then redownloaded/reinstalled. the problem remains.

it looks correct in Safari & Chrome. and it was fine up until the evening of January 27, 2022. the next morning it looked like this. so i don't know what happened over night that night to cause this.

i even installed earlier versions of Firefox, and they even show this problem. very confusing because i've been using this for many months with no problem at all.

i'll attach a screenshot of what Roboto variants look like in the same Google Doc on 3 different computers i could try on. this leads me to think there's some bug between Firefox and the new Mac M1 computers, since the two older ones render it appropriately.

but again, i got this M1 Mac in November & have been using it with Roboto in Gdocs just fine until now. i just don't understand what could have caused this change (nor how to fix it).

thanks for any help/suggestions/ideas.


more options

Did you check in the Inspector what font and font rules are applied to the normal font ?

Do you locally have Roboto fonts installed on your computer ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


more options

yes, i checked the inspector & it's showing Roboto 400 for normal text.

no, i do not have Roboto font installed on my computer.

Google Docs disables the normal right-click menu options with it's own. but i went to the Developer Tools option to see it. there is no "rules" tab, but in the "Fonts" tab i played with the weight, brought it down to 100 but nothing on the page changed.


more options

anyone? anything? does anybody else see this difference (please see my screenshot attached above)?

Modified by syberknight


more options

this is STILL a problem, and everything (macOS & Firefox etc) is up to date. please check out my screenshots comparing the browsers & this font. thx.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.