Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get back search box in a new tab? When I open a new tab it's only show the address bar.

  • 9 replies
  • 3 have this problem
  • 1912 views
  • Last reply by Sharminmz

more options

When I click + to open a new tab,that tab only shows the address bar, no search box! This problem creates suddenly. Before, this problem, when I opened a new tab it shows address bar and google search box. Now, the address bar of new tab page worked as both search box and address bar.

I have followed about:config process and it's worked. But, when I start my computer after few hours again I see that problem! What can I do? Please tell me.

I have attached an image for your understanding.

Chosen solution

I would not try a reinstall just yet. An ordinary reinstall often does not change much that could cause this.

The file user.js will be a small file in your profile and has text content. If you copy it and rename it user.txt or user.js.txt it will be readable by any word processor, although notepad may even open it as it is.

Paste the content into your next reply. It may give us some clue as to what is happening.

In fact the file user.js will be changing Firefox's behavior and you may just wish to temporarily rename; instead of renaming a copy; in order to disable it and see what happens.


Just another thought the usual options used for newtabs

  • about:blank - thats a plain blankpage, no search bar within it.
  • about:newtab - currently by default has a search bar and tiles
  • about:home - a search bar and some settings etc icons

You can try any of those out by typing into the addressbar about:home or whatever, ( or try about:about ).


There are two troubleshooting steps that are simple likely to help, but you do not appear to have tried yet.

First try Firefox's safe mode. For instance by holding the Shift Key when you click on the icon to start Firefox

The second procedure worth trying is creating a new additional profile for test purposes. That clears most settings and will not be affected by the file user.js or interfere with your existing settup. You get the choice which profile to use when you start Firefox.

Read this answer in context 👍 1

All Replies (9)

more options

You need to post a 2nd time to add a screenshot to this thread.

more options

Make sure that toolbars like the "Bookmarks Toolbar" are visible.

  • "3-bar" Firefox menu button > Customize > Show/Hide Toolbars
  • View > Toolbars
    Tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Open the Customize window and set which toolbar items to display.

  • "3-bar" Firefox menu button > Customize
  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the Customize palette into the Customize window to the Bookmarks Toolbar
  • check that the search bar is on the Navigation Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button to restore the default toolbar setup

You may have removed the button(s) from the Navigation Toolbar by accident.

If you right-click a toolbar item in normal (non-customize) mode then you can remove this item from the toolbar.

  • "Remove from Toolbar" will remove this item from the Navigation Toolbar and moves it to the Customize palette ("3-bar" Firefox menu button > Customize)
  • "Move to Menu" will move this item to the "3-bar" Firefox menu button drop-down list
  • "Move to Toolbar" in the "3-bar" Firefox menu button drop-down list will move this item to the toolbar
more options

Okay, I post the same question with a screenshot.

When I click + to open a new tab,that tab only shows the address bar, no search box! This problem creates suddenly. Before, this problem, when I opened a new tab it shows address bar and google search box. Now, the address bar of new tab page worked as both search box and address bar. I have followed about:config process and it's worked. But, when I start my computer after few hours again I see that problem! What can I do? Please tell me. I have attached an image for your understanding.

more options

Does the setting get lost if you close Firefox and start it up again, or only when you shut down and restart Windows?

If it happens with any Firefox shutdown, consider these possibilities:

  • How to fix preferences that won't save - especially whether there is an optional settings file named user.js (Windows may hide the .js)
  • Utility programs like Advanced SystemCare (or security software) that protects against unwanted browser settings changes by rolling back all settings changes
  • Add-on that might want to take over the new tab page but which only is able to display a blank page (speed dial add-on, for example)
more options

You do appear to have a user.js file, per the system details aside.

  • Did you personally add that ?
  • And if not, do you know what did ? and what it contains ?

If you use about:config

  • What is the value of browser.newtab.url is it about:newtab or something else ?
  • Do you notice that value change when the search bar disappears ?
more options

I do see the search bar (placeholder text: search) next to the location/address bar on the Navigation Toolbar in the screenshot.

The search bar has changed in Firefox 34 and later and now only shows a generic search icon and no longer the search engine name and icon.

When you start typing you will see a drop-down with choices for the search engine.

more options

Hello John! I did not add a user.js personally. And I have no idea about this. The value of browser.newtab.url is about:newtab and I have noticed that the value changed in blank when the search bar disappears. Another thing is generally there is a gear icon at the upper right corner in a new tab. In my case this also disappear.

Hello cor-el! I am looking for the search box in the upper middle in a new tab.

By the way, thank you so much all of you! I have a query. If I install the browser again can I get back that?

more options

Chosen Solution

I would not try a reinstall just yet. An ordinary reinstall often does not change much that could cause this.

The file user.js will be a small file in your profile and has text content. If you copy it and rename it user.txt or user.js.txt it will be readable by any word processor, although notepad may even open it as it is.

Paste the content into your next reply. It may give us some clue as to what is happening.

In fact the file user.js will be changing Firefox's behavior and you may just wish to temporarily rename; instead of renaming a copy; in order to disable it and see what happens.


Just another thought the usual options used for newtabs

  • about:blank - thats a plain blankpage, no search bar within it.
  • about:newtab - currently by default has a search bar and tiles
  • about:home - a search bar and some settings etc icons

You can try any of those out by typing into the addressbar about:home or whatever, ( or try about:about ).


There are two troubleshooting steps that are simple likely to help, but you do not appear to have tried yet.

First try Firefox's safe mode. For instance by holding the Shift Key when you click on the icon to start Firefox

The second procedure worth trying is creating a new additional profile for test purposes. That clears most settings and will not be affected by the file user.js or interfere with your existing settup. You get the choice which profile to use when you start Firefox.

Modified by John99

more options

Hello John! I am holding the Shift Key when click on the icon to start Firefox. Then I got an option for restore Firefox. I choose it and it's worked! Get back the search box in new tab.

May be it's a weird problem! But it was very disturbing to me! Thank you so much! Really grateful to you!