X
Tap here to go to the mobile version of the site.

Support Forum

Default zoom is too big

Posted

I just upgraded to Firefox 38 on Ubuntu 14.04/64 bit. Prior to the upgrade, all webpages displayed perfectly normally. Now on v 38, the default zoom is very large. I have to ctl-minus each and every webpage I visit to get the zoom back down to a normal size.. In fact, the entire user interface of 38 is too big.. icons on the bookmark toolbar are far bigger than they were on 37.0.2.. What changed between 37.0.2 and 38??????

Dave

Further update: Tried upgrading from 37.02 to 38 on a Windows 10 tech preview system and do not get the screwed up default zoom...

I just upgraded to Firefox 38 on Ubuntu 14.04/64 bit. Prior to the upgrade, all webpages displayed perfectly normally. Now on v 38, the default zoom is very large. I have to ctl-minus each and every webpage I visit to get the zoom back down to a normal size.. In fact, the entire user interface of 38 is too big.. icons on the bookmark toolbar are far bigger than they were on 37.0.2.. What changed between 37.0.2 and 38?????? Dave Further update: Tried upgrading from 37.02 to 38 on a Windows 10 tech preview system and do not get the screwed up default zoom...

Modified by dfrandin

Chosen solution

Another Ubuntu user posted about this last hour: Firefox graphics scaled up ridiculously after update (unsolved).

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • The IcedTea-Web Plugin executes Java applets.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202
  • Mime Type x-skype for Skype Buttons
  • Version 2.1.4 Rincewind, copyright 1996-2012 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 38.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0/Linux/en-US/

Extensions

  • AmazonSmile 1Button for Firefox 1.0 (smile1Button@amazon.com)
  • ChatZilla 0.9.91.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Clear Cache 2.0.1 (clearcache@michel.de.almeida)
  • Clear Cache Button 0.9f ({563e4790-7e70-11da-a72b-0800200c9a66})
  • ColorZilla 2.8 ({6AC85730-7D0F-4de0-B3FA-21142DD85326})
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • DownThemAll! AntiContainer 1.3.1-signed (anticontainer@downthemall.net)
  • EditCSS 0.3.7 ({A0A87DB2-80BA-493a-B22F-FAFBAEA3E0A2})
  • Element Hiding Helper for Adblock Plus 1.3.2 (elemhidehelper@adblockplus.org)
  • Elite Proxy Switcher 1.2.0.2 (eliteproxyswitcher@my-proxy.com)
  • Extended Copy Menu (fix version) 1.6.1c (extended.copy.menu@fix.version)
  • Extended Statusbar 2.0.3 ({daf44bf7-a45e-4450-979c-91cf07434c3d})
  • feedly 16.0.528 (feedly@devhd)
  • Firebug 2.0.9.1-signed (firebug@software.joehewitt.com)
  • Firefinder for Firebug 1.4 (firefinder@robertnyman.com)
  • FirePHP 0.7.4 (FirePHPExtension-Build@firephp.org)
  • Ghostery 5.4.5 (firefox@ghostery.com)
  • Google Disconnect 2.4.2 (google@disconnect.me)
  • Greasefire 1.0.8.1-signed (greasefire@skrul.com)
  • Greasemonkey 3.1 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Live HTTP headers 0.17 ({8f8fe09b-0bd3-4470-bc1b-8cad42b8203a})
  • NetVideoHunter 1.18 (netvideohunter@netvideohunter.com)
  • Pastebin 3.0 (pastebin.com@gmail.com)
  • ReloadEvery 28.0.2 ({888d99e7-e8b5-46a3-851e-1ec45da1e644})
  • Saved Password Editor 2.9 (savedpasswordeditor@daniel.dawson)
  • SQLite Manager 0.8.3 (SQLiteManager@mrinalkant.blogspot.com)
  • StumbleUpon 4.19 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Stylish 2.0.2 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Super Start 7.3.3 (superstart@enjoyfreeware.org)
  • Theme Font & Size Changer 37.4 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Toggle Web Developer Toolbar 34.0.1-signed ({c75a27d8-4529-449f-b67b-aba65d7a1c0a})
  • uBlock 0.9.1.0 ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Web Developer Toolbar Button 1.12 (webdevelopertoolbarbutton@polygonpla.net)
  • YouTube ALL HTML5 2.1.3 (jid1-qj0w91o64N7Eeg@jetpack)
  • YouTube Control Center 0.3.2 (jid1-CikLKKPVkw6ipw@jetpack)
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack) (Inactive)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com) (Inactive)
  • Unity Websites integration 2014.08.06.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- Quadro FX 770M/PCIe/SSE2
  • adapterDeviceID: Quadro FX 770M/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 331.113
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- Quadro FX 770M/PCIe/SSE2
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
6447 solutions 52783 answers

Helpful Reply

I think your distribution includes platform-specific extensions, so I suggest testing with those disabled in case there is a compatibility issue with Firefox 38. One way to do that is to run in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


If that doesn't make any difference, you could try adjusting the setting for High DPI support, which operates as a global zoom factor:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) The layout.css.devPixelsPerPx preference usually is set to -1.0 which means use the system default. You can change that to 1.0 for 96-dpi dispay and see whether that is what you prefer. And you can increase the size from there in increments, for example, 1.1 for a global "110%" zoom.

Please be careful not to set this value to something tiny, as it can be hard to recover from that.

I think your distribution includes platform-specific extensions, so I suggest testing with those disabled in case there is a compatibility issue with Firefox 38. One way to do that is to run in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? ---- If that doesn't make any difference, you could try adjusting the setting for High DPI support, which operates as a global zoom factor: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''pix''' and pause while the list is filtered (3) The '''layout.css.devPixelsPerPx''' preference usually is set to -1.0 which means use the system default. You can change that to '''1.0''' for 96-dpi dispay and see whether that is what you prefer. And you can increase the size from there in increments, for example, 1.1 for a global "110%" zoom. Please be careful not to set this value to something tiny, as it can be hard to recover from that.
jscher2000
  • Top 10 Contributor
6447 solutions 52783 answers

Chosen Solution

Another Ubuntu user posted about this last hour: Firefox graphics scaled up ridiculously after update (unsolved).

Another Ubuntu user posted about this last hour: [https://support.mozilla.org/questions/1061820 Firefox graphics scaled up ridiculously after update] (unsolved).
adamcrume 0 solutions 2 answers

For what it's worth, setting layout.css.devPixelsPerPx to 1.0 fixed it for me.

For what it's worth, setting layout.css.devPixelsPerPx to 1.0 fixed it for me.

Helpful Reply

Same here.. Safe mode did nothing, but layout.css.devPixelsPerPx was set to -1 .. changing it to 1 fixed the problem....

Thanks all!!!

Same here.. Safe mode did nothing, but layout.css.devPixelsPerPx was set to -1 .. changing it to 1 fixed the problem.... Thanks all!!!

Modified by dfrandin

anev942 1 solutions 2 answers

Win 7 64 same issue, though not as bad as OP, recent update to38 default zoom appeared 110%, so was zooming out to 90% for 'normal' appearance. Tried Safe mode showed no change- changing the about:config setting from -1 to 1 fixed.

Win 7 64 same issue, though not as bad as OP, recent update to38 default zoom appeared 110%, so was zooming out to 90% for 'normal' appearance. Tried Safe mode showed no change- changing the about:config setting from -1 to 1 fixed.

Modified by anev942

brumman 0 solutions 2 answers

I had this problem with FF38 on Ubuntu 12.04 and after hours of searching I finally found this thread! Changing layout.css.devPixelsPerPx to 1.4 returned to the normal appearance before the FF38 update. Thanks!

@jscher2000 what do you mean "be careful not to set this value to something tiny, as it can be hard to recover from that." ?

I had this problem with FF38 on Ubuntu 12.04 and after hours of searching I finally found this thread! Changing layout.css.devPixelsPerPx to 1.4 returned to the normal appearance before the FF38 update. Thanks! @jscher2000 what do you mean "be careful not to set this value to something tiny, as it can be hard to recover from that." ?
cor-el
  • Top 10 Contributor
  • Moderator
15475 solutions 140161 answers

If you would set this pref to 0.3 or even smaller then the entire Firefox user interface would shirk to a very small window. You would have to edit the prefs.js file and remove or modify the corresponding line to recover from this.

If you would set this pref to 0.3 or even smaller then the entire Firefox user interface would shirk to a very small window. You would have to edit the prefs.js file and remove or modify the corresponding line to recover from this.