Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Browser Magnified And I don't Know why

  • 12 replies
  • 12 have this problem
  • 5961 views
  • Last reply by jscher2000

more options

Hi! I don't know what is going on but a few days ago my Firefox browser enlarged and I don't know how to get it to size back down to the normal size it was at before.

I don't just mean the webpage content has enlarged but the browser itself looks magnified. The tabs are way bigger than they were before.

Also every time I try to open a new webpage or tab the page content is now enlarged by default. I can zoom it down with ctr+ - , but my pages never used to this before. They used to appear normal sized.

This is what I have tried so far and none of it has worked: For the webpages: ctrl+ - Scales page down for the moment, but wont stop new pages from loading already zoomed. For the browser itself: I went to View>Zoom>Zoom Out but this only affected the webpage content, NOT the browser. I have also tried resetting the computer multiple times-even shutting it down-and the problem is still not fixed. :/

The very top line of the browser looks normal, but everything from the tabs down is too big. If anyone knows how to help me I would appreciate it very much! Thanks so much for your time!!

Chosen solution

Firefox on Windows is now following display scaling options which may render text larger on high resolution displays. Some users may notice that web pages and the browser UI appear magnified in Firefox 22.

The layout.css.devPixelsPerPx preference handles this and lets you fine tune the size of all fonts and other elements in the browser. Start with the default value of the preference, i.e. 1.0. To reduce the font size, use values between 1.0 and 0.5 (do NOT go too low!), to increase the size of fonts, use values greater than 1.0.

To modify it do the following:

  1. Type about:config into the browser's address bar and tap on the enter key.
  2. Confirm that you will be careful if the warning appears.
  3. Filter for layout.css.devPixelsPerPx.
  4. Double-click the entry and change its value - to default 1.0 for starters

Note that changes take effect immediately. You can right-click the preference and select Reset to set it to its default value again.

Read this answer in context 👍 7

All Replies (12)

more options

Chosen Solution

Firefox on Windows is now following display scaling options which may render text larger on high resolution displays. Some users may notice that web pages and the browser UI appear magnified in Firefox 22.

The layout.css.devPixelsPerPx preference handles this and lets you fine tune the size of all fonts and other elements in the browser. Start with the default value of the preference, i.e. 1.0. To reduce the font size, use values between 1.0 and 0.5 (do NOT go too low!), to increase the size of fonts, use values greater than 1.0.

To modify it do the following:

  1. Type about:config into the browser's address bar and tap on the enter key.
  2. Confirm that you will be careful if the warning appears.
  3. Filter for layout.css.devPixelsPerPx.
  4. Double-click the entry and change its value - to default 1.0 for starters

Note that changes take effect immediately. You can right-click the preference and select Reset to set it to its default value again.

more options

Thank you both very much!!! The instructions were clear and helpful and I got it to work very easily :) I really appreciate the help! :)

more options

(Sorry, re-edited post to make it easier to read)

I have the same problem, since updating to FF 22

I've made some changes to the configuration and was able to fix some of the issues, but not all:

FIXED:

  • Problem 1: Embedded images would show up zoomed, and therefore blurry (huge issue for me since I work with art, and I need all images to display at 100%)
  • Solution: I changed "layout.css.devPixelsPerPx" to 1.0. Now the images are the right size, but the font is tiny.

NOT YET FIXED:

  • Problem 2: The font on webpages is tiny. Is there a way to have it automatically zoom the text only, without having to go View -> Zoom -> Zoom Text Only .. and then Ctrl+ + on every single site individually?
  • Problem 3: The text on the Firefox User Interface is too small. The font on menu (I use the old layout with File, Edit, View, etc instead of the newer layout with the orange button), as well as in the bookmarks, and in the address bar - the text on those places is really small after the upgrade to v22.0 and some people in my household are having trouble seeing it.

Please advise. And thanks in advance!

Modified by jhst

more options

You may find the No-Squint add-on useful. NoSquint allows you to adjust the text-only and full-page (both text and images) zoom levels as well as color settings both globally (for all sites) and per site.

Let us know if it helped.

Modified by smo

more options

Hi jhst,

For Problem 3, the most convenient workaround is the Theme Font & Size Changer extension.

Regarding Problem 2, can you give an example URL of a page where the text is much too tiny when images are normal-sized?

Modified by jscher2000

more options

Hi jhst, I also should mention that you can create individual Firefox profiles for different family members so they can have separate settings, bookmarks, history, add-ons, and so forth. This doesn't work completely seamlessly with external programs that launch links in Firefox, but if you would like to explore it further, see: Profile Manager - Create, remove or switch Firefox profiles. (When creating a new profile, please let Firefox create a new folder; re-using an existing folder can cause data loss.)

more options

Try clearing cache and history as explained below

more options

Thank you so much, jscher and smo for your help! :D

>>Regarding Problem 2, can you give an example URL of a page where the text is much too tiny when images are normal-sized?

deviantart.com and twitter.com are two examples right off the bat that I noticed were very small when images were normal sized. I did a Zoom -> Text Only on both after changing the PixelsPerPx setting to 1.0

more options

Hello again. One of my problems was fixed-the size of the browser (NOT THE WEBPAGE CONTENT)-by doing this: To modify it do the following:

  " Type about:config into the browser's address bar and tap on the enter key.
   Confirm that you will be careful if the warning appears.
   Filter for layout.css.devPixelsPerPx.
   Double-click the entry and change its value - to default 1.0 for starters 

Note that changes take effect immediately. You can right-click the preference and select Reset to set it to its default value again. "

But now the problem of web page content being automatically huge by default still hasn't been fixed. :/ I can un-zoom it with ctrl+- but before the OS update webpage content was not huge by default, and I didn't have to un-zoom it all the time. If anyone knows how to fix this I would be very grateful! Thank you so much for your time!!!!

more options

Usually setting layout.css.devPixelsPerPx = 1.0 will show the content area at the old default of 96ppi.

Did you install either NoSquint or Default FullZoom Level? If so, check and adjust the magnification there.

more options

I have the problem with the video playback in firefox. Any website with embeded video's playback is hugely magnified! This happen recently when firefox updated to 24 (beta)How can I fix the video? I've tried the ctrl - but all it does is shrink the webpage..

Also, How do I go back to a stable version of Firefox?

Thanks for your help

more options

Hi LauraE, you have Windows, I assume. Can you check whether you have zoom set to only modify the text size and not the other content.

View menu > Zoom > uncheck Zoom Text Only

(On Windows if you are using the orange Firefox button, tap the Alt key to display the classic menu bar temporarily to access the full View menu.)

You can reinstall Firefox 23.0.1 from here: https://www.mozilla.org/en-US/firefox/all/


In case this is a Flash-related issue, this is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?