X
Tap here to go to the mobile version of the site.

Support Forum

gmail logon screen is wrong and won't accept my password. Url is right. Help!

Posted

I'm on an iMac, OS 10.9.5, Firefox 37.0.2. When I either (1) click on the gmail link from Google's site or (2) type in the gmail url, I get a login screen that only asks for my user name and then allows me to click Next. On the next screen I'm asked for my password. When I enter my password, the screen refreshes but presents the same screen again, with blank fields. This isn't happening if I use Safari. Everything looks/acts right in Safari. I hardly ever use Safari, please don't make me start!

I'm on an iMac, OS 10.9.5, Firefox 37.0.2. When I either (1) click on the gmail link from Google's site or (2) type in the gmail url, I get a login screen that only asks for my user name and then allows me to click Next. On the next screen I'm asked for my password. When I enter my password, the screen refreshes but presents the same screen again, with blank fields. This isn't happening if I use Safari. Everything looks/acts right in Safari. I hardly ever use Safari, please don't make me start!

Chosen solution

Well, it's taken a while and a ton of sleuthing, but problem solved. You were right cor-el, running Safe Mode made it work right. Then I just disabled all the extensions and added them back in one at a time until one of them broke it again. The culprit is Disconnect Search. I even deleted it and downloaded it again hoping it was a version incompatibility, but no go. Grrrrrrrr. I'll message them and let them know what happened.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Musicnotes Viewer plugin 1.19.0 http://www.musicnotes.com
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • doubleTwist Web Plugin

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AddThis 3.6.5 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom)
  • AmazonSmile 1Button for Firefox 1.0 (smile1Button@amazon.com)
  • Disconnect 3.15.3 (2.0@disconnect.me)
  • Disconnect Search 1.4.0 (search@disconnect.me)
  • EPUBReader 1.5.0.6 ({5384767E-00D9-40E9-B72F-9CC39D655D6F})
  • Social Fixer 12.0 (socialfixer@mattkruse.com)
  • Who Deleted Me 0.2.19 (whodeletedme@deleted.io)
  • None 8.0.6 (urladvisor@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

For some reason my screenshot didn't show up, so am re-adding.

For some reason my screenshot didn't show up, so am re-adding.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Does this page work?

This issue can be caused by corrupted cookies or cookies that are blocked.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
Does this page work? *https://accounts.google.com/ServiceLogin?service=mail&continue=https://mail.google.com/mail/ This issue can be caused by corrupted cookies or cookies that are blocked. *check the permissions on the about:permissions page and in "Tools > Page Info > Permissions" *https://support.mozilla.org/kb/fix-login-issues-on-websites-require-passwords Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Question owner

1. That page shows up exactly like the problem I'm having. No change. 2. Have repeated cleared cache and cookies. No change. 3. Have repeatedly removed cookies. No change.

Why would the exact same url return pages with different content on different browsers? Have checked urls to ensure no redirection. So confused.

1. That page shows up exactly like the problem I'm having. No change. 2. Have repeated cleared cache and cookies. No change. 3. Have repeatedly removed cookies. No change. Why would the exact same url return pages with different content on different browsers? Have checked urls to ensure no redirection. So confused.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Thought I'd solved it. Turns out urls weren't identical (though where the broken one came from is a mystery).

Safari: https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/&ss=1&scc=1&ltmpl=default&ltmplcache=2&emr=1&osid=1

Firefox: https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/&ss=1&scc=1&ltmpl=default&ltmplcache=2&emr=1&osid=1#identifier

Don't know what happened. Looks like it still tracks back to Google. Should I worry that I've been typing my password into a fake site?

Thought I'd solved it. Turns out urls weren't identical (though where the broken one came from is a mystery). Safari: https://accounts.google.com/ServiceLogin?service=mail&amp;passive=true&amp;rm=false&amp;continue=https://mail.google.com/mail/&amp;ss=1&amp;scc=1&amp;ltmpl=default&amp;ltmplcache=2&amp;emr=1&amp;osid=1 Firefox: https://accounts.google.com/ServiceLogin?service=mail&amp;passive=true&amp;rm=false&amp;continue=https://mail.google.com/mail/&amp;ss=1&amp;scc=1&amp;ltmpl=default&amp;ltmplcache=2&amp;emr=1&amp;osid=1#identifier Don't know what happened. Looks like it still tracks back to Google. Should I worry that I've been typing my password into a fake site?

Modified by uualpeters

Question owner

Well, I thought I'd solved it, but it keeps coming back. With that #identifier on the end of the url. No amount of clearing cache/cookies or removing cookies makes a difference. Help!

Well, I thought I'd solved it, but it keeps coming back. With that #identifier on the end of the url. No amount of clearing cache/cookies or removing cookies makes a difference. Help!
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

I was already surprised that the appended anchor would be causing this issue. Only if some script would evaluate this anchor then it would make a difference.

You can check the network.http.* prefs on the about:config page to see if any are user set (bold).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


Make sure that you aren't blocking cookies.

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
I was already surprised that the appended anchor would be causing this issue. Only if some script would evaluate this anchor then it would make a difference. You can check the network.http.* prefs on the <b>about:config</b> page to see if any are user set (bold). You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config ----- Make sure that you aren't blocking cookies. You can inspect and manage permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Looks like this may be a result of something our whacky friends at Google are doing. The screen login has now changed on Safari as well, only that login actually works and doesn't send me in an endless loop. Hmmmm. Curiouser and curiouser.

Looks like this may be a result of something our whacky friends at Google are doing. The screen login has now changed on Safari as well, only that login actually works and doesn't send me in an endless loop. Hmmmm. Curiouser and curiouser.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

I'm seeing that split login form as well now. I hadn't seen it before, so maybe Google rolled this out in stages or their servers.

The first pass has: #identifier The second pass has: #password It looks that this is evaluated via JavaScript, so make sure that you aren't blocking any JavaScript. Both fields are present and one has a hidden attribute.

I'm seeing that split login form as well now. I hadn't seen it before, so maybe Google rolled this out in stages or their servers. The first pass has: #identifier The second pass has: #password It looks that this is evaluated via JavaScript, so make sure that you aren't blocking any JavaScript. Both fields are present and one has a hidden attribute.

Modified by cor-el

Question owner

Aha! Thank you for restoring my sense of sanity. I've found a very strange workaround (for now). On the #identifier screen there's also a Help link at the bottom, left, of the screen. If I click that and then use one of the logon links available from there everything works fine because it reverts to the original logon screen that includes password.

I don't think I'm blocking JavaScript or I would be having problems with a lot of other online forms. I'm sorta blocking java (applets), but they're not the same thing. Am attaching my screenshot and it looks just like yours, I think.

Aha! Thank you for restoring my sense of sanity. I've found a very strange workaround (for now). On the #identifier screen there's also a Help link at the bottom, left, of the screen. If I click that and then use one of the logon links available from there everything works fine because it reverts to the original logon screen that includes password. I don't think I'm blocking JavaScript or I would be having problems with a lot of other online forms. I'm sorta blocking java (applets), but they're not the same thing. Am attaching my screenshot and it looks just like yours, I think.

Question owner

Ok... I spoke too soon. It worked for a couple of days just fine, then just now it died again. Am also getting the 2-part logon in Safari, but it seems to recognize me once I click Next after entering my email address. Enough so that it shows my profile above on the password dialog. HELP... really, HELP!

Ok... I spoke too soon. It worked for a couple of days just fine, then just now it died again. Am also getting the 2-part logon in Safari, but it seems to recognize me once I click Next after entering my email address. Enough so that it shows my profile above on the password dialog. HELP... really, HELP!

Chosen Solution

Well, it's taken a while and a ton of sleuthing, but problem solved. You were right cor-el, running Safe Mode made it work right. Then I just disabled all the extensions and added them back in one at a time until one of them broke it again. The culprit is Disconnect Search. I even deleted it and downloaded it again hoping it was a version incompatibility, but no go. Grrrrrrrr. I'll message them and let them know what happened.

Well, it's taken a while and a ton of sleuthing, but problem solved. You were right cor-el, running Safe Mode made it work right. Then I just disabled all the extensions and added them back in one at a time until one of them broke it again. The culprit is Disconnect Search. I even deleted it and downloaded it again hoping it was a version incompatibility, but no go. Grrrrrrrr. I'll message them and let them know what happened.