X
Tap here to go to the mobile version of the site.

Support Forum

FireFox will not go 'Full Screen' . .

Posted

When attempting to use the FULL SCREEN feature by clicking the FS Icon or using the F11 the browser will not go full screen. The Title Bar, Menu Bar, Address Box including my displayed ICONS and my Bookmarks Toolbar will not go up and out of sight as normal. This just started yesterday, thought it may go away by rebooting and it was late so went to bed. Have closed down and reopen Moz FireFox v37.0.2 and still will not go FS. Is there something that may have changed in the 'about:config' command structure, I know about this feature but do not use it.

When attempting to use the FULL SCREEN feature by clicking the FS Icon or using the F11 the browser will not go full screen. The Title Bar, Menu Bar, Address Box including my displayed ICONS and my Bookmarks Toolbar will not go up and out of sight as normal. This just started yesterday, thought it may go away by rebooting and it was late so went to bed. Have closed down and reopen Moz FireFox v37.0.2 and still will not go FS. Is there something that may have changed in the 'about:config' command structure, I know about this feature but do not use it.

Chosen solution

While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is browser.fullscreen.autohide (default value is true).

If that's not it, hmm...

Read this answer in context 25

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 16.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

jscher2000
  • Top 10 Contributor
7298 solutions 59418 answers

Chosen Solution

While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is browser.fullscreen.autohide (default value is true).

If that's not it, hmm...

While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is '''browser.fullscreen.autohide''' (default value is true). If that's not it, hmm...

Question owner

jscher2000 said

While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is browser.fullscreen.autohide (default value is true).

NOTE: Have removed the ". . . hmm..." That did the trick, SOLVED. Thank you very muchly, thought this had to be simple. Do not know how that was unchecked. When in full screen do not find anything about Hide toolbar . . NEVER thought of doing that when in FS.

Great JOB . . . SOLVED my issue . .

''jscher2000 [[#answer-723126|said]]'' <blockquote> While in full screen mode, if you right-click at the very top of the screen, is there a checkmark in front of "Hide Toolbars"? If not, go ahead and click that to turn it back on. The corresponding preference in about:config is '''browser.fullscreen.autohide''' (default value is true). </blockquote> NOTE: Have removed the ". . . hmm..." That '''did''' the trick, '''SOLVED'''. Thank you very muchly, thought this had to be simple. Do not know how that was unchecked. When in full screen do not find anything about Hide toolbar . . NEVER thought of doing that when in FS. '''Great JOB''' . . . '''SOLVED''' my issue . .
cor-el
  • Top 10 Contributor
  • Moderator
16245 solutions 146652 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Try to rename (or delete) the xulstore.json file in the Firefox profile folder. You can use this button to go to the currently used Firefox profile folder:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Try to rename (or delete) the xulstore.json file in the Firefox profile folder. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
PDTillman 0 solutions 1 answers

I have the same problem: going to Full Screen just widens the window, but leaves all the toolbars up across the top. I tried both tips here, no joy. Plus, the reply box keeps eating my post, sigh….

My Setup: Mac OS 10.10.3 (new Macbook Pro), Firefox 38.0.5

For the first tip, control-clicking at the very top of the screen gives me two different pop-up menus for tabs and bookmark bar — but no option to turn the bars OFF. Believe me, I right-clicked all over the top!

I then restarted FF in SAFE mode, and deleted the xulstore.json file. Restarted again, no help.

Any more ideas? Worked fine on the old machine….

I have the same problem: going to Full Screen just widens the window, but leaves all the toolbars up across the top. I tried both tips here, no joy. Plus, the reply box keeps eating my post, sigh…. My Setup: Mac OS 10.10.3 (new Macbook Pro), Firefox 38.0.5 For the first tip, control-clicking at the very top of the screen gives me two different pop-up menus for tabs and bookmark bar — but no option to turn the bars OFF. Believe me, I right-clicked all over the top! I then restarted FF in SAFE mode, and deleted the xulstore.json file. Restarted again, no help. Any more ideas? Worked fine on the old machine….
jscher2000
  • Top 10 Contributor
7298 solutions 59418 answers

Helpful Reply

Hi PDTillman, I know as a Windows user that things may work differently on Mac. That said, could you check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste full and pause while the list is filtered

(3) If the browser.fullscreen.autohide preference is bolded and user set to false, double-click it to restore the default value of true.

If that was already set to true, hmm, maybe Firefox is never going into full screen mode. Does either of these methods work to switch between regular and full screen views:

  • Command+Shift+f
  • F11 function key
  • View menu > Full Screen
Hi PDTillman, I know as a Windows user that things may work differently on Mac. That said, could you check: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''full''' and pause while the list is filtered (3) If the '''browser.fullscreen.autohide''' preference is bolded and user set to false, double-click it to restore the default value of true. If that was already set to true, hmm, maybe Firefox is never going into full screen mode. Does either of these methods work to switch between regular and full screen views: * Command+Shift+f * F11 function key * View menu > Full Screen

Question owner

That being solved, for me anyway, do not access the NEWS MEDIA networks very often. Have found some I have visited when clicking a link, of the ad on a video screen that runs before their report, will open another Window and in that window there shows a part of other information at the bottom of THAT window yet there is not a 'scroll' slider on the side nor will the mouse wheel move the displayed window up to see what else there is to view. AND there are not an Icon nor Menu to select from to add any features to that new open Window nor will it go to full screen either.

I know this is a little involved, do not have a link to give for demo . . maybe if one is found will provide. TOO many other projects underway now.

Cannot find where to edit my signature, or do we need to create a new . . TIA, CU L8R, NTLS "Lone Wanderer"

That being solved, for me anyway, do not access the NEWS MEDIA networks very often. Have found some I have visited when clicking a link, of the ad on a video screen that runs before their report, will open another Window and in that window there shows a part of other information at the bottom of THAT window yet there is not a 'scroll' slider on the side nor will the mouse wheel move the displayed window up to see what else there is to view. AND there are not an Icon nor Menu to select from to add any features to that new open Window nor will it go to full screen either. I know this is a little involved, do not have a link to give for demo . . maybe if one is found will provide. TOO many other projects underway now. Cannot find where to edit my signature, or do we need to create a new . . TIA, CU L8R, NTLS "Lone Wanderer"
jscher2000
  • Top 10 Contributor
7298 solutions 59418 answers

Hi NTLS, to edit your profile on this site, find your user name at the very top of the page and hover over it or click it to get a menu with different actions for your Mozilla Support account.

Regarding the "featureless" windows, there is a bug in Firefox 38 with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Hi NTLS, to edit your profile on this site, find your user name at the very top of the page and hover over it or click it to get a menu with different actions for your Mozilla Support account. Regarding the "featureless" windows, there is a bug in Firefox 38 with this combination of circumstances: (1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned ''off'' (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank") The new window opens without menus, toolbar, scroll bars, etc. Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug: (1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead"); (2) Shift+click links to open them in a new window with the standard features; or (3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed. ''For #3, here are the steps:'' (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (B) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (C) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Question owner

"jscher2000."

Had a good reply going and for some reason my page went away and lost my response to your data.

This is a first for me, report an issue with some techy details in my terminology AND have someone to accept it, understand, and even have a solution in hand, oops, in mind.

Will copy this to my little text editor, not really little but very powerful called "Edit Pad Light" by JGSoftware. Google it and see what I mean, where MS NotePad opens only one file at a time this one will open an unlimited number of files at the same time and can copy/paste from anyone to any other. That is only the start . . .

Using that 'EPL' will be able to edit out what is not tied to my issue and sort out what I will use and HOW!

Very NICE and neat . . as well as being tidy.

P.S. There is not a place to do a Signature or a Sig for messages.

TIA, CU L8R, 'd' NTLS "Lone Wanderer"

"jscher2000." Had a good reply going and for some reason my page went away and lost my response to your data. This is a first for me, report an issue with some techy details in my terminology AND have someone to accept it, understand, and even have a solution in hand, oops, in mind. Will copy this to my little text editor, not really little but very powerful called "Edit Pad Light" by JGSoftware. Google it and see what I mean, where MS NotePad opens only one file at a time this one will open an unlimited number of files at the same time and can copy/paste from anyone to any other. That is only the start . . . Using that 'EPL' will be able to edit out what is not tied to my issue and sort out what I will use and HOW! Very NICE and neat . . as well as being tidy. P.S. There is not a place to do a Signature or a Sig for messages. TIA, CU L8R, 'd' NTLS "Lone Wanderer"

Modified by NTLS