Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox not allowing my Google calendar to work - it did work before.

  • 3 replies
  • 2 have this problem
  • 3166 views
  • Last reply by DeafStamps

more options

I'm getting the following messages...

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

   This problem can sometimes be caused by disabling or refusing to accept cookies.

Chosen solution

Starting with the hint provided by Google, in case one or more of the Google cookies Firefox is storing is corrupt, inconsistent, or obsolete, could you try clearing them? Here's how to clear just Google cookies:

While viewing a page on google.com, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, the top box should have google.com entered already, and you can remove the site's cookies individually.

Then try reloading the page again. Any improvement?


If you have changed your cookie settings recently, this article describes how to go back to the most compatible settings: Websites say cookies are blocked - Unblock them.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Starting with the hint provided by Google, in case one or more of the Google cookies Firefox is storing is corrupt, inconsistent, or obsolete, could you try clearing them? Here's how to clear just Google cookies:

While viewing a page on google.com, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, the top box should have google.com entered already, and you can remove the site's cookies individually.

Then try reloading the page again. Any improvement?


If you have changed your cookie settings recently, this article describes how to go back to the most compatible settings: Websites say cookies are blocked - Unblock them.

more options

Do you recall where you got the "MediaPlayer 3.3.0" extension? That sounds suspicious to me. You may want to try disabling that and Skype Click-to-call until you are sure they are not causing problems.

You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

more options

jscher2000 said

Starting with the hint provided by Google, in case one or more of the Google cookies Firefox is storing is corrupt, inconsistent, or obsolete, could you try clearing them? Here's how to clear just Google cookies: While viewing a page on google.com, try either:
  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"
In the dialog that opens, the top box should have google.com entered already, and you can remove the site's cookies individually. Then try reloading the page again. Any improvement?

If you have changed your cookie settings recently, this article describes how to go back to the most compatible settings: Websites say cookies are blocked - Unblock them.


Thanks!!! I'm now one happy camper!!!  ;-)