Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stream mp3's in gmail?

  • 4 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

In the past, I used to be able to just click on mp3's in gmail to have them stream. A few years ago, this stopped working in firefox. The streaming window pops up, but it never plays (see image).

Is there any way to stream mp3's in gmail with just one click? I have projects where I will need to stream 100's of mp3s. This may end my long run with firefox if it can't be fixed.

Attached screenshots

All Replies (4)

more options

Does your Firefox play MP3s using the native HTML5 audio player? You can test using this page:

If the MP3 does not play there, it's possible that both of the technologies Firefox uses to decode MPEG media have been disabled or are broken at the OS level (Firefox doesn't have a built-in MPEG decoder for patent-related reasons).

To check your settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) {for Windows newer than XP} If the preference is bolded and user set to "false", double-click it to switch it to true

(4) {for Windows XP} If the media.directshow.enabled preference is bolded and user set to "false", double-click it to switch it to true

If you changed these settings, does that make any difference? I'm not sure whether the change takes effect immediately or after you exit Firefox and start it up again.

more options

Thanks. Unfortunately the html player does work and that config setting is already set to True.

more options

Do you see any error messages in the Web Console or Browser Console (Firefox/Tools > Web Developer) about media files?

more options

Okay, I reopened the test message that worked for me in November 2013 and as you say, it is not working now. I sent a new test message to my Gmail account, and same problem.

There seem to be two issues:

  • Firefox sometimes does not get a redirect to the media. Closing the black screen and clicking again may bypass this. (First screen shot.)
  • The audio is not auto-starting in Firefox when the media loads successfully, which makes the control bar useless. If you use a script command to trigger the media to play, the control bar starts working normally. (Second screen shot.)

This is annoying. Because Google's scripts are normally very complex, I don't think I'll be able to figure out why the media isn't autostarting.

If no solution is discovered, as a workaround, you could manually trigger the player using a bookmarklet, or possibly autostart it using a Greasemonkey userscript (probably a new script, unless someone has already posted one).

The bookmarklet would be as follows:

(1) Select and copy the following line of script:


(2) Right-click a convenient location on your Bookmarks Toolbar or Bookmarks Menu and choose New Bookmark.

(3) Paste the script into the Location field. Then in the name field, you can type Gmail Play or any name you like.

(4) Click the Add button

You would try clicking the bookmarklet after the player appears.