Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a message that gmail is not supported by IE but I use Firefox

  • 13 replies
  • 2 have this problem
  • 471 views
  • Last reply by Regnuhann

more options

A couple of weeks ago, I started getting a message that my version of Gmail was not supported by IE. But I don't use IE. I talked to my tech and we made sure compatability view in IE was off, I have the latest version of IE -11. This issue appears when I log in to gmail or log off, not consistently. I can get around it by staying signed in while I'm online or signing in to google. But it is frustrating. I visited the gmail forum on this and the best answer they had was update IE to 11 (already done) and use a different browser like Firefox (Already using). So how do I get rid of this message?

Chosen solution

Hi Regnuhann, if you want to open Firefox's Add-ons page, you can use any of these methods:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, you can choose categories such as Plugins or Extensions. Then those items will be listed on the right.

I'm not sure that's what you meant by:

I no longer have a Firefox tool bar to get to add ons.
Read this answer in context 👍 0

All Replies (13)

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I am not computer savvy and do not understand about reloading the web page. I only have this problem with gmail. I did clear cache and I already have custom history. I checked cookies and found one that I did not enter so deleted that. I don't know how to start in safe mode.

I did log into gmail with no message, but got it when I logged out. It flashes by so quickly but this time I did see it went on to say I needed a modern browser. I have the most updated Firefox. Any other suggestions?

more options

I was able to find instructions to open in safe mode. But when I do, I no longer have a Firefox tool bar to get to add ons.

more options

Chosen Solution

Hi Regnuhann, if you want to open Firefox's Add-ons page, you can use any of these methods:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, you can choose categories such as Plugins or Extensions. Then those items will be listed on the right.

I'm not sure that's what you meant by:

I no longer have a Firefox tool bar to get to add ons.
more options

By the way, when cor-el mentioned reloading the page, there were some methods listed to do that, the first three bullet points in the post: https://support.mozilla.org/questions/1053012#answer-706450

more options

I did not understand what web page she was referring to. The gmail page? Then when I opened in safe mode, I had no tool bar, no "tools" to get to add-ons. I tried putting all that in as a URL but it just kept telling me I had Firefox. I finally went in regular, changed appearance to default and left it at that. I see a color change and notice that when I do open gmail it no longer automatically checks the keep me signed in box and , so far, I haven't gotten the message. So far. As I said before, I am pretty much computer kindergarten, a lot of this is over my head. But thank you.

more options

Regnuhann said

A couple of weeks ago, I started getting a message that my version of Gmail was not supported by IE. But I don't use IE. I talked to my tech and we made sure compatability view in IE was off, I have the latest version of IE -11. This issue appears when I log in to gmail or log off, not consistently. I can get around it by staying signed in while I'm online or signing in to google. But it is frustrating. I visited the gmail forum on this and the best answer they had was update IE to 11 (already done) and use a different browser like Firefox (Already using). So how do I get rid of this message?

I thought the problem was solved, but when I booted up it was back last night and again this morning. The only extension I have is Norton and they told me to get help from Firefox. Does anyone have any other suggestions?

more options

Regnuhann said

I thought the problem was solved, but when I booted up it was back last night and again this morning.

Could you update the current symptoms: is it still: You are using Firefox to access Gmail, and it is telling your that your Internet Explorer is out of date?

There's no reason for Gmail to think Firefox is Internet Explorer unless a setting is wrong inside Firefox, or some other software is modifying your web requests as they are being submitted.

On the first point, please follow the steps in this article to check your settings: How to reset the default user agent on Firefox.

On the second point, in your Norton software, you may have some privacy options. For example, you might be able to block certain information that browsers normally send to websites. If any of those options are turned on, try turning them off.

more options

Thank you for your response. The message I get flashes by so fast, it's been hard to get it all. But here is what it says:

You are using a version of gmail that is not supported by Internet Explorer. Update to a modern browser.

It doesn't mention Firefox. But I have IE11 so why would that be a problem? I have no clue as to what to look for in my settings on Firefox. In options, everything is the same as always. Norton has already said the problem is not with them. The message comes up and then it doesn't, it disappears for a while and then comes back. How would I even begin to identify what software is at fault? I already admitted I am not computer savvy.

more options

Can you post your troubleshooting information with the extensions list?

more options

Hi Regnuhann, were you able to follow the steps in the support article I linked to? Just the first section where you use about:config.

https://support.mozilla.org/kb/websites-say-firefox-outdated-or-incompatible

more options

Co-rel - I did troubleshoot. Extensions.

Norton Toolbar Version 2014.7.11.42 enabled true {2D3F3651-74B9-4795-BDEC-6DA2F431Cb62}

jscher2000 - I did not read the support article yet. The message does not refer to Firefox. But I will do that next.

My IT friend is convinced that I have malware or exploit ware. But I ran a full system scan last night and nothing came up. Aargh!!

more options

jscher - I did read the support article and followed the instructions. This seems to be a gmail problem. I notice that if I click the "stay signed in" box, I can go back to gmail sign in without the message popping up. But even my bookmark doesn't work right. Strange.