X
Tap here to go to the mobile version of the site.

Support Forum

How do I turn Javascript on in my browser ?

Posted

I have developed a problem where by every time I go to certain web sites I am asked to turn on Javascript in my browser in order to continue viewing the page correctly. Whilst trying to find an answer to this problem I have discovered it needs to say under about:config "Javascript enabled" - default - true, but mine says default - boolean - true. Does anyone know if this is right and can anyone tell me what the correct settings should be so that I don't get the same statement on pages that really need Javascript ? Thank you.

I have developed a problem where by every time I go to certain web sites I am asked to turn on Javascript in my browser in order to continue viewing the page correctly. Whilst trying to find an answer to this problem I have discovered it needs to say under about:config "Javascript enabled" - default - true, but mine says default - boolean - true. Does anyone know if this is right and can anyone tell me what the correct settings should be so that I don't get the same statement on pages that really need Javascript ? Thank you.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Coupons, Inc. Coupon Printer 4.0.2.0
  • DYMO Label Framework Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 35.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Extensions

  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • Button for Amazon 1.4.0 (AmazonHotStuff@wangtom.com)
  • Consumer Input 12171 (ConsumerInput@Compete)
  • FEBE 8.3 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • Nectar Toolbar 1.0.9 ({EBB6A13A-F162-47D8-8BAE-B587C99A6C0E})
  • NoScript 2.6.9.15 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Quidco Cashback Reminder 2.0.21 (quidcotoolbar@quidco.com)
  • TopCashBack 1.0.9 ({46581BCF-7C9E-4983-A869-90B3874A8933})
  • Treat Street Points Booster 1.3.0.0 (treatstreet@boots.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • UserZoom Survey Tool 3.2 (userzoom_survey_tool@jetpack)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouGovPulse 4.3.15 (addon@yougov.wakoopa.com)
  • BullGuard Safe Browsing 2.1 (antiphishing@bullguard) (Inactive)
  • Classic Theme Restorer 1.2.9.6 (ClassicThemeRestorer@ArisT2Noia4dev) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-31-2010
  • driverDate2:
  • driverVersion: 8.15.10.2104
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20150122214805
  • browser.startup.homepage: http://www.ustart.org/
  • browser.startup.homepage_override.buildID: 20150122214805
  • browser.startup.homepage_override.mstone: 35.0.1
  • browser.tabs.onTop: False
  • dom.max_chrome_script_run_time: 60
  • dom.max_script_run_time: 20
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 35.0.1
  • font.internaluseonly.changed: True
  • font.size.variable.x-western: 17
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 1
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1423488911
  • media.gmp-gmpopenh264.version: 1.3
  • media.gmp-manager.lastCheck: 1425389943
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1425389925
  • places.history.expiration.transient_current_max_pages: 102041
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1424259176
  • webgl.disabled: True

Misc

  • User JS: No
  • Accessibility: No
Big_Munz 1 solutions 7 answers

If the list in About:config shows that your 'javascript enabled' option is set as 'true' then it may be that the java plugin has been disabled through the add-ons manager (The type 'boolean' is normal, it just defines the 'value' as either true or false).

You can access Add-ons through the 'tools' drop down menu, or through the icon with three horizontal lines. Select 'Add-ons', this should open the Add-ons manager. Select 'Plugins' from the left side of the manager, you should now see a list of the plugins currently installed in your Firefox browser. Confirm that your Java platform is set to either 'ask to activate' or 'always activate'.

If you are still having issues with Java content, you may need to update your Java components. This support page can walk you through updating and managing your Java plugin:

https://support.mozilla.org/en-US/kb/use-java-plugin-to-view-interactive-content

If the list in About:config shows that your 'javascript enabled' option is set as 'true' then it may be that the java plugin has been disabled through the add-ons manager (The type 'boolean' is normal, it just defines the 'value' as either true or false). You can access Add-ons through the 'tools' drop down menu, or through the icon with three horizontal lines. Select 'Add-ons', this should open the Add-ons manager. Select 'Plugins' from the left side of the manager, you should now see a list of the plugins currently installed in your Firefox browser. Confirm that your Java platform is set to either 'ask to activate' or 'always activate'. If you are still having issues with Java content, you may need to update your Java components. This support page can walk you through updating and managing your Java plugin: https://support.mozilla.org/en-US/kb/use-java-plugin-to-view-interactive-content
James
  • Moderator
1593 solutions 11223 answers

^The Java plugin and JavaScript are unrelated as JavaScript was originally going to be called LiveScript.

Anyways I see you have the NoScript extension installed as it may be blocking the JavaScript.

^The Java plugin and JavaScript are unrelated as JavaScript was originally going to be called LiveScript. Anyways I see you have the NoScript extension installed as it may be blocking the JavaScript.
cor-el
  • Top 10 Contributor
  • Moderator
17343 solutions 156777 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes