Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am no longer able to see images on some websites

more options

Hi,

  I am no longer able to see images on some websites.  I have followed all suggested : reset firefox, restarted in safe mode - no difference, clear cash and cookies, tried auto:config suggestions etc...no help.  Some images show up others don't.  
  All except one add-on shows up to date and that one I have downloaded but still will not show correctly. This is the information I get below.  Any help would be appreciated.   Thank you Melina
  The plugin Check & Update shows: Outdated

Plugins Plugin Status Action Adobe Flash PlayerRealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In vulnerable 1.3.3.66 Update Now


These plugins are up to date Plugin Status Action Adobe Flash PlayerShockwave Flash 16.0 r0 Up to Date 16.0.0.305 Up to Date Java Runtime EnvironmentNPRuntime Script Plug-in Library for Java(TM) Deploy Up to Date 11.31.2.13 Up to Date Adobe ReaderAdobe PDF Plug-In For Firefox and Netscape Up to Date 11.0.8.4 Up to Date QuickTime Plug-inThe QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site. Up to Date 7.7.6.0 Up to Date Java Runtime EnvironmentNext Generation Java Plug-in 11.31.2 for Mozilla browsers Up to Date 11.31.2.13 Up to Date Silverlight Plug-In5.1.30514.0 Up to Date 5.1.30514.0 Up to Date


Unknown Plugins Plugin Action Windows Media Player Plug-in Dynamic Link Library (v. 3.0.2.629)Npdsplay dll Research Google Earth Plugin (v. 7.1.2.2041)GEPlugin Research iTunes Application Detector (v. 1.0.1.1)iTunes Detector Plug-in Research RealPlayer Download Plugin (v. 16.0.3.51)RealPlayer Download Plugin Research Microsoft® DRM (v. 9.0.0.4503)DRM Store Netscape Plugin Research Windows Presentation Foundation (v. 3.5.30729.1)Windows Presentation Foundation (WPF) plug-in for Mozilla browsers Research 3DVIA player (v. 4.1.0.78)3D Life Player Beta (4.1.0.78). For more information, visit the 3D Life Player web site. Research Picasa (v. 3.0.0.0)Picasa plugin Research RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In (32-bit) (v. 1.3.3.66)RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In Research Skype Web Plugin (v. 3.2.0.23388)Skype Web Plugin Research Google Update (v. 1.3.26.9)Google Update Research Windows Live® Photo Gallery (v. 14.0.8117.416)NPWLPG Research RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) (v. 16.0.3.51)RealPlayer(tm) LiveConnect-Enabled Plug-In Research

Chosen solution

Thank you for all your help. I had loaded and used both JetClean & CCleaner for Malware removal. This evening as a last attempt to figure out my issue, I tried a few more programs. First Malwarebytes which located 3 more issues. 2 Trogans and on vgrabber programs. Then I loaded the Windows malware removal program. After both programs were finished everything is working.

Read this answer in context 👍 0

All Replies (11)

more options

Hi, please try working through this article, there may be some things that you haven't tried!

Hope it helps.

more options

No the only option I had not tried was the New Profile. I have tried this and I get the same results on the new profile. I must be missing something but I really don't know what to do from here. Thank you

more options

What kind of images are missing?

Are that background images?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

If images are missing then check that you do not block images from some domains.

  • Tap the Alt key or press F10 to show the Menu Bar

Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

This is a screen shot that shows ebay, but it also happens on other sites as well. Appreciate you help!

more options

-check that you do not block images from some domains. - OK - if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain. - OK -about:config page should be 1. OK

I even was able to update my Adobe Flash PlayerRealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In as I did find that option blocked.

This did not correct my problem

Thank you Melina

more options

I use Avira but have for years. I even shut it down yesterday and that was no help either :(

more options

Do you see at least the URLs of the missing images in "Tools > Page Info > Media"?

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if content from a some domains is blocked and has a file size 0 (zero).

You need to reload the page (F5 or Ctrl+F5) to generate the log.

more options

Thank you...with this I am getting 404 errors on thumbnails. Unfortunately I don't really understand how to fix this. :( I have a picture attached. Thank you

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Hi and thank you. Nothing is helping unfortunately.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.  'DONE'

"Clear the Cache":

   Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"  - 'DONE many times over'

"Remove Cookies" from sites causing problems:

   Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"  - 'Done no change and also blocks the login option on ebay'

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem Done many times

Default Theme is on.

Ugh thank you Melina

more options

Chosen Solution

Thank you for all your help. I had loaded and used both JetClean & CCleaner for Malware removal. This evening as a last attempt to figure out my issue, I tried a few more programs. First Malwarebytes which located 3 more issues. 2 Trogans and on vgrabber programs. Then I loaded the Windows malware removal program. After both programs were finished everything is working.