Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Want ENGLISH ONLY on this damn site--I should not have to keep changing it!!!!!!!!!! It is already in ENGLISH!

  • 1 reply
  • 5 have this problem
  • 46 views
  • Last reply by user633449

more options

I have followed all the Normal methods, and they do not work. I live in Tampa Florida--USA. That means ENGLISH. I have never had this problem before 2014, so something has changed--I certainly did not request Spanish. I don't speak Spanish--I don't want SPANISH!!!!

All Replies (1)

more options

What website are you referring to?

Ensure that you are allowing cookies from the website, which is normally how language preferences are saved. If your anti-virus is automatically clearing cookies that could cause this problem.