Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

no option for 1080p youtube

  • 2 replies
  • 72 have this problem
  • 16877 views
  • Last reply by sampson3121

more options

Hi, i have always had the option to play youtube videos in 1080 or higher until today. for some reason when i try to play a video that IS 1080p, i don't even get the option to change to anything higher then 720p. i also tried this with Explorer and it's fine.

I've tried looking on the net for answers and i can't fix this problem.

can you please help me because i would rather use Firefox instead of Internet Explorer...but if i have to i will.

Chosen solution

You can try to delete the YouTube cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You need a Firefox version that has MSE (Media Source Extensions) enabled to get this offered.


You can look at the current beta release that comes with media.mediasource.youtubeonly = true.

Do a custom install and create a new profile for the Beta release.

Read this answer in context 👍 5

All Replies (2)

more options

Chosen Solution

You can try to delete the YouTube cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You need a Firefox version that has MSE (Media Source Extensions) enabled to get this offered.


You can look at the current beta release that comes with media.mediasource.youtubeonly = true.

Do a custom install and create a new profile for the Beta release.

more options

sampson3121 said

Hi, i have always had the option to play youtube videos in 1080 or higher until today. for some reason when i try to play a video that IS 1080p, i don't even get the option to change to anything higher then 720p. i also tried this with Explorer and it's fine. I've tried looking on the net for answers and i can't fix this problem. can you please help me because i would rather use Firefox instead of Internet Explorer...but if i have to i will.

thanks, i tried your solution and it worked :)