X
Tap here to go to the mobile version of the site.

Support Forum

remove developer tools

Posted

I've tried everything I can find on-line but I cannot prevent the developer tools from interfering when I type in a search or type in text on a web page.

I have gone to about:config and turned off every dev listed, still nothing changes.

Please tell me how to remove the developer tools from my computer

I've tried everything I can find on-line but I cannot prevent the developer tools from interfering when I type in a search or type in text on a web page. I have gone to about:config and turned off every dev listed, still nothing changes. Please tell me how to remove the developer tools from my computer

Chosen solution

If Safe Mode works normally, that usually means that one of your extensions is causing the issue.

You could try disabling the less common ones -- Garmin and AVG -- on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then you can find the Disable button for each of those.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that improve Firefox's behavior?

It's also possible that the problem extension works fine on its own but is interacting badly with one your plugins, so if you want to keep both of those extensions enabled, review and disable unnecessary plugins.

On the Add-ons page, in the left column, click Plugins. To disable a plugin, change its permission from "Ask to Activate" to "Never Activate". You may need to open a new window (Ctrl+n) or exit and start Firefox up again to see the effects of the change.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Creative Cloud Desktop Plugin.v_2_0_0_0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Download Plugin
  • This plug-in enables downloading of HTML5 videos
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Roblox Launcher Plugin
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • iTunes Detector Plug-in

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom)
  • AVG SafeGuard toolbar 18.1.9.799 (avg@toolbar)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • RealDownloader 17.0.15 ({338950EA-82DB-44C1-930D-0C28E023C9F0})
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Quadro 4000
  • adapterDescription2:
  • adapterDeviceID: 0x06dd
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 078010de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 10-23-2013
  • driverDate2:
  • driverVersion: 9.18.13.3165
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA Quadro 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
Chandan_Baba 35 solutions 369 answers

did you done using this command devtools.*.enabled ? Make out all values false .

Read more about about:config > http://kb.mozillazine.org/about:config
did you done using this command '''devtools.*.enabled''' ? Make out all values false . Read more about '''about:config''' > http://kb.mozillazine.org/about:config

Helpful Reply

Thanks,

I've done that but it still takes over when I type. Even as I have been typing this reply.

Thanks, I've done that but it still takes over when I type. Even as I have been typing this reply.
John99 971 solutions 13138 answers

Helpful Reply

Is it just the built-in devtools you are having an issue with, or is it some add-on, or some other thirdparty software you have installed.

Most users will not ever notice any developer's tools even exist.

I can understand some actions may include using shortcuts ordinarily used by the developer tools but simply typing text into these reply boxes should be ok.

What tools are a problem, and what typing shortcuts are involved ?

Is it just the built-in devtools you are having an issue with, or is it some add-on, or some other thirdparty software you have installed. Most users will not ever notice any developer's tools even exist. I can understand some actions may include using shortcuts ordinarily used by the developer tools but simply typing text into these reply boxes should be ok. What tools are a problem, and what typing shortcuts are involved ?

Question owner

I'm not sure, I don't have it in add-ons and it doesn't seem to be a third party software. I just start typing and I get a window the bottom of my screen with Developer tools, code etc.

It's not always happening but it does almost always when I do a web search and often when I type in boxes on sites.

I don't know what tools, I just don't want the window popping up and as for shortcuts, I can't narrow down the key strokes as it has happened so often it is virtually any key I type.

I'm not sure, I don't have it in add-ons and it doesn't seem to be a third party software. I just start typing and I get a window the bottom of my screen with Developer tools, code etc. It's not always happening but it does almost always when I do a web search and often when I type in boxes on sites. I don't know what tools, I just don't want the window popping up and as for shortcuts, I can't narrow down the key strokes as it has happened so often it is virtually any key I type.
John99 971 solutions 13138 answers

Are you able to get a screenshot of this and then use the Add images: button to browse for and attach the file. (You will need to use some sort of small file such as a .gif or .jpeg)

Are you able to get a screenshot of this and then use the ''Add images:'' button to browse for and attach the file. (You will need to use some sort of small file such as a .gif or .jpeg) * https://wikipedia.org/wiki/Screenshot * [[How do I create a screenshot of my problem?]]
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158559 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Firefox might be having trouble reading the state of your keyboard correctly, although, if the issue doesn't occur when filling in web-based forms, then that might not be the issue.

Next time the tools appear, could make a note of which tab is selected, e.g., Console (Ctrl+Shift+k), Inspector (Ctrl+Shift+c), etc.

In addition to those, there is a short command line (Shift+F2) which could be what you're seeing.

Firefox might be having trouble reading the state of your keyboard correctly, although, if the issue doesn't occur when filling in web-based forms, then that might not be the issue. Next time the tools appear, could make a note of which tab is selected, e.g., Console (Ctrl+Shift+k), Inspector (Ctrl+Shift+c), etc. In addition to those, there is a short command line (Shift+F2) which could be what you're seeing.

Question owner

Hi all,

Thanks for the help.

I opened Firefox in safe mode and that seemed to work. I've attached a screen grab of the what happens when Firefox is open normally. The developer tools opens on the console tab.

Again, thanks for the help.

Hi all, Thanks for the help. I opened Firefox in safe mode and that seemed to work. I've attached a screen grab of the what happens when Firefox is open normally. The developer tools opens on the console tab. Again, thanks for the help.
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Chosen Solution

If Safe Mode works normally, that usually means that one of your extensions is causing the issue.

You could try disabling the less common ones -- Garmin and AVG -- on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then you can find the Disable button for each of those.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that improve Firefox's behavior?

It's also possible that the problem extension works fine on its own but is interacting badly with one your plugins, so if you want to keep both of those extensions enabled, review and disable unnecessary plugins.

On the Add-ons page, in the left column, click Plugins. To disable a plugin, change its permission from "Ask to Activate" to "Never Activate". You may need to open a new window (Ctrl+n) or exit and start Firefox up again to see the effects of the change.

If Safe Mode works normally, that ''usually'' means that one of your extensions is causing the issue. You could try disabling the less common ones -- Garmin and AVG -- on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then you can find the Disable button for each of those. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that improve Firefox's behavior? It's also possible that the problem extension works fine on its own but is interacting badly with one your plugins, so if you want to keep both of those extensions enabled, review and disable unnecessary plugins. On the Add-ons page, in the left column, click Plugins. To disable a plugin, change its permission from "Ask to Activate" to "Never Activate". You may need to open a new window (Ctrl+n) or exit and start Firefox up again to see the effects of the change.

Question owner

Thanks jscher 2000,

The latter seems to have solved the problem. I appreciate the input and time, thanks so much.

John

Thanks jscher 2000, The latter seems to have solved the problem. I appreciate the input and time, thanks so much. John
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Hi John, if you can put your finger on a particular plugin that has this issue, feel free to name names.

Hi John, if you can put your finger on a particular plugin that has this issue, feel free to name names.

Question owner

I disabled both AVG Safeguard tool bar in the extensions and Garmin Communicator in the extensions and plug-ins.

I'm not sure which specifically solved the problem but it now seems to be running fine and the developer window doesn't pop up anymore, so I'm just leaving it this way.

Again, thanks for all the help, it makes searching and typing while on-line much less aggravating.

I disabled both AVG Safeguard tool bar in the extensions and Garmin Communicator in the extensions and plug-ins. I'm not sure which specifically solved the problem but it now seems to be running fine and the developer window doesn't pop up anymore, so I'm just leaving it this way. Again, thanks for all the help, it makes searching and typing while on-line much less aggravating.
Kirvee 0 solutions 2 answers

I've been having this exact same problem for a while and it is infuriating and makes Firefox practically UNUSABLE.

Unfortunately, unlike John, my problems don't go away in Safe Mode. And I have allllllllll the values for this damn thing set to False. Since I make themes, I normally love this tool and use it a lot, but now it's just a headache. I can't type properly, can't browser, can't do anything. It pops up when I type, pops up while I'm scrolling, pops up when I change tabs.

It doesn't help that this also happens in Chrome, so I feel like it might be my keyboard's fault, but I use a laptop and can't figure out how to make it behave.

The devtools popping up when not wanted wouldn't be so annoying if it didn't change the focus of the typing cursor. So like, I could type and it would just be at the bottom flashing its little heart out. I wouldn't care if it did that. But as it is, it's disrupting my browsing experience and I can't afford a new laptop yet.

Does anyone have any solution that isn't: safe mode or about:config?

I've been having this exact same problem for a while and it is infuriating and makes Firefox practically UNUSABLE. Unfortunately, unlike John, my problems don't go away in Safe Mode. And I have allllllllll the values for this damn thing set to False. Since I make themes, I normally love this tool and use it a lot, but now it's just a headache. I can't type properly, can't browser, can't do anything. It pops up when I type, pops up while I'm scrolling, pops up when I change tabs. It doesn't help that this also happens in Chrome, so I feel like it might be my keyboard's fault, but I use a laptop and can't figure out how to make it behave. The devtools popping up when not wanted wouldn't be so annoying if it didn't change the focus of the typing cursor. So like, I could type and it would just be at the bottom flashing its little heart out. I wouldn't care if it did that. But as it is, it's disrupting my browsing experience and I can't afford a new laptop yet. Does anyone have any solution that isn't: safe mode or about:config?
John99 971 solutions 13138 answers

Hi Kirvee, Sorry you have run into this problem. It is probably best to post a new Question of your own.

Please use this special link {Quick, cuts out a few steps, and contributors will realise it originated in this thread) The current thread is already solved. A new thread enables you the option to provide full system details.

Hi Kirvee, Sorry you have run into this problem. It is probably best to post a new Question of your own. Please use this '''[https://support.mozilla.org/en-US/questions/new/desktop/fix-problems/form?search=Dev+tools+steal+focus+%28%2Fquestions%2F1042229%29&step=aaq-question special link]''' {Quick, cuts out a few steps, and contributors will realise it originated in this thread) The current thread is already solved. A new thread enables you the option to provide full system details.

Question owner

Hi Kirvee

Sorry I didn't post any more, my problem isn't solved although I thought it was. I just gave up as solving it kept me from getting deadlines done. I still have the same problem - I've unistalled and reinstalled firefox, I've dealt with the about:config, I've turned off all of the add ons etc. I'm stumped and needed to actual get my work done.

Hope you find an answer.

Hi Kirvee Sorry I didn't post any more, my problem isn't solved although I thought it was. I just gave up as solving it kept me from getting deadlines done. I still have the same problem - I've unistalled and reinstalled firefox, I've dealt with the about:config, I've turned off all of the add ons etc. I'm stumped and needed to actual get my work done. Hope you find an answer.
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158559 answers

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.


Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox ----- Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall