X
Tap here to go to the mobile version of the site.

Support Forum

Websites that use java are not working. In the Java control panel, under advanced, default java for browsers "mozilla family" won't stay clicked

Posted

I've recently gotten a new Windows 8 computer. Ever since, I've tried accessing certain websites (like www.cnet.com) and can't get the java scripts to load like for the drop down menus. When I hover over them they don't do anything. Other computers I have that run Windows 7 are working just fine.

I've upgraded Firefox and Java to all of the newest versions but it's still not working. When I go to the Java control panel, under "Advanced" and under "Default Java for browsers", the check box next to "Mozilla family" won't stay checked. I'll check it, click "Apply" and "Ok" and then when I open it back up it's unchecked again.

Help.

I've recently gotten a new Windows 8 computer. Ever since, I've tried accessing certain websites (like www.cnet.com) and can't get the java scripts to load like for the drop down menus. When I hover over them they don't do anything. Other computers I have that run Windows 7 are working just fine. I've upgraded Firefox and Java to all of the newest versions but it's still not working. When I go to the Java control panel, under "Advanced" and under "Default Java for browsers", the check box next to "Mozilla family" won't stay checked. I'll check it, click "Apply" and "Ok" and then when I open it back up it's unchecked again. Help.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40422 answers
See this KB article - https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins
cor-el
  • Top 10 Contributor
  • Moderator
17678 solutions 159899 answers

Java and JavaScript are different languages. To avoid confusion, see:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

That setting in the Java control panel doesn't apply to Firefox. If under the security tab "Enable Java content in the browser" is selected then that is enough and because the Java plugin shows in the System Details list then this is likely the case.

Java and JavaScript are different languages. To avoid confusion, see: *http://kb.mozillazine.org/JavaScript_is_not_Java Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- That setting in the Java control panel doesn't apply to Firefox. If under the security tab "Enable Java content in the browser" is selected then that is enough and because the Java plugin shows in the System Details list then this is likely the case.
AliceWyman
  • Moderator
240 solutions 2607 answers

needfixin1004 said

I've recently gotten a new Windows 8 computer. Ever since, I've tried accessing certain websites (like www.cnet.com) and can't get the java scripts to load like for the drop down menus. When I hover over them they don't do anything.

www.cnet.com doesn't use Java. JavaScript is not Java. See:

Do the problem websites work in Firefox Safe Mode?

  1. Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  2. When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35

If the site works in Safe Mode, try disabling added extensions like NoScript or Ghostery that block JavaScript.

How to disable individual extensions Disabling an extension will turn it off without removing it:

  1. Click the menu button New Fx Menu and choose Add-ons . The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the extension and click the Disable button.
  4. Click Restart now if it pops up. Your tabs will be saved and restored after the restart.

If you need more help, please post back.

''needfixin1004 [[#question-1042114|said]]'' <blockquote> I've recently gotten a new Windows 8 computer. Ever since, I've tried accessing certain websites (like www.cnet.com) and can't get the java scripts to load like for the drop down menus. When I hover over them they don't do anything. </blockquote> www.cnet.com doesn't use Java. Java'''Script''' is not Java. See: *[https://www.java.com/en/download/faq/java_javascript.xml How is JavaScript different from Java?] * [[JavaScript settings and preferences for interactive web pages]]. Do the problem websites work in [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]]? #Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. #When the Firefox Safe Mode window appears, select "Start in Safe Mode". :[[Image:SafeMode-Fx35]] If the site works in Safe Mode, try disabling added extensions like NoScript or Ghostery that block JavaScript. '''How to disable individual extensions''' Disabling an extension will turn it off without removing it: # Click the menu button [[Image:New Fx Menu]] and choose '''Add-ons''' . The Add-ons Manager tab will open. # In the Add-ons Manager tab, select the '''Extensions''' panel. # Select the extension and click the '''Disable''' button. # Click '''Restart now''' if it pops up. Your tabs will be saved and restored after the restart. If you need more help, please post back.

Question owner

Referring to the Java/JavaScript confusion, I wasn't aware of that, thanks for the clarification.

It still doesn't work in Firefox Safe Mode. Nothing happens when I over over the menu options.

Referring to the Java/JavaScript confusion, I wasn't aware of that, thanks for the clarification. It still doesn't work in Firefox Safe Mode. Nothing happens when I over over the menu options.
cor-el
  • Top 10 Contributor
  • Moderator
17678 solutions 159899 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Also make sure that your security software isn't blocking content.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Also make sure that your security software isn't blocking content. Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

For clarification, www.cnet.com menu still doesn't work when I hover over it in Firefox Safe Mode.

For clarification, ''www.cnet.com'' menu still doesn't work when I hover over it in Firefox Safe Mode.

Question owner

I tried all the above and no luck.

I tried all the above and no luck.

Question owner

I should also say that it works fine in Internet Explorer, but as a habit I don't like using that and would hate to have to go back to that.

I should also say that it works fine in Internet Explorer, but as a habit I don't like using that and would hate to have to go back to that.
AliceWyman
  • Moderator
240 solutions 2607 answers

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following so that we can check for modified preferences (specifically, javascript.enabled)

  1. Open the Firefox Troubleshooting Information page: Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following so that we can check for modified preferences (specifically, ''javascript.enabled'') #Open the Firefox Troubleshooting Information page: Click the menu button [[Image:New Fx Menu]], click on help [[Image:Help-29]] and select ''Troubleshooting Information''. #At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it. #Now, go back to your forum post, right-click in the reply box and select '''Paste''' from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]]. Thanks in advance for your help!
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Could you try disabling the McAfee plugin? Safe Mode disables extensions, but does not disable plugins.

You can open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then change the permission for the McAfee plugin to "Never Activate".

You might also consider disabling other plugins that do not have an immediately obvious benefit for viewing web content.

Such changes might not have any effect in the current window, but if you launch a new window (Ctrl+n), the plugin should be disabled there. Any difference?

Could you try disabling the McAfee plugin? Safe Mode disables extensions, but does not disable plugins. You can open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Then change the permission for the McAfee plugin to "Never Activate". You might also consider disabling other plugins that do not have an immediately obvious benefit for viewing web content. Such changes might not have any effect in the current window, but if you launch a new window (Ctrl+n), the plugin should be disabled there. Any difference?

Question owner

Thanks for the reply back.

I actually tried from scratch with a brand new download of Firefox (no extensions or plugins) and it still didn't work. I did try your suggestion about disabling McAfee and it also still didn't work.

I am leaning more towards that this is a problem with Windows 8 since I have the same extensions and plugins on my computers with Windows 7 and they work just fine. I just have no idea what it could be on Windows 8 that would be causing the problem.

Thanks for the reply back. I actually tried from scratch with a brand new download of Firefox (no extensions or plugins) and it still didn't work. I did try your suggestion about disabling McAfee and it also still didn't work. I am leaning more towards that this is a problem with Windows 8 since I have the same extensions and plugins on my computers with Windows 7 and they work just fine. I just have no idea what it could be on Windows 8 that would be causing the problem.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Does your Windows 8 system have a touch screen? Users occasionally have reported issues where some features you would expect could be accessed by mouse only worked by touch.

Here are some past threads about this:

Does your Windows 8 system have a touch screen? Users occasionally have reported issues where some features you would expect could be accessed by mouse only worked by touch. Here are some past threads about this: * [https://support.mozilla.org/questions/986902 mouse hover drop down menu not shown] - resolved by disabling touch at the Windows level * [https://support.mozilla.org/questions/971084 Javascript menus don't work.] - similar problems in Google Chrome and Firefox with HP All-in-One system, resolved by disabling touch at the Windows level * [https://support.mozilla.org/questions/961224 When trying to click on menus on USAA, it shows "javascript:;" in the bottom left hand corner and the menu won't work in FF 21.] - resolved by disabling a preference in Firefox

Question owner

jscher2000 - it is a touchscreen computer.

I tried what you suggested and it works if I disable the touch screen function on the computer level.

Makes no sense whatsoever - especially since it works fine on IE without having to disable it.

I tried disabling the preference in Firefox but that didn't work apparently. So I'm not sure if I should call this one "solved" or not - that seems asinine to me but I guess it's a workaround. I appreciate the help, I would never have gotten that far.

jscher2000 - it is a touchscreen computer. I tried what you suggested and it works if I disable the touch screen function on the computer level. Makes no sense whatsoever - especially since it works fine on IE without having to disable it. I tried disabling the preference in Firefox but that didn't work apparently. So I'm not sure if I should call this one "solved" or not - that seems asinine to me but I guess it's a workaround. I appreciate the help, I would never have gotten that far.
cor-el
  • Top 10 Contributor
  • Moderator
17678 solutions 159899 answers

You can try to modify these prefs on the about:config page:

  • dom.w3c_touch_events.enabled = 0
  • dom.w3c_touch_events.expose = false

The dom.w3c_touch_events.enabled tri-state preference can be used to disable (0), enable (1) and auto-detect(2) support for standard touch events; by default, they're on auto-detect(2). After changing the preference, you must restart the browser for the changes to take effect.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can try to modify these prefs on the about:config page: * dom.w3c_touch_events.enabled = 0 * dom.w3c_touch_events.expose = false The dom.w3c_touch_events.enabled tri-state preference can be used to disable (0), enable (1) and auto-detect(2) support for standard touch events; by default, they're on auto-detect(2). After changing the preference, you must restart the browser for the changes to take effect. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Helpful Reply

cor-el -

The dom.w3c_touch_events.enabled was already set to 0.

I don't have a "dom.w3c_touch_events.expose" line. Is that something I should?

cor-el - The dom.w3c_touch_events.enabled was already set to 0. I don't have a "dom.w3c_touch_events.expose" line. Is that something I should?