X
Tap here to go to the mobile version of the site.

Support Forum

Can't get multiple audio layers on a page to play.

Posted

One of my clients has an online course in which each weekly lesson is presented on one web page. A typical lesson includes three MP3 audio files for playback only (no download). The site is built in WordPress, and is using the MediaElement.js HTML5 audio player plug-in, which produces HTML5 code with a fall back to Flash. This system has worked properly for almost two years. A student complained yesterday that she could only get the first audio to play on the Week 1 page; the other two just did nothing when she clicked their Play buttons. I was able to confirm that such was the case in FireFox 34.0 and IE 11, but Chrome and Safari are still working fine. Just focusing on FireFox right now, I have tried several other player plug-ins, with no luck, and even hand crafted HTML5 audio tags in place of the player shortcodes, but got the same result. WordPress and the players are all latest versions. I have also made sure that my FireFox QuickTime and Flash plug-ins are latest versions, but still no change. The console shows a message that the audio file could not be decoded whenever the non-playing players are clicked. Also, in trying different course pages, I find that sometimes the successful player is the first one on the page, but not always; the second or even the third player is sometimes the successful player, while the other two will not play.

I would appreciate any information that could help me get this working again. Now I will go talk to Microsoft about version of this problem. :)

One of my clients has an online course in which each weekly lesson is presented on one web page. A typical lesson includes three MP3 audio files for playback only (no download). The site is built in WordPress, and is using the MediaElement.js HTML5 audio player plug-in, which produces HTML5 code with a fall back to Flash. This system has worked properly for almost two years. A student complained yesterday that she could only get the first audio to play on the Week 1 page; the other two just did nothing when she clicked their Play buttons. I was able to confirm that such was the case in FireFox 34.0 and IE 11, but Chrome and Safari are still working fine. Just focusing on FireFox right now, I have tried several other player plug-ins, with no luck, and even hand crafted HTML5 audio tags in place of the player shortcodes, but got the same result. WordPress and the players are all latest versions. I have also made sure that my FireFox QuickTime and Flash plug-ins are latest versions, but still no change. The console shows a message that the audio file could not be decoded whenever the non-playing players are clicked. Also, in trying different course pages, I find that sometimes the successful player is the first one on the page, but not always; the second or even the third player is sometimes the successful player, while the other two will not play. I would appreciate any information that could help me get this working again. Now I will go talk to Microsoft about version of this problem. :)

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Citrix Online App Detector Plugin
  • Zeon PDF Plugin For Mozilla
  • GEPlugin
  • Version 5.38.6.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 34.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0/WINNT/en-US/

Extensions

  • Firebug 2.0.7 (firebug@software.joehewitt.com)
  • McAfee SiteAdvisor 3.7.1 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • PDF Converter 7.1 1.0 (nuance@pdf7)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • HP Smart Web Printing 4.5 (smartwebprinting@hp.com) (Inactive)
  • McAfee Security Scan Plus 1.0 ({e4f94d1e-2f53-401e-8885-681602c0ddd8}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 04471028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-10-2012
  • driverDate2:
  • driverVersion: 8.15.10.2622
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.cache.frecency_experiment: 1
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 7
  • browser.search.suggest.enabled: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141125180439
  • browser.startup.homepage: http://www.msn.com/
  • browser.startup.homepage_override.buildID: 20141125180439
  • browser.startup.homepage_override.mstone: 34.0
  • browser.tabs.loadInBackground: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 34.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • keyword.URL: http://search.yahoo.com/search?fr=mcafee&p=
  • media.gmp-gmpopenh264.lastUpdate: 1414677193
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1419965056
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1419946120
  • places.history.expiration.transient_current_max_pages: 102097
  • places.history.expiration.transient_optimal_database_size: 163354704
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1419783714

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

I've called the big guys to help you. Good luck.


Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

I've called the big guys to help you. Good luck. ------------------- Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' -------------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Fred, thanks for your reply. I don't think the things you suggest are really helpful in this particular situation, and here is why. This is not a case of me trying to get it to work so I can consume a web page somebody else created. My problem is that a page that I created and that has been working for some time now suddenly doesn't work in FF for a client's customer and for me. The same page works fine in Chrome and Safari, but also fails now in IE. The advice you have given is essentially a general troubleshooting guide, and is frankly not what I would want to have to give the client's customer. I need to get my page back in a state which will allow it to work fine on the browser's standard install. I really do appreciate that you attempted to help, but I feel I need help more from a development viewpoint. I don't know exactly who "the big boys" are, but I appreciate you referring my issue to others who may be able to help.

Sincere thanks, Kerry

Fred, thanks for your reply. I don't think the things you suggest are really helpful in this particular situation, and here is why. This is not a case of me trying to get it to work so I can consume a web page somebody else created. My problem is that a page that I created and that has been working for some time now suddenly doesn't work in FF for a client's customer and for me. The same page works fine in Chrome and Safari, but also fails now in IE. The advice you have given is essentially a general troubleshooting guide, and is frankly not what I would want to have to give the client's customer. I need to get my page back in a state which will allow it to work fine on the browser's standard install. I really do appreciate that you attempted to help, but I feel I need help more from a development viewpoint. I don't know exactly who "the big boys" are, but I appreciate you referring my issue to others who may be able to help. Sincere thanks, Kerry
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

That is why I flagged your post, to call the Big Guys.

See if there are updates for your graphics drive drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

That is why I flagged your post, to call the Big Guys. See if there are updates for your graphics drive drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration