Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Help! Blank viewing window on You Tube started 2 days ago :(

  • 8 replies
  • 2 have this problem
  • 48 views
  • Last reply by FredMcD

more options

Started out of the blue two days ago and I'm going round in circles.

  • I've downloaded latest Flash Player about 20 times
  • Checked Firefox is up to date
  • Been in Firefox Safe mode and disabled all plugins and extensions
  • Reset Firefox

None of these make any difference and You Tube will play in other browsers.

The viewing window is blank. You can't right click on it or anything to change settings. If you try to open a video on the right hand side list, then the big screen flashes for part of a second black and then back to blank or just stays blank.

Issue is driving me to distraction now.

Also if I try to play music files on say Soundcloud a box comes up saying something about me having a Flash blocker enabled???

Hope someone can help me please?

With many thanks!

All Replies (8)

more options

This is a screen capture...

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Thanks for the suggestions :)

I'd already cleared the cache. Have done so again and also cleared the cookies. Have also turned off the Hardware Acceleration and still no change I'm afraid.

Soundcloud says I may have a Flash blocker extension or setting in my browser and I can't find one.

You Tube still as above.. blank viewing screen.

Any other suggestions?

more options

This is what I get on Soundcloud..

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, find and check the plugins, make sure they are set properly.

Those options that you think you need, turn off the Default and select Allow.

more options

I still have the problem.. if I want to watch videos or listen to music I have to use Internet Explorer instead. It's very annoying.

I can watch some videos on Firefox on You Tube in HTLM5 but none in Flashplayer and Soundcloud is still stating that I appear to have a Flash blocker.

Nothing looks amiss and everything is up to date. All themes are set to basic. Hardly have any add-ons.

This all started out of the blue and I was hoping that it would have resolved by now via updates etc or a flash (excuse the pun) of inspiration, but alas not :(

more options

Did you run Firefox in safe mode?

Did you check the permissions?

Did you install new software, or change any settings?


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also: