Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep getting a JavaScript Application Error: 'setTimeout' called on an object that does not implement interface Window for Firefox.

  • 2 replies
  • 17 have this problem
  • 3426 views
  • Last reply by Lori_Doria

more options

I keep getting a box pop up, with the message: JavaScript Application Error: 'setTimeout' called on an object that does not implement interface Window for Firefox.

But it seems to only appear when I go to Amazon.com. Then it pops up with this message and the option OK? But as fast as I can click OK, another box appears. After about half a dozen, it disappears--until I move to another part of Amazon! I uninstalled--and then reinstalled--both Firefox and Jaza. I don't understand this!

(And of course, there's always the possibility that it doesn't only attack me on Amazon...there may be a lot of other sites that also trigger it, and I just haven't been there yet.)

Chosen solution

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 👍 5

All Replies (2)

more options

Chosen Solution

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

It worked! After "restart with add-ons disabled" the problem was gone! But I didn't really want to disable all my add-ons, forever, so I restarted the traditional way, and began taking a close look at my list of add-ons. (I'm afraid I have a tendency to install add-ons that sound neat, without really knowing what they'll do. I just figure I'll study them closely some other time....) Well, I spotted an add-on that was clearly the source of the problem...and, being too impulsive, as usual, I removed it, without first making a note of the name. So all I can tell you is that the name started with php. somethingsomething and ended with Timeout. I have no idea why I installed it in the first place, or what I thought it would do for me. Duh! But I'm really grateful for the help and guidance that fixed this problem! (And I will be much more cautious in the future.) THANK YOU!!!