Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla won't allow update of Adobe plugin although it recommends the update.

  • 10 replies
  • 7 have this problem
  • 1 view
  • Last reply by user338059

more options

Mozilla recommends update of Adobe plug in for Reader. Mozilla won't allow viewing files because plugin is out of date, When trying to update to 15.0.0.152, Mozilla blocks the update and says it is "out of date." This is being installed on a WIndows 7 desktop.

All Replies (10)

more options

hello, adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

more options

Mozilla blocked the Adobe Flash Player version 16.0.0.235 when I tried to download it, per your instructions.

more options

can you elaborate on this "block" - i'm not aware of any mechanism in firefox that would do that...

more options

Firefox blocked the Adobe update 16.0.0.235 stating the reason that it was unsafe and an obsolete version.

more options

Hello Everyone,

I used the link from Philipp and downloaded the Windows Flash Player for Plugin-based browsers. After closing FF to complete the installation I started FF to find that Flash Player 16.0.0.235 is installed and active in the list of plugins.

Thanks

more options

Adobe Flash PlayerShockwave Flash 16.0 r0 vulnerable 16.0.0.305 Adobe ReaderAdobe PDF Plug-In For Firefox and Netscape vulnerable 10.1.13.16 Adobe Flash PlayerRealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In vulnerable 1.3.3.66

I get all three of these as vulnerable and please update So I update and - even after the updates, they still show as above. I just did these updates a few minutes ago. Still get the same messages as shown above as BEFORE I did the updates. These three continually have this issue.

more options

Hi johnmyself

What is your operating system?


The current Flash version is 17.0.0.134

You can find the latest Flash player versions for Firefox on this page:

For the Adobe Reader you can look here:

more options

this particular machine is running win vista home premium.

I will check into the options you provided and get back to you on this.

thank you.

more options

Hi johnmyself, cor-el has covered Flash. For the other two:

  • Adobe ReaderAdobe PDF Plug-In For Firefox and Netscape - because Adobe doesn't support Reader XI on Vista, you're stuck with the Reader X series and corresponding plugin 10. Mozilla's plugin check site only considered the current plugin 11 series to be up-to-date, so you'll have to rely on Adobe to keep you on the latest Reader X and plugin 10. You can use Help > Check for Updates in Adobe Reader X to watch for updates.
  • Adobe Flash PlayerRealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In - this is something supplied by RealDownloader and most likely would be updated when you update that software.
more options

ok I have tried the remedies suggested. Flash ver 17 appears not to have installed and the current ver 16 persists.

as to the adobe reader - that installer says that I have a more recent version than the one available already installed.

oh well