X
Tap here to go to the mobile version of the site.

Support Forum

error code: ssl_error_bad_mac_read

Posted

I'm trying to download an attachment on email, and get:

An error occurred during a connection to ne1-attach.mail.yahoo.com.

SSL received a record with an incorrect Message Authentication Code.

I'm using mac mini with 10.10.1

Please help. Thanks.

I'm trying to download an attachment on email, and get: An error occurred during a connection to ne1-attach.mail.yahoo.com. SSL received a record with an incorrect Message Authentication Code. I'm using mac mini with 10.10.1 Please help. Thanks.

Chosen solution

That specific error code is somewhat rare in forum threads. Past solutions may have included (sometimes it's hard to tell which suggestion helped):

  • Disabling Firefox from using IPv6 (see that topic in: Firefox can't load websites but other browsers can)
  • Checking for a proxy setting in the Options dialog: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button -- try "No Proxy"
  • Fixing a flaky internet connection
  • Removing some extensions (e.g., MaskMe and an old version of DoNotTrackMe)
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

FredMcD
  • Top 10 Contributor
3821 solutions 53043 answers

Is there a reason you are using an old version of Firefox?

Download Firefox Full Installer For All languages And Systems {web link}


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Is there a reason you are using an old version of Firefox? '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox Full Installer For All languages And Systems]''' {web link} ------------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.
jscher2000
  • Top 10 Contributor
7930 solutions 64774 answers

Chosen Solution

That specific error code is somewhat rare in forum threads. Past solutions may have included (sometimes it's hard to tell which suggestion helped):

  • Disabling Firefox from using IPv6 (see that topic in: Firefox can't load websites but other browsers can)
  • Checking for a proxy setting in the Options dialog: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button -- try "No Proxy"
  • Fixing a flaky internet connection
  • Removing some extensions (e.g., MaskMe and an old version of DoNotTrackMe)
That specific error code is somewhat rare in forum threads. Past solutions may have included (sometimes it's hard to tell which suggestion helped): * Disabling Firefox from using IPv6 (see that topic in: [[Firefox can't load websites but other browsers can]]) * Checking for a proxy setting in the Options dialog: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button -- try "No Proxy" * Fixing a flaky internet connection * Removing some extensions (e.g., MaskMe and an old version of DoNotTrackMe)

Question owner

I discovered my web filter Net Nanny was causing the problem. When disabled, the downloads work fine!!

I discovered my web filter Net Nanny was causing the problem. When disabled, the downloads work fine!!