X
Tap here to go to the mobile version of the site.

Support Forum

delete a tab

Posted

Google mail keeps opening up in a new tab every time I start Firefox. How do I stop this I don't have a gmail address anymore? Thanks Tim

Google mail keeps opening up in a new tab every time I start Firefox. How do I stop this I don't have a gmail address anymore? Thanks Tim

Chosen solution

Plugins are different from extensions. Sorry, I should have mentioned that in Safe Mode, plugins are not affected so if you use those plugins you can enable them.

Can you disable extensions from:

  • Tools (or New Fx Menu ) > Add-ons > Extensions

Another user with a seemingly identical problem had the extensions FromDocToPDF and Apollo Sync for Firefox. If you have those extensions can you try disabling them to see if that fixes your issue? Looking into "Apollo Sync", it seems that it uses a Google account to work.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • ActiveTouch General Plugin Container Version 105
  • 5.1.30514.0
  • iTunes Detector Plug-in
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • NPWLPG
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40294 answers

Try resetting your homepage to only one tab. See - How to set the home page

Try resetting your homepage to only one tab. See - [[How to set the home page]]
CoryMH 229 solutions 1076 answers

Hello,

Check your home page settings at:

  • Tools (or New Fx Menu ) > Options > General

If there is a pipe (|), delete it as it is for loading up several pages when Firefox starts up.

You can also check your Firefox shortcut to see if it was modified in any way, right click on the shortcut and select "Properties". Check the Target line under Shortcut tab and make sure there is nothing after "firefox.exe".

Hello, Check your home page settings at: * Tools (or [[Image: New Fx Menu]]) > Options > General If there is a pipe (|), delete it as it is for loading up several pages when Firefox starts up. You can also check your Firefox shortcut to see if it was modified in any way, right click on the shortcut and select "Properties". Check the Target line under Shortcut tab and make sure there is nothing after "firefox.exe".

Question owner

Reset my home page did not resolve the problem. How do I find my short cut properties? This opens up like I have 2 home pages, connecting to Goggle email sign page. Thanks.

Reset my home page did not resolve the problem. How do I find my short cut properties? This opens up like I have 2 home pages, connecting to Goggle email sign page. Thanks.
CoryMH 229 solutions 1076 answers

If you open Firefox from your Desktop - right click the Firefox icon on your desktop and select Properties. Click the "Shortcut" tab and look at the Target line. If there is anything after "firefox.exe", delete it so that "firefox.exe" is the last part of the line.

If you use the Firefox shortcut from the start menu, open your start menu, right click the Firefox entry there and use the same steps as above.

For more information see Wrong home page opens when I start Firefox - How to fix


When you went to the Options dialog's General tab, did your home page settings have the Gmail sign in page as one of the links? If you removed it and found that it keeps putting itself back in there after restarting Firefox, please see How to fix preferences that won't save.

One possibility is that you have a user.js file in your profile folder. Go to:

  • Help (or New Fx Menu > Help-29 ) > Troubleshooting Information
  • On the page that loads, click the "Show Folder" to open your profile folder in Windows Explorer
  • If there is a user.js file in the folder, you can delete it. Note that Windows by default hides common file extensions, so if you just see "user", you can right click on it and select Properties to see the full file name.

More information: http://kb.mozillazine.org/Profile_folder_-_Firefox

Let us know if that helps.

If you open Firefox from your Desktop - right click the Firefox icon on your desktop and select Properties. Click the "Shortcut" tab and look at the Target line. If there is anything after "firefox.exe", delete it so that "firefox.exe" is the last part of the line. If you use the Firefox shortcut from the start menu, open your start menu, right click the Firefox entry there and use the same steps as above. For more information see [[Wrong home page opens when I start Firefox - How to fix]] ---------------------- When you went to the Options dialog's General tab, did your home page settings have the Gmail sign in page as one of the links? If you removed it and found that it keeps putting itself back in there after restarting Firefox, please see [[How to fix preferences that won't save]]. One possibility is that you have a ''user.js'' file in your profile folder. Go to: * Help (or [[Image: New Fx Menu]] > [[Image: Help-29]]) > Troubleshooting Information * On the page that loads, click the "Show Folder" to open your profile folder in Windows Explorer * If there is a ''user.js'' file in the folder, you can delete it. Note that Windows by default hides common file extensions, so if you just see "user", you can right click on it and select Properties to see the full file name. More information: http://kb.mozillazine.org/Profile_folder_-_Firefox * [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] Let us know if that helps.

Question owner

Nothing after "firefox.exe". But I did find a folder called Signedinuser.Json a JSon file is that what I'm looking for I just wanted to double check. Thanks.

Nothing after "firefox.exe". But I did find a folder called Signedinuser.Json a JSon file is that what I'm looking for I just wanted to double check. Thanks.
CoryMH 229 solutions 1076 answers

That's something else, you don't need to worry about it. About the user.js file:

What do your home page settings say in:

  • Tools (or New Fx Menu ) > Options > General
That's something else, you don't need to worry about it. About the user.js file: * http://kb.mozillazine.org/User.js_file What do your home page settings say in: * Tools (or [[Image: New Fx Menu]]) > Options > General

Question owner

Home page address, http://forecast.weather.gov/MapClick.php?CityName=Naperville&state=IL&site=LOT&textField1=41.7626&textField2=-88.1543#.VGD0JsmwVGU Show my home page is selected
CoryMH 229 solutions 1076 answers

Its very strange that it keeps opening Gmail of all things when Firefox starts up and those settings aren't causing it. Would you mind entering about:preferences into your address bar and checking the General tab there to make sure it matches up with what you have in the Options dialog?


If everything looks fine on that page too, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Its very strange that it keeps opening Gmail of all things when Firefox starts up and those settings aren't causing it. Would you mind entering '''about:preferences''' into your address bar and checking the General tab there to make sure it matches up with what you have in the Options dialog? ---------- If everything looks fine on that page too, '''try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. When the Firefox Safe Mode window appears, select "Start in Safe Mode".<br> [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
jscher2000
  • Top 10 Contributor
8786 solutions 71864 answers

Do you have any add-ons that might need to connect to Google? You can review and manage add-ons on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. If you find any Google-related plugins, try setting them to "Never Activate".

In the left column, click Extensions. Then disable anything nonessential or unrecognized.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that end the Google login request?

Do you have any add-ons that might need to connect to Google? You can review and manage add-ons on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. If you find any Google-related plugins, try setting them to "Never Activate". In the left column, click Extensions. Then disable anything nonessential or unrecognized. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that end the Google login request?
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158913 answers

The signedInUser.json file is used by Firefox Sync to store the credentials, so you would have to enter the Master Password to make Sync work.

The signedInUser.json file is used by Firefox Sync to store the credentials, so you would have to enter the Master Password to make Sync work.

Question owner

Cor-el; I don't have a master password.

CoryMH; When I switched to the safe mode Goggle sign in did not open. Followed suggested fix, shut off, use hardware acceleration when available. Still appeared after re-start.

Cor-el; I don't have a master password. CoryMH; When I switched to the safe mode Goggle sign in did not open. Followed suggested fix, shut off, use hardware acceleration when available. Still appeared after re-start.
CoryMH 229 solutions 1076 answers

An extension is the likely causing your problem. Have you tried following the instructions in jscher2000's post?

An extension is the likely causing your problem. Have you tried following the instructions in '''jscher2000''''s post?

Question owner

Cory, Yes I did. I shut off both goggle plugins. Did not work.

Cory, Yes I did. I shut off both goggle plugins. Did not work.
CoryMH 229 solutions 1076 answers

Chosen Solution

Plugins are different from extensions. Sorry, I should have mentioned that in Safe Mode, plugins are not affected so if you use those plugins you can enable them.

Can you disable extensions from:

  • Tools (or New Fx Menu ) > Add-ons > Extensions

Another user with a seemingly identical problem had the extensions FromDocToPDF and Apollo Sync for Firefox. If you have those extensions can you try disabling them to see if that fixes your issue? Looking into "Apollo Sync", it seems that it uses a Google account to work.

Plugins are different from extensions. Sorry, I should have mentioned that in Safe Mode, plugins are not affected so if you use those plugins you can enable them. Can you disable extensions from: * Tools (or [[Image: New Fx Menu]]) > Add-ons > Extensions Another user with a seemingly identical problem had the extensions ''FromDocToPDF'' and ''Apollo Sync for Firefox''. If you have those extensions can you try disabling them to see if that fixes your issue? Looking into "Apollo Sync", it seems that it uses a Google account to work.

Question owner

Yea! that worked. Now how can I sync my IPhone?

Yea! that worked. Now how can I sync my IPhone?
CoryMH 229 solutions 1076 answers

If you do not want to use Apollo Sync anymore, you can also use a different sync extension. This will allow you to avoid using your Google account entirely. You can search for alternatives here:

A good idea would be to read the add-on description and the user reviews to make sure that the add-on is well suited to your needs before installing. It also helps you prepare for any issues that other users have experienced with the extension.

If you do not want to use Apollo Sync anymore, you can also use a different sync extension. This will allow you to avoid using your Google account entirely. You can search for alternatives here: * https://addons.mozilla.org/en-US/firefox/ * A quick search for "bookmark sync" showed extensions such as this one: https://addons.mozilla.org/en-US/firefox/addon/fvd-synchronizer A good idea would be to read the add-on description and the user reviews to make sure that the add-on is well suited to your needs before installing. It also helps you prepare for any issues that other users have experienced with the extension.

Question owner

Cory, Deleted the Apollo Sync and loaded the Firefox synchronizer. Then opened set sync, reloaded account information. Did not give me an area to add other devices?

Cory, Deleted the Apollo Sync and loaded the Firefox synchronizer. Then opened set sync, reloaded account information. Did not give me an area to add other devices?
CoryMH 229 solutions 1076 answers

Note that Firefox is not available for iPhones, so the built-in Firefox sync might not be able to help you. See Retiring Firefox Home.

Unfortunately I don't use those particular sync tools myself so my knowledge on them is limited. If you need support for any of the extensions it might be better to contact the support page for those extensions there. This information is usually on the right side of the add-ons page, or if you already installed the extension go to:

  • Tools (or New Fx Menu ) > Add-ons > Extensions
  • There should be a "More" link for each extension, click on it for the extension you want to see more information
Note that Firefox is not available for iPhones, so the built-in Firefox sync might not be able to help you. See [https://blog.mozilla.org/services/2012/08/31/retiring-firefox-home/ Retiring Firefox Home]. Unfortunately I don't use those particular sync tools myself so my knowledge on them is limited. If you need support for any of the extensions it might be better to contact the support page for those extensions there. This information is usually on the right side of the add-ons page, or if you already installed the extension go to: * Tools (or [[Image: New Fx Menu]]) > Add-ons > Extensions * There should be a "More" link for each extension, click on it for the extension you want to see more information

Question owner

To bad it was retired. I really like that sync mode. Thanks for all your help.

To bad it was retired. I really like that sync mode. Thanks for all your help.