Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox wont show facebook emoticons and addons wont stay

  • 6 replies
  • 6 have this problem
  • 522 views
  • Last reply by Micros

more options

Hello,

I am having two problems. 1. In firefox, facebook isnt showing emoticons in the chat or comments..

2. I installed a check pagerank plugin and then customize firefox to show it on toolbar, but when I restart firefox it gets disappeared and I have to customize again and drag it to the toolbar again..

I don't know whats the problem.. I bought new laptop, besides this everything is working fine.. using windows 8.1 64-bit.

All Replies (6)

more options

Missing icons can be supplied by a font that is downloaded from the server (@font-face), especially if you see little boxes that show the hex code of the characters.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

more options

Hello,

Thank you for your kind reply.. However, "Allow pages to choose their own fonts, instead of my selections above" was already checked..

And gfx.downloadable_fonts.enabled is already true..

sadly, this doesn't resolve my issue :/

more options

You can open the Web Console (Firefox/Tools > Web Developer). You can check if there are error message about downloading font files

Check on the Network tab if any (font) content is blocked and has a file size 0 (zero). Reload the page via F5 or bypass the cache via Ctrl + F5 to generate a new log.

more options

Hi,

I get all the green, all are loading fine I guess.

Check the screenshot: http://i.imgur.com/mk3YKqt.png


Also, the same post show the emoticons sometimes, sometimes it doesn't. I commented an emoticon it showed my emoticon and it started showing the one in the posts as well, but then disappeared, I didn't even refreshed..

I dont know why its happening. Any help?

more options

Hi,

Also, check the attached screenshot, I customize firefox to show this plugin, it shows it there, but when i restart it, it disappears and I have to put it there again..


And Emoticons still sometimes appear and sometime don't, it remains a big issue for me.

more options

Bug is triggered by hardware acceleration - when I turn off hardware acceleration Firefox shows emoticons normally.

https://support.mozilla.org/en-US/questions/1053941