X
Tap here to go to the mobile version of the site.

Support Forum

Firefox UI is slow when typing or selecting text (after 33.0 update)

Posted

After the 33.0 update, I noticed that typing or backspacing in any field on a webpage or even in the Firefox address bar is slow to echo, about a 1 second lag. Also, selecting typed text (to delete it, etc.) by a quick click-drag doesn't select the whole area, yet when I click in the dialog to deselect, the portion that wasn't showing as selected at first, becomes selected for a moment before the whole string selection hilite disappears.

This makes the browser very cumbersome to use.

This appears to be new to 33.0. I tried resetting Firefox, but that didn't fix the problem. No issue in IE 11.0, so I don't think its malware. I also keep all s/w up-to-date, and run avast/zonealarm for security. I've never had a malware infection on this machine. Win7 Home Premium 64-bit, 8GB RAM. Resource utilization is low, so no out-of-control processes.

I did apply the latest Microsoft "Patch Tuesday" updates on 10/15, the same day that I updated Firefox. This may complicate the diagnosis. But again, IE wasn't affected, so how is the Firefox UI different for basic keyboard/display I/O?

If there's an easy way to "downgrade" to the prior 32.0.3 revision, I could try that to confirm. Please help!

After the 33.0 update, I noticed that typing or backspacing in any field on a webpage or even in the Firefox address bar is slow to echo, about a 1 second lag. Also, selecting typed text (to delete it, etc.) by a quick click-drag doesn't select the whole area, yet when I click in the dialog to deselect, the portion that wasn't showing as selected at first, becomes selected for a moment before the whole string selection hilite disappears. This makes the browser very cumbersome to use. This appears to be new to 33.0. I tried resetting Firefox, but that didn't fix the problem. No issue in IE 11.0, so I don't think its malware. I also keep all s/w up-to-date, and run avast/zonealarm for security. I've never had a malware infection on this machine. Win7 Home Premium 64-bit, 8GB RAM. Resource utilization is low, so no out-of-control processes. I did apply the latest Microsoft "Patch Tuesday" updates on 10/15, the same day that I updated Firefox. This may complicate the diagnosis. But again, IE wasn't affected, so how is the Firefox UI different for basic keyboard/display I/O? If there's an easy way to "downgrade" to the prior 32.0.3 revision, I could try that to confirm. Please help!

Modified by mozgbl37

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Google Update
  • 5.1.30514.0
  • ActiveTouch General Plugin Container Version 105
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 33.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.5 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • DuckDuckGo Plus 0.4.2 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • FireFTP 2.0.21 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • Hostname in Titlebar 3.0.1 (bughunter2@hostnameintitlebar)
  • HTTPS-Everywhere 4.0.2 (https-everywhere@eff.org)
  • KeeFox 1.4.3 (keefox@chris.tomlinson)
  • NoScript 2.6.9.1 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Privacy Badger Firefox 0.2.3 (jid1-MnnxcxisBPnSXQ@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2021.112 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 5670
  • adapterDescription2:
  • adapterDeviceID: 0x68d8
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 12-11-2009
  • driverDate2:
  • driverVersion: 8.690.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 5670 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141011015303
  • browser.startup.homepage: www.cincinnatibell.net
  • browser.startup.homepage_override.buildID: 20141011015303
  • browser.startup.homepage_override.mstone: 33.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 33.0
  • font.internaluseonly.changed: True
  • gfx.blacklist.suggested-driver-version: 10.6
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1413357504
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1413507878
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1413572154
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npctrl: 2
  • plugin.state.npdeployjava: 0
  • plugin.state.nppdfxcviewnpplugin: 0
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.tls.version.min: 1
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1411414763

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
16992 solutions 153423 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Helpful Reply

Safe mode fixed it, so I then tested disabling all add-ons and plug-ins--no joy. I then disabled hardware acceleration, which fixed it. Re-enabled all add-ons and plug-ins, and still works, so it was the hardware acceleration.

For reference, my system is a Dell desktop with an ATI Radeon HD5670 graphics card, and Dell's latest official driver is the one that shipped with the system in 2010. ATI (AMD) has their latest generic driver for the HD5xxx series dated Sep 2014. Thanks, Dell :-( So, can't really do much about that--glad I'm not a gamer.

Anyway, this still begs the question of what changed in the last 3 days where Firefox went from working just fine with hardware acceleration enabled, to exhibiting this problem.

Safe mode fixed it, so I then tested disabling all add-ons and plug-ins--no joy. I then disabled hardware acceleration, which fixed it. Re-enabled all add-ons and plug-ins, and still works, so it was the hardware acceleration. For reference, my system is a Dell desktop with an ATI Radeon HD5670 graphics card, and Dell's latest official driver is the one that shipped with the system in 2010. ATI (AMD) has their latest generic driver for the HD5xxx series dated Sep 2014. Thanks, Dell :-( So, can't really do much about that--glad I'm not a gamer. Anyway, this still begs the question of what changed in the last 3 days where Firefox went from working just fine with hardware acceleration enabled, to exhibiting this problem.
bigst 0 solutions 10 answers

Same problem, same solution: disable hardware acceleration with ATI Mobility Radeon HD 5145 - driver 8.653.0.0 (latest version)

Disable hardware acceleration: see https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration

Same problem, same solution: disable hardware acceleration with ATI Mobility Radeon HD 5145 - driver 8.653.0.0 (latest version) Disable hardware acceleration: see [https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration]

Modified by bigst

hairyfox 0 solutions 7 answers

I've encountered similar problems with lagging (text, tabs, page scroll) after updating to FF 33.0. It seems that FF 33.0 might have some conflict with certain graphics adapters.

Mine:

  • ATI Mobility Radeon HD5650 (driver: 8.702.5.0 latest version)
  • Intel HD Graphics (driver: 8.702.5.0 latest version)

NVIDIA adapters are also amongst those reported as causing a lag in FF 33.0.

I had checked the release notes for the newer FF 33.0.1, but this lagging bug is not even recognized as an extant problem. Disabling hardware acceleration is a not a long-term solution.

Hoping that the conflict would be resolved soon. Otherwise I probably would stick with FF 32.0.3 indefinitely, or switch to another browser. The pervasive lag is too severe & non-conducive even for casual browsing.


Note:- I wasn't able to post a reply here, until I registered for a new user account (which is possible only if I post a New Question). Hence more details of my situation at: https://support.mozilla.org/en-US/questions/1027663

I've encountered similar problems with lagging (text, tabs, page scroll) after updating to FF 33.0. It seems that FF 33.0 might have some conflict with certain graphics adapters. Mine: <ul> <li><b>ATI Mobility Radeon HD5650</b> (driver: 8.702.5.0 latest version)</li> <li><b>Intel HD Graphics</b> (driver: 8.702.5.0 latest version)</li> </ul> '''NVIDIA''' adapters are also amongst those reported as causing a lag in FF 33.0. I had checked the release notes for the newer FF 33.0.1, but this lagging bug is not even recognized as an extant problem. Disabling hardware acceleration is a not a long-term solution. Hoping that the conflict would be resolved soon. Otherwise I probably would stick with FF 32.0.3 indefinitely, or switch to another browser. The pervasive lag is too severe & non-conducive even for casual browsing. <hr> Note:- I wasn't able to post a reply here, until I registered for a new user account (which is possible only if I post a New Question). Hence more details of my situation at: https://support.mozilla.org/en-US/questions/1027663

Question owner

hairycactus,

It looks like you've done a thorough survey, thanks! Did you file a bug report? I haven't yet, but I could. You do seem to have more complete information, so have you or would you be willing to file it? I also have the disadvantage of having updated Windows the same day, so might be less credible.

hairycactus, It looks like you've done a thorough survey, thanks! Did you file a bug report? I haven't yet, but I could. You do seem to have more complete information, so have you or would you be willing to file it? I also have the disadvantage of having updated Windows the same day, so might be less credible.
bigst 0 solutions 10 answers

bug 1089875 created

[https://bugzilla.mozilla.org/show_bug.cgi?id=1089875 bug 1089875] created

Question owner

Thanks!

Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
16992 solutions 153423 answers

Does setting layers.offmainthreadcomposition.enabled = false on the about:config page has any effect on this like suggested in the bug report?

Does setting layers.offmainthreadcomposition.enabled = false on the <b>about:config</b> page has any effect on this like suggested in the bug report?
hairyfox 0 solutions 7 answers

Thanks for the bug report.

In my browser, layers.offmainthreadcomposition.enabled = false by default. I have never changed this value.

ie. Hardware Acceleration = enabled, layers.OMTC.enabled = false => Experienced severe lagging (text-related, tab switching, page scrolling) in FF 33.0 => Ok in FF 32.0.3 & earlier versions

The above was the case before I was forced to reinstall FF 32.0.3 after encountering the "Couldn't load XPCOM" bug (whereby the rolled-back FF couldn't even launch) after a Windows system restore.

At the moment, I am hesitant to update to the newer FF 33.0.1 because of the unresolved lag, as well as the possibility of getting the "Couldn't load XPCOM" error again.

Has the lagging bug anything to do with the "black start-up screen" (apparently fixed in 33.0.1) or the "black main window" (still unresolved in 33.0.1) experienced by some FF users "with certain graphics drivers" or "some combination of hardware and drivers" respectively ?

Thanks for the bug report. In my browser, '''layers.offmainthreadcomposition.enabled = false''' by default. I have never changed this value. ie. '''Hardware Acceleration = enabled''', '''layers.OMTC.enabled = false''' => Experienced severe lagging (text-related, tab switching, page scrolling) in FF 33.0 => Ok in FF 32.0.3 & earlier versions The above was the case before I was forced to reinstall FF 32.0.3 after encountering the ''"Couldn't load XPCOM"'' bug (whereby the rolled-back FF couldn't even launch) after a Windows system restore. At the moment, I am hesitant to update to the newer [https://www.mozilla.org/en-US/firefox/33.0.1/releasenotes/ FF 33.0.1] because of the unresolved lag, as well as the possibility of getting the ''"Couldn't load XPCOM"'' error again. Has the lagging bug anything to do with the ''"black start-up screen"'' (apparently fixed in 33.0.1) or the ''"black main window"'' (still unresolved in 33.0.1) experienced by some FF users "with certain graphics drivers" or "some combination of hardware and drivers" respectively ?

Question owner

@cor-el:

My about:config shows layers.offmainthreadcomposition.enabled = true by default, and this was the setting up till now. So here are my test results (Firefox 33.0.1; using about:config to toggle state of layers.offmainthreadcomposition.enabled, and Tools|Options|Advanced|General to change hardware acceleration):

hardware acceleration OFF (unchecked), layers.offmainthreadcomposition.enabled = true: No lag problem.

hardware acceleration OFF (unchecked), layers.offmainthreadcomposition.enabled = false: No lag problem.

hardware acceleration ON (checked), layers.offmainthreadcomposition.enabled = true. Originally described lagging symptoms reappear.

hardware acceleration ON (checked), layers.offmainthreadcomposition.enabled = false: No lag problem.

I closed and reopened the browser after each change. Testing was done in the address bar and reply window for this post. Note that I did *not* create a new profile for this test. I can do so if that would be useful.

Because the layers.offmainthreadcomposition.enabled setting seems to have a narrower scope than the hardware acceleration option, I'll leave the former false and the latter ON, unless you recommend otherwise.

Side question: why would hairycactus have different about:config defaults than me if the browser version is the same (presumably)?

@cor-el: My about:config shows layers.offmainthreadcomposition.enabled = true by default, and this was the setting up till now. So here are my test results (Firefox 33.0.1; using about:config to toggle state of layers.offmainthreadcomposition.enabled, and Tools|Options|Advanced|General to change hardware acceleration): hardware acceleration OFF (unchecked), layers.offmainthreadcomposition.enabled = true: No lag problem. hardware acceleration OFF (unchecked), layers.offmainthreadcomposition.enabled = false: No lag problem. hardware acceleration ON (checked), layers.offmainthreadcomposition.enabled = true. Originally described lagging symptoms reappear. hardware acceleration ON (checked), layers.offmainthreadcomposition.enabled = false: No lag problem. I closed and reopened the browser after each change. Testing was done in the address bar and reply window for this post. Note that I did *not* create a new profile for this test. I can do so if that would be useful. Because the layers.offmainthreadcomposition.enabled setting seems to have a narrower scope than the hardware acceleration option, I'll leave the former false and the latter ON, unless you recommend otherwise. Side question: why would hairycactus have different about:config defaults than me if the browser version is the same (presumably)?

Modified by mozgbl37

Question owner

@bigst:

Seems there is a discrepancy in the state of layers.offmainthreadcomposition.enabled that causes the lag problem....

Care to break the tie?  ;-)

@all:

Of course, there could be other preferences that might account for this. Based on file compares, here are the relevant entries in my prefs.js from just before my testing in my previous post, and what appeared in their place after my testing:

Before (h/w accel OFF, layers.offmainthreadcomposition.enabled = true (default)): user_pref("gfx.direct2d.disabled", true); user_pref("layers.acceleration.disabled", true);

After (h/w accel ON, layers.offmainthreadcomposition.enabled = false): user_pref("layers.offmainthreadcomposition.enabled", false);

None of these entries were present when the lag problem appeared (h/w accel ON, layers.offmainthreadcomposition.enabled = true (default)).

Note that apparently only non-default entries appear, and that I never explicitly altered anything in about:config except layers.offmainthreadcomposition.enabled.

@bigst: Seems there is a discrepancy in the state of layers.offmainthreadcomposition.enabled that causes the lag problem.... Care to break the tie? ;-) @all: Of course, there could be other preferences that might account for this. Based on file compares, here are the relevant entries in my prefs.js from just before my testing in my previous post, and what appeared in their place after my testing: Before (h/w accel OFF, layers.offmainthreadcomposition.enabled = true (default)): '''user_pref("gfx.direct2d.disabled", true);''' '''user_pref("layers.acceleration.disabled", true);''' After (h/w accel ON, layers.offmainthreadcomposition.enabled = false): '''user_pref("layers.offmainthreadcomposition.enabled", false);''' None of these entries were present when the lag problem appeared (h/w accel ON, layers.offmainthreadcomposition.enabled = true (default)). Note that apparently only non-default entries appear, and that I never explicitly altered anything in about:config except layers.offmainthreadcomposition.enabled.
bigst 0 solutions 10 answers

@mozgbl37 , @cor-el : layers.offmainthreadcomposition.enabled = false ; hardware acceleration ON ==> OK, no lagging.

@all: see also bug 1088034

some graphics drivers are blacklisted due to old drivers . Maybe that's the reason why hairycactus has different settings. see Blocked Graphics Drivers

@mozgbl37 , @cor-el : layers.offmainthreadcomposition.enabled = false ; hardware acceleration ON ==> OK, no lagging. @all: see also [https://bugzilla.mozilla.org/show_bug.cgi?id=1088034 bug 1088034] some graphics drivers are blacklisted due to old drivers . Maybe that's the reason why hairycactus has different settings. see [https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers Blocked Graphics Drivers]
bigst 0 solutions 10 answers

Especialy bug 1084440 is interesting.

Question asked in that bug: re-enable OMTC and

- layers.prefer-d3d9 to true
- gfx.direct2d.disabled to true

This will tell us whether we need to blacklist the driver entirely or if we can still do accelerated compositing through D3D9.

And about the driver: A quick forum search yielded this info: http://goo.gl/BD21ni

Apparently those driver will work on *any* laptop with kludged drivers such as the Toshiba. Can you give them a try? They're 2011 but at least that's newer than 2009. The instructions are pretty detailed and the forum from which I obtained this info said to be exacting in following the instructions. I'd also suggest having the installer for the drivers you currently have.

Especialy [https://bugzilla.mozilla.org/show_bug.cgi?id=1084440 bug 1084440] is interesting. Question asked in that bug: re-enable OMTC and - layers.prefer-d3d9 to true - gfx.direct2d.disabled to true This will tell us whether we need to blacklist the driver entirely or if we can still do accelerated compositing through D3D9. And about the driver: A quick forum search yielded this info: http://goo.gl/BD21ni Apparently those driver will work on *any* laptop with kludged drivers such as the Toshiba. Can you give them a try? They're 2011 but at least that's newer than 2009. The instructions are pretty detailed and the forum from which I obtained this info said to be exacting in following the instructions. I'd also suggest having the installer for the drivers you currently have.
bigst 0 solutions 10 answers

For me:

hardware acceleration ON layers.offmainthreadcomposition.enabled = true layers.prefer-d3d9 = true gfx.direct2d.disabled = true

==> NOT OK

- no lagging - but: when firefox is set full screen, the minimize/maximize/close buttons are gone.

For me: hardware acceleration ON layers.offmainthreadcomposition.enabled = true layers.prefer-d3d9 = true gfx.direct2d.disabled = true ==> NOT OK - no lagging - but: when firefox is set full screen, the minimize/maximize/close buttons are gone.

Modified by bigst

bigst 0 solutions 10 answers

@hairycactus: Blocked Graphics Drivers: Our current blacklisting implementation does not properly support dual-GPU systems

@hairycactus: [[Blocked Graphics Drivers|Blocked Graphics Drivers]]: Our current blacklisting implementation does not properly support dual-GPU systems

Question owner

@bigst:

I tried your suggestion:

 re-enable OMTC and
 - layers.prefer-d3d9 to true
 - gfx.direct2d.disabled to true

This worked (i.e. no lag), but the color contrast was muted compared to before (most obvious on the minimize/maximize/close buttons, which were still there full-screen BTW). So I reverted (to all 3 of these false), and the color contrast was back to normal. Once I noticed the difference, I also checked turning hardware acceleration OFF in Options--the color contrast was normal as well--no further improvement.

So I'm back to hardware acceleration ON, and OMTC enabled = false. Anyone know whether this still provides some graphics speedup over hardware acceleration OFF?

For reference-- I checked my ATI driver version: 8.690.0.0 12/11/09 ATI Radeon HD 5670

@bigst: I tried your suggestion: re-enable OMTC and - layers.prefer-d3d9 to true - gfx.direct2d.disabled to true This worked (i.e. no lag), but the color contrast was muted compared to before (most obvious on the minimize/maximize/close buttons, which were still there full-screen BTW). So I reverted (to all 3 of these false), and the color contrast was back to normal. Once I noticed the difference, I also checked turning hardware acceleration OFF in Options--the color contrast was normal as well--no further improvement. So I'm back to hardware acceleration ON, and OMTC enabled = false. Anyone know whether this still provides some graphics speedup over hardware acceleration OFF? For reference-- I checked my ATI driver version: 8.690.0.0 12/11/09 ATI Radeon HD 5670

Question owner

OK, just updated to 33.0.2, and redid all above tests with same results.

After reading bug 1089183, I expanded my tests with hardware acceleration ON and OMTC enabled = true to cover all combinations of:

layers.prefer-d3d9:	T    T    F    F
gfx.direct2d.disabled:	T    F    T    F
test result:		C    C    L    L

where 'C' means no lag, but color contrast problem, and 'L' means lag problems, but color OK. No joy here...

so again, I've reverted to hardware acceleration ON, OMTC enabled = false, others default (both false). Still looking for an answer to whether this is any benefit over just hardware acceleration OFF?

OK, just updated to 33.0.2, and redid all above tests with same results. After reading bug 1089183, I expanded my tests with hardware acceleration ON and OMTC enabled = true to cover all combinations of: layers.prefer-d3d9: T T F F gfx.direct2d.disabled: T F T F test result: C C L L where 'C' means no lag, but color contrast problem, and 'L' means lag problems, but color OK. No joy here... so again, I've reverted to hardware acceleration ON, OMTC enabled = false, others default (both false). Still looking for an answer to whether this is any benefit over just hardware acceleration OFF?

Modified by cor-el

hairyfox 0 solutions 7 answers

@ mozgbl37: "ATI Radeon HD 5670, v 8.690.0.0 (12/11/09)"

According to Mozilla, for AMD/ATI graphics cards in Windows OS, FF requires driver of at least technical version 8.741.0.0. I suppose this means that your current graphics driver is blacklisted.

Since you're using a Dell desktop with a (presumably) removable graphics card, isn't it possible/ safe to upgrade using AMD's direct installer (v 14.9, 29 Sep 2014 — Win7 64-bit, 32-bit) ?

Or does your graphics card have Dell-specific features that require Dell drivers ? Try checking: ATI Catalyst Control Center > Graphics > Information Center > Graphics Software > Driver Packaging Version

Is your driver version stated as 8.690.0.0-[xxxx], or 8.690.0.0-[xxxx]-Dell ?

If the driver is Dell-specific, there might be a newer driver version available for ATI Radeon HD 5670. Eg. v 8.850.0.0 (19 Apr 2011) for Dell Studio XPS 8100 Desktop running Win 7. This is a higher version than Mozilla's specific minimum 8.741.0.0.

If the above is not your desktop model, perhaps you could download the portable version of the Driver Identifier app to see if you could hunt down a newer Dell-specific driver version for your graphics card.

As comparison, mine is a Lenovo laptop where the graphics "card" is integrated as a chip on the motherboard (ie. no physically-removable card). And the driver is Lenovo-specific (ver. xxxx-xxxx-Lenovo), thus it seems that I can't simply upgrade the driver using the latest generic installer from AMD's website.

''@ mozgbl37: "ATI Radeon HD 5670, v 8.690.0.0 (12/11/09)"'' According to Mozilla, for AMD/ATI graphics cards in Windows OS, FF requires driver of at least technical version [https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Windows 8.741.0.0]. I suppose this means that your current graphics driver is blacklisted. Since you're using a Dell desktop with a (presumably) removable graphics card, isn't it possible/ safe to upgrade using AMD's direct installer (v 14.9, 29 Sep 2014 — Win7 [http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64 64-bit], [http://support.amd.com/en-us/download/desktop?os=Windows+7+-+32 32-bit]) ? Or does your graphics card have Dell-specific features that require Dell drivers ? Try checking: '''ATI Catalyst Control Center > Graphics > Information Center > Graphics Software > Driver Packaging Version''' Is your driver version stated as 8.690.0.0-[xxxx], or 8.690.0.0-[xxxx]-Dell ? If the driver is Dell-specific, there might be a newer driver version available for ATI Radeon HD 5670. Eg. v [http://www.driveridentifier.com/scan/ati-radeon-hd-5670/download/89979245/962AF9B7BDF24887865A21ADD2F29B13/PCI%5CVEN_1002%26DEV_68D8%26SUBSYS_68E01028 8.850.0.0] (19 Apr 2011) for Dell Studio XPS 8100 Desktop running Win 7. This is a higher version than Mozilla's specific minimum 8.741.0.0. If the above is not your desktop model, perhaps you could download the [http://www.driveridentifier.com/files/driveridentifier_portable.exe portable] version of the Driver Identifier app to see if you could hunt down a newer Dell-specific driver version for your graphics card. As comparison, mine is a Lenovo laptop where the graphics "card" is integrated as a chip on the motherboard (ie. no physically-removable card). And the driver is Lenovo-specific (ver. xxxx-xxxx-Lenovo), thus it seems that I can't simply upgrade the driver using the latest generic installer from AMD's website.
hairyfox 0 solutions 7 answers

@ mozgbl37: "why would hairycactus have different about:config defaults than me if the browser version is the same (presumably)?"

OMTC = disabled has always been the default in all my FF versions. But interestingly enough, the latest FF 33.0.2 apparently introduces a "new" feature whereby "Windows: OMTC enabled by default".

Doesn't that imply that OMTC = disabled was the former default setting in prior FF versions ?


@ bigst: "Blocked Graphics Drivers: Our current blacklisting implementation does not properly support dual-GPU systems"

Yes, I'm using an integrated dual-GPU, switchable graphics Lenovo laptop, as opposed to single-GPU laptop or desktop. But only 1 GPU is active at any one time, & my default primary GPU is ATI Mobility Radeon HD 5650.

The secondary Intel HD Graphics GPU is by default inactive, unless I choose to "switch graphics", eg. when running on battery. But switching GPU is not compulsory, even if I'm on battery mode. So do dual-GPU systems necessarily conflict with FF design ?

Btw, although 'Windows's Device Manager > Update Driver' previously indicated that I already have the latest GPU driver version, I managed to hunt down & successfully install the latest-available (but only very slightly newer) Lenovo-specific driver version.

Primary GPU: ATI Mobility Radeon HD 5650 (0x68C1)

  • Previous: v 8.702.5 -100505a-100063C-Lenovo (05 May 2010, factory)
  • Now: v 8.772 -100831a-108908C-Lenovo (31 Aug 2010, latest from Lenovo)

(where: v 8.772.0.0 exceeds FF's required minimum v 8.741.0.0)

Secondary GPU: Intel HD Graphics (0x0046, Core i5)

Having already tried FF 33.0 (severe lagging, unusable), would it be useful to try installing FF 33.0.2 (released: 28 Oct 2014) now, or would it be pointless because dual-GPU systems are still being blacklisted by Mozilla ?

''@ mozgbl37: "why would hairycactus have different about:config defaults than me if the browser version is the same (presumably)?"'' OMTC = disabled has always been the default in all my FF versions. But interestingly enough, the latest [https://www.mozilla.org/en-US/firefox/33.0.2/releasenotes FF 33.0.2] apparently introduces a "new" feature whereby '''"Windows: OMTC enabled by default"'''. Doesn't that imply that OMTC = disabled was the former default setting in prior FF versions ? ''@ bigst: "Blocked Graphics Drivers: Our current blacklisting implementation does not properly support dual-GPU systems"'' Yes, I'm using an integrated dual-GPU, switchable graphics Lenovo laptop, as opposed to single-GPU laptop or desktop. But only 1 GPU is active at any one time, & my default primary GPU is ATI Mobility Radeon HD 5650. The secondary Intel HD Graphics GPU is by default inactive, unless I choose to "switch graphics", eg. when running on battery. But switching GPU is not compulsory, even if I'm on battery mode. So do dual-GPU systems necessarily conflict with FF design ? Btw, although 'Windows's Device Manager > Update Driver' previously indicated that I already have the latest GPU driver version, I managed to hunt down & successfully install the latest-available (but only very slightly newer) Lenovo-specific driver version. '''Primary GPU: ATI Mobility Radeon HD 5650 (0x68C1)''' * Previous: v '''8.702.5''' -100505a-100063C-Lenovo ''(05 May 2010, factory)'' * Now: v '''8.772''' -100831a-108908C-Lenovo ''(31 Aug 2010, latest from Lenovo)'' (where: v 8.772.0.0 exceeds FF's required minimum v 8.741.0.0) Secondary GPU: Intel HD Graphics (0x0046, Core i5) Having already tried FF 33.0 (severe lagging, unusable), would it be useful to try installing FF 33.0.2 (released: 28 Oct 2014) now, or would it be pointless because dual-GPU systems are ''still'' being blacklisted by Mozilla ?
hairyfox 0 solutions 7 answers

@ mozgbl37: "I've reverted to hardware acceleration ON, OMTC enabled = false, others default (both false). Still looking for an answer to whether this is any benefit over just hardware acceleration OFF?"

Depending on your system setup, you may experience the following, or not much difference at all.

FF HWA = on, with compatible GPU Significant performance boost for video playback, flash animation, 3D features (eg. in Google Earth/Maps); Supposedly faster rendering & better support of HTML5 webpages (the latest & complete HTML standard); All these whilst being less demanding on the CPU.

FF HWA = off FF launches more quickly; No lag; Possibly faster page-loading, but at the expense of video resolution (lower fps) & animation rendering (less fluid); Higher CPU usage incurred for similar video/ animation performance-quality.

FF HWA = on, with non-compatible/ blacklisted GPU Possibility of FF lagging, unresponsive, crashing, taking a long time to launch; Web pages load really slowly; Blurry fonts/ graphics; OS lagging/ hanging (ridiculously-high CPU usage); Possibly long OS boot up/ shutdown times, etc.


http://html5test.com Have you ever tried the above test with your lagging FF 33.0.2, & perhaps with different config settings ?

Using my rolled-back FF 32.0.3 (no text lag), my score is 460 out of 555 pts regardless of settings. But according to the webpage's "compare" tab, past results for FF 32.0 users show a higher averaged score (475) ! The attached screenshot compares the scores for FF (32.0.3, 32.0) with those of IE11, Chrome 37 & Opera 24.

''@ mozgbl37: "I've reverted to hardware acceleration ON, OMTC enabled = false, others default (both false). Still looking for an answer to whether this is any benefit over just hardware acceleration OFF?"'' Depending on your system setup, you may experience the following, or not much difference at all. '''FF HWA = on, with compatible GPU''' Significant performance boost for video playback, flash animation, 3D features (eg. in Google Earth/Maps); Supposedly faster rendering & better support of HTML5 webpages (the latest & complete HTML standard); All these whilst being less demanding on the CPU. '''FF HWA = off''' FF launches more quickly; No lag; Possibly faster page-loading, but at the expense of video resolution (lower fps) & animation rendering (less fluid); Higher CPU usage incurred for similar video/ animation performance-quality. '''FF HWA = on, with non-compatible/ blacklisted GPU''' Possibility of FF lagging, unresponsive, crashing, taking a long time to launch; Web pages load really slowly; Blurry fonts/ graphics; OS lagging/ hanging (ridiculously-high CPU usage); Possibly long OS boot up/ shutdown times, etc. http://html5test.com Have you ever tried the above test with your lagging FF 33.0.2, & perhaps with different config settings ? Using my rolled-back FF 32.0.3 (no text lag), my score is 460 out of 555 pts regardless of settings. But according to the webpage's "compare" tab, past results for FF 32.0 users show a higher averaged score (475) ! The attached screenshot compares the scores for FF (32.0.3, 32.0) with those of IE11, Chrome 37 & Opera 24.