Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dropdown menu not working in Firefox ubuntu

more options

We are trying to create a lockdown in Ubuntu where users are only allowed to use firefox without being able to print, edit/open settings, and are only allowed to use the extensions already installed by us (Java). In order to do this we created a new session in /usr/share/xsessions

[Desktop Entry] Encoding=UTF-8 Name=Kiosk Mode Comment=Firefox Kiosk Mode Exec=/usr/bin/firefox -height 900 -width 1440 Type=Application

When we start in this session, everything seems to work fine. Firefox starts, no menu's in the background. When firefox is closed, the session is closed too. With this session somehow the menu's cannot be opened with the mouse, but keyboard shortcuts still work.

But the real problem is that the users need to go to a certain site which is using dropdown menu's. The problem is that when we use this session, users cannot open the dropdown menu's. They can only select an option by selecting the dropdown menu and use the arrows on the keyboard. We want them to be able to use the mouse to select an option in the dropdown.

We are using Ubuntu 14.04.1 with Mozilla Firefox 32.0.3.

Edit: In order to test this problem, I created a new virtual environment with the same session, but a new Firefox profile and no extensions. This gave exactly the same problem.

Modified by UnknownToYou

All Replies (2)

more options

What preferences have you locked? And are the websites with dropdown menus using javascript?

more options

At the moment I dont have any preferences locked. The site with the dropdowns are using javascript. But it is not only the dropdown on the site. But also the Firefox option buttons like opening the favorites menu or clicking the 'open menu' button are not working, even on a simple installation with only the desktop session as described above, so only starting Firefox.