Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is using internet explorer's home page after PC is restarted, even if I change it back, it happens everytime

  • 10 replies
  • 4 have this problem
  • 1386 views
  • Last reply by cor-el

more options

I am using my work's laptop. I have internet explorer which is required for our work's intranet related stuff and internet explorer uses our work's intranet home page. I also use firefox and like to use a different home page (ie bing, google, whatever...). So for work related stuff I use IE, for non-work web browsing I use firefox. Recently every time I reboot my PC and start up firefox, firefox uses my internet explorer (work intranet) homepage. I then easily reset it back to my preference (bing.com) and as long as the PC is on, if I close and open firefox it keeps bing.com as my home page. I could do this 20x over and it will keep bing.com as the home page. However when I shut down and restart the PC, firefox goes back to using the IE home page (work's intranet). Is there a permanent way to fix this. Our IT department was no help. A week before this started happening they did upgrade our computers to internet explorer 11. I tried resetting Firefox but that did not solve the problem.

Chosen solution

Hi nomeans, something is modifying or overwriting your prefs.js file.

Perhaps you can outsmart it by creating a user.js file. This file is read at Firefox startup and will override prefs.js. Basically it only needs one line, so you could open prefs.js in a text editor after you've corrected the homepage preference, use Save As to create user.js and then delete all the other lines and save/close.

More info on user.js: http://kb.mozillazine.org/User.js_file

Read this answer in context 👍 0

All Replies (10)

more options

I had a similar problem where all my browsers (IE, Chrome and Firefox) were opening to the same page, even though the home page remained set as I'd intended in the settings, and I could click on the home icon and the browsers would go to their designated home page. I went through everything, even the registry.

Turned out that when I went to the icons on the desk top (for me I keep them on the task bar) for the browsers, right clicked the icon, then negotiated the list to properties for that program, I found the url for the page that was opening tacked on to the target .exe file for the program. I simply deleted that added url and now everything works fine.

I'm not sure how it got there, probably some browser controlling PUP I'd removed (sometimes they get by Malwarebytes) but the removal had left that url behind when I'd uninstalled it. Just guessing.

more options

That was not the case for me. The properties target is a clean firefox.exe

more options

After your next Windows startup, before starting Firefox, could you check whether your prefs.js file shows that it has been updated just then (modified date/time) or looks like it might have been rolled back to before you last changed your home page?

As a shortcut to find that file, you can type or paste this in the Start menu search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

You might find only one semi-randomly-named folder there to click into, or multiple folders, in which case, try the most recently modified one.

The most logical timestamp would be when you last exited Firefox or when you changed any setting in Firefox. Anything suspicious?

To view the content of the prefs.js file, I suggest using right-click > Edit. (Double-clicking will execute the script, which is not a valid Windows script, so that's a dead end.) If you search for home, can you see whether user_pref("browser.startup.homepage" is still set to Bing or has changed to the unwanted page?

more options

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Jscher2000, thanks, I checked several times to make sure. After I set the homepage to bing, when I restart the computer, before I open firefox, I check the prefs.js file. In the file the homepage is set to my work's intranet website, not bing.com. After I open firefox and reset the homepage to bing.com, when I open prefs.js (firefox open or close) the homepage reads bing.com.

So this didnt solve the problem, but does answer your question.

For what its worth, the problem is not occuring with chrome. That homepage stays where ever I set it, even after restarting the computer.

more options

cor-el, My PC has ESET NOD32 Antivirus 4 and Shavlik Protect Agent. I removed Shavlic Protect Agent from the startup folder, but that did no good. The ESET NOD32 Antivirus has been on the PC for a long time and I cannot really change anything in there, its password protected by IT. This is a new problem anyway. I really suspect it has something to do with the upgrade to Internet Explorer 11, but I dont know.

more options

Chosen Solution

Hi nomeans, something is modifying or overwriting your prefs.js file.

Perhaps you can outsmart it by creating a user.js file. This file is read at Firefox startup and will override prefs.js. Basically it only needs one line, so you could open prefs.js in a text editor after you've corrected the homepage preference, use Save As to create user.js and then delete all the other lines and save/close.

More info on user.js: http://kb.mozillazine.org/User.js_file

more options

Jscher2000, That solved it!!! Thanks. But I did not delete all the other lines. I kept user.js the same as prefs.js just with the homepage set as bing.com. Do you see this as a problem?

Now just for some extra info: If I set my internet explorer homepage as google.com, when the computer restarts, internet explorer homepage automatically resets to the company's intranet homepage.

more options

Hi nomeans, I think there probably are some preferences in prefs.js that you will want to change later, for example, if you pin pages on the New Tab page or modify the selection/order of icons on the toolbar. Also, some preferences are for Firefox to maintain. So it would be best to only override the preference(s) you know you want to override.

Also, external software sometimes modifies the user.js file, so knowing what you added helps in figuring out what shouldn't be there.

Modified by jscher2000

more options

Note that you can't modify prefs set via user.js permanently. Changes made during a session, either on about:config or via the Option panel or otherwise, will be lost if you close and restart Firefox because Firefox will use the settings in user.js to override ches saved in prefs.js from the previous session. You can easily forget that you have such lines in the user.js file, so be careful with placing or leaving user_pref() lines in this file.

Modified by cor-el