X
Tap here to go to the mobile version of the site.

Support Forum

After I updated Firefox, the indicator bar in the scroll bar is missing.

Posted

The small bar in the scroll bar that indicates how far down the page you are is missing. Sometimes it appears when the page first loads, but vanishes if I click anywhere in the scroll bar (on the up or down arrows, on the indicator, or anywhere in the length of the bar.

The small bar in the scroll bar that indicates how far down the page you are is missing. Sometimes it appears when the page first loads, but vanishes if I click anywhere in the scroll bar (on the up or down arrows, on the indicator, or anywhere in the length of the bar.

Chosen solution

See also this bug report:

  • bug 1066934 - FF32: Skinned scrollbars thumb disappear upon scrolling a page at specific zoom percentage (different between FF themes)

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • 5.1.30514.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • DivX Plus Web Player version 2.3.1.51
  • DivX VOD Helper Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 32.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0.3/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Classic Compact Options 25.0 (notreal.ccoptions@environmentalchemistry.com)
  • Classic Theme Restorer 1.2.3 (ClassicThemeRestorer@ArisT2Noia4dev)
  • DownloadHelper 4.9.24 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Greasemonkey 2.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2021.112 (wrc@avast.com) (Inactive)
  • B-Folders 4 Firefox Extension 4.2.0 (b-folders-4@jointlogic) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Link Alert 1.0.2 (linkalert.conlan@addons.mozilla.com) (Inactive)
  • Power Twitter 2.02 ({b2509cd4-17cd-45ed-8146-a82af038f493}) (Inactive)
  • Xpnd.it! short URL expander 1.1a (xpndit@long-shore.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 210
  • adapterDescription2:
  • adapterDeviceID: 0x0a65
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-2-2014
  • driverDate2:
  • driverVersion: 9.18.13.4052
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage: https://www.google.com/voice/#inbox
  • browser.startup.homepage_override.buildID: 20140923175406
  • browser.startup.homepage_override.mstone: 32.0.3
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 32.0.3
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • general.useragent.extra.zencast:
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1411606569
  • places.history.expiration.transient_current_max_pages: 87193
  • places.last_vacuum: 1334185965
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml,application/x-shockwave-flash,application/futuresplash
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 4
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1410223380

Misc

  • User JS: Yes
  • Accessibility: No
David Tenser 30 solutions 310 answers

Helpful Reply

Hi there,

That sounds weird. Would you be able to provide a screenshot of what you're seeing? That might enable us to figure out what's going on with your Firefox.

Another approach that might solve the problem is to try to Reset Firefox: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems. It's a bit like killing a fly with a hammer, but it might do the trick.

Thanks!

- David

Hi there, That sounds weird. Would you be able to provide a screenshot of what you're seeing? That might enable us to figure out what's going on with your Firefox. Another approach that might solve the problem is to try to Reset Firefox: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems. It's a bit like killing a fly with a hammer, but it might do the trick. Thanks! - David

Question owner

It is weird. The page loads normally, as in the first image, with the scroll bar on the right, arrows at top and bottom, and the indicator bar in between, at the top. If I scroll the page, by clicking the down arrow, by attempting to move the indicator bar with the mouse, or by using the scroll button on the mouse, that indicator bar vanishes, as in the second image.

It's very inconvenient when I'm reading a long article or comments, because I can't tell where I am on the page.

It is weird. The page loads normally, as in the first image, with the scroll bar on the right, arrows at top and bottom, and the indicator bar in between, at the top. If I scroll the page, by clicking the down arrow, by attempting to move the indicator bar with the mouse, or by using the scroll button on the mouse, that indicator bar vanishes, as in the second image. It's very inconvenient when I'm reading a long article or comments, because I can't tell where I am on the page.

Question owner

Oh, and I might try the reset, but not right away -- I'm curious about the problem. I couldn't be the only person this happens to, but folks who don't use the scroll bar as much as I do might not notice right away.

Oh, and I might try the reset, but not right away -- I'm curious about the problem. I couldn't be the only person this happens to, but folks who don't use the scroll bar as much as I do might not notice right away.
cor-el
  • Top 10 Contributor
  • Moderator
16551 solutions 149426 answers

Chosen Solution

See also this bug report:

  • bug 1066934 - FF32: Skinned scrollbars thumb disappear upon scrolling a page at specific zoom percentage (different between FF themes)

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

See also this bug report: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1066934 bug 1066934] - FF32: Skinned scrollbars thumb disappear upon scrolling a page at specific zoom percentage (different between FF themes) <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>
FredMcD
  • Top 10 Contributor
3705 solutions 50986 answers

If you have a three button mouse, click the middle button to turn the mouse into a scroll controller.

If you have a three button mouse, click the middle button to turn the mouse into a scroll controller.

Question owner

That bug report is very interesting. Thinking back, I think this started in 32.0.2; when I updated to 32.0.3 I had hoped it would fix this. Comments on the bug report mention that bug happens at certain size(s) of a skinned, variably sized scroll bar. I do use a theme -- not sure if the scroll bar varies in size, but there is no change in the problem when I change the Firefox window size. I'll test dropping the theme.

That bug report is very interesting. Thinking back, I think this started in 32.0.2; when I updated to 32.0.3 I had hoped it would fix this. Comments on the bug report mention that bug happens at certain size(s) of a skinned, variably sized scroll bar. I do use a theme -- not sure if the scroll bar varies in size, but there is no change in the problem when I change the Firefox window size. I'll test dropping the theme.

Question owner

If I drop the theme, the problem goes away. But, it's definitely a Firefox bug -- the theme worked fine until 32.0.2 (and we all had to wait a good long time for the add-on folks to catch up to the new FF; I think they're swimming as fast as they can). I hope this gets fixed. I probably will just use Opera more, for the time being, rather than try to find a compatible skin in FF that looks decent and doesn't take up too much screen space. One of the great and useful things about FF has always been the broad array of functional add-ons, so I look forward to the fix.

Any other ideas are most welcome!

If I drop the theme, the problem goes away. But, it's definitely a Firefox bug -- the theme worked fine until 32.0.2 (and we all had to wait a good long time for the add-on folks to catch up to the new FF; I think they're swimming as fast as they can). I hope this gets fixed. I probably will just use Opera more, for the time being, rather than try to find a compatible skin in FF that looks decent and doesn't take up too much screen space. One of the great and useful things about FF has always been the broad array of functional add-ons, so I look forward to the fix. Any other ideas are most welcome!

Question owner

I notice one reply has been flagged "chosen solution", not by me. This problem has not been solved, however; we just have information that may explain the problem. Listing this as solved precludes further input on causes and possible fixes.

I hope this bug is fixed very soon. I will not be able to update Firefox on my other machines until there's a fix for the scrolling function. On the machine that is running 32.0.3, I will only be able to use Firefox for limited purposes, and cannot use it as my default browser. Please fix this bug ASAP. Thanks

I notice one reply has been flagged "chosen solution", not by me. This problem has not been solved, however; we just have information that may explain the problem. Listing this as solved precludes further input on causes and possible fixes. I hope this bug is fixed very soon. I will not be able to update Firefox on my other machines until there's a fix for the scrolling function. On the machine that is running 32.0.3, I will only be able to use Firefox for limited purposes, and cannot use it as my default browser. Please fix this bug ASAP. Thanks
FredMcD
  • Top 10 Contributor
3705 solutions 50986 answers

I notice one reply has been flagged "chosen solution", not by me.

It is possible you did without meaning to. Its the way the notice to your e-mail is set up. Go to the post flagged as Solved, and unflag it.


If I drop the theme, the problem goes away

Then the theme may be the cause. Some add-ons, plugins, themes just do not like each other. Also, some themes are not compatible with the current Firefox. Contact the writer of the theme.

''I notice one reply has been flagged "chosen solution", not by me.'' It is possible you did without meaning to. Its the way the notice to your e-mail is set up. Go to the post flagged as '''Solved,''' and unflag it. ''If I drop the theme, the problem goes away'' Then the theme may be the cause. Some add-ons, plugins, themes just do not like each other. Also, some themes are not compatible with the current Firefox. Contact the writer of the theme.
cor-el
  • Top 10 Contributor
  • Moderator
16551 solutions 149426 answers

Currently solutions have a tooltip set via the title attribute that shows who marked a reply as the solution.

<h3 class="is-solution" title="Solution chosen by the-edmeister"></h3>

This is a bug that is present in Firefox 32, so only when Firefox 33 gets released or you would install the current beta release then this issue is fixed (note that installing a beta version will get you to the beta release update channel).

This bug probably only occurs when you use a custom theme, so if you switch to the default theme then you shouldn't experience this as well.

Currently solutions have a tooltip set via the title attribute that shows who marked a reply as the solution. <pre><nowiki><h3 class="is-solution" title="Solution chosen by the-edmeister"></h3></nowiki></pre> This is a bug that is present in Firefox 32, so only when Firefox 33 gets released or you would install the current beta release then this issue is fixed (note that installing a beta version will get you to the beta release update channel). *https://www.mozilla.org/en-US/firefox/beta/ This bug probably only occurs when you use a custom theme, so if you switch to the default theme then you shouldn't experience this as well.