Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

continual compatibility screen + Theme & Font Changer e.t.c. (since last FF update)

  • 4 replies
  • 1 has this problem
  • 115 views
  • Last reply by cor-el

more options

Hello all.

Hope someone can help as I have run out of ideas how to fix my problem? since updating to FF33 some add-ons IE the Theme & Font add on continually shows up,together with the compatibility screen,also the ebay sidebar add on? I have done all the usual restarting,emptying cookies,history e.t.c. but still there.

Have noticed in the past Theme & Font changer add on as being a bit of a nuisance to stop it showing,but never like it is now

best wishes Steve

Chosen solution

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

Read this answer in context 👍 0

All Replies (4)

more options

Hi spuroneman, I do not think that there is a compatibility mode in Firefox, but I am still learning, so I could be wrong. It is possible to turn off these add ons in the add ons menu.

If they are not there you can try a new profile or a Firefox reset, it will remove addons. Reset is done by going to the url about:support and clicking the Reset Firefox button.

more options

Hello Very good to hear from you,much appreciated. The compatibility screen comes on when FF updates to latest platform ,checking that your add-ons are compatible with new issue.

after at the last but one update,the compatibilty box comes up everytime I click on FF,and also the theme & font add on and the side bar for ebay. I have tried most things but they refuse to stop.

any further help appreciated

best wishes Steve

more options

Hi Steve, (rolling up the sleeves :-)) To make sure you are not clicking on the installer, do you have more than one icon of Firefox in your list of programs?

Do you have the latest version of the sidebar 3.15? Does this happen when it is disabled? Is the add on updated? You can check from the about:addons page and click on the update button on the top right.

I created a new profile in version 33 and added the ebay side bar and the theme and font changer. I added a change to the theme and restarted it in safe mode. The weird thing was that the background color stayed the custom color.

"Did you make sure that all check-boxes on the Compatibility tab of the Firefox desktop shortcut and the Firefox.exe file in the Firefox program folder are unchecked ?"

more options

Chosen Solution

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.